Posts by TobiasReich

    Ah alright, to everyone who has the same issue.

    There seems to be a known bug - and a work around for now.

    I followed this suggestion here:…rotate-restart-error.html

    And it seems to work for now.


    In short:

    Edit the service file, to add a retry.

    Open: /etc/init.d/proftpd

    Find this line:

    start-stop-daemon --stop --signal $SIGNAL --quiet --pidfile "$PIDFILE"

    Change to this:

    start-stop-daemon --stop --signal $SIGNAL --retry 1 --quiet --pidfile "$PIDFILE"


    I just had a look at my FTP logs and saw hundrets of messages that look like this

    Code - ProFTPD 1.3.6 (stable) built ... standalone mode Startup
    Starting ftp server: proftpd - ProFTPD killed (signal 15) - ProFTPD 1.3.6 standalone mode SHUTDOWN

    And then it begins again. All this within maybe 10-15 seconds.

    Am I missing something here? It looks like something is killing my FTP deamon but I have no clue what / why this might happen. Any idea where to look?


    Tobias Reich

    Okay I found a part of a solution.

    It seems the (Filezilla) client did not reuse SSL session and was rejecting the data connection.

    That was fixed by setting the parameter "No session reuse required (The requirement that the SSL session from the control connection is reused for data connections is not required.)" 

    In the control panel.

    Now the folder is shown almost correctly since the "root" folder is "/srv/ftp" now. I understand this is the normal behaviour and if I enter then "/Files" in FileZilla I can actually reach the folder I want the users to be in.

    But it is not shown nor is it the chosen root folder.

    Any idea how this can be achieved?

    I already tried setting

    DefaultRoot /srv/dev-disk-by-label-Data/Files
    DefaultChdir /srv/dev-disk-by-label-Data/Files

    in both "Settings" and "SSL/TLS" input fields and even other combinations like

    DefaultRoot /Files
    DefaultChdir /Files

    etc. but to no success!

    I tried with both.

    SFTP requires the ssh group to be set for the user so maybe that enables something I missed.

    However, if you mean the "Shares"-Option I set a shared folder there. This is the "Files" in the configuration. Still that doesn't change anything.

    FTPS doesn't work and SFTP shows the whole range of the file system.

    I installed OMV 5 fresh (with an old hard disk though) and I seem to have problems with the FTP server.

    From what I understand the login works fine but it appears as if the default folder is the root one.

    I therefore get an error message regarding the permissions:

    I try to connect locally in my LAN, no firewall configuration yet and - as mentioned - a fresh install.

    I also tried to set the default root folder in the advanced settings

    DefaultRoot /srv/dev-disk-by-label-Data/

    But with no success.

    The /etc/proftpd/proftpd.conf looks like this:

    Looks all fine to me so what am I missing?

    Thanks a lot!


    #### EDIT ####

    Looks like it works when I switch to SFTP. However the users can now traverse throught the whole filesystem. Before they saw only the shared folders. If there would be a way of changing this, I would also be fine with SFTP instead.

    Have you found a solution? I seem to have the same problem!

    It appears as if the default folder is root and the access is not permitted via ftp.

    However, I just can't change this!

    Okay, I have found out what happened.

    When logging in it was calling

    hostname -i

    which results in that error

    Name or service not known

    because even though my Hostname seemes to be OMV it wasnt correct. The hostname has the domain attached as suffix. So it was OMV.local instead. I have no Idea why or when that domain got attached but the difference of this to what was written in /etc/hosts seems to be the problem.

    I recently updated from OMV 4 to OMV 5 but it seems something went wrong.

    I used that "guide" here:

    RE: OMV 5.0 - finally out! :-)

    however, when I start the web access panel I can't login anymore.

    I get the Login screen but when I proceed I get an error alert stating:


    Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C.UTF-8; hostname --fqdn 2>&1' with exit code '1': hostname: Name or service not known

    With the details like that

    Does anyone have any idea what happened there? I tried to reset things via the omv-firstaid but did not succeed.

    Thanks a lot!

    Well, the point is, I don't like having any third party have "access" to my data. Honestly I'm not sure how it works. But if they have access to my music or movies, what else do they have.
    I wanted this NAS as a storage for me and my family. So there are private data on it.
    I guess my concern is not only creating a (paid) account but also in more general that I have no idea what this server does.
    I saw them indexing my files (which seems okay so far) but also some services of downloading album art or generating previews etc.
    After all, what I only want is a simple media player. As mentioned earlier, we used our old NAS via SMB / CIFS. So family members were up/downloading directly. Now I was hoping for something a bit more comfortable like a browser related service. I'd be even happy about a simple page with a VLC plugin showing files instead of downloading them with the Windows Explorer or what ever...

    TL;DR Are there any privacy related topics. I just don't trust the Plex server since I see the service running, reading and writing on my disk...

    Hello everyone!

    I'm new here so please excuse my question but I couldn't find any answer to this yet.

    I wanted to install a "media server" on my OMV 3. I still know Kodi from my Raspberry Pi and I assumed the Plex Mediaserver would be somewhat similar.
    Everything worked fine with the installation and when I opened it in the browser, I was able to see the web interface with it's configuration panel etc.
    However this worked only hen blocking the java script for "".
    The moment I don't block that script, I get forwarded directly to a plex page that tells me

    "Plex Web would like to sign in to your Plex account"

    However I can't register there (there is a Facebook Login but it's not working). And honestly that doesn't seem to be what I want anyway. I don't want something like internet TV. Especially not with any paid "Plex Pass" account or what ever.
    All I want is to use it locally on my own as I did before via Kodi (or even CIFS / SMB with the VLC connected via LAN).

    So could anyone please tell me what am I missing? Is this a paid feature only? Do I have to configure something specifically if I use it only in my home network?

    Thanks for your help,