Posts by rdmATX

    This is one I can't decipher even after looking here: General and other Fora locations.



    This is a replay of the various errors I get when trying to create, delete, unmount, mount drives:

    VIDEO LINK OVERVIEW

    Code
    Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C.UTF-8; omv-salt deploy run --no-color fstab 2>&1' with exit code '1': debian: ---------- ID: create_filesystem_mountpoint_5491bfd4-da55-4618-8d1d-8b113294670a Function: file.accumulated Result: True Comment: Accumulator create_filesystem_mountpoint_5491bfd4-da55-4618-8d1d-8b113294670a for file /etc/fstab was charged by text Started: 18:13:39.389508 Duration: 2.119 ms Changes: ---------- ID: mount_filesystem_mountpoint_5491bfd4-da55-4618-8d1d-8b113294670a Function: mount.mounted Name: /srv/dev-disk-by-label-General3 Result: True Comment: Target was already mounted Started: 18:13:39.393056 Duration: 143.304 ms Changes: ---------- umount: Forced remount because options (user_xattr) changed ---------- ID: create_filesystem_mountpoint_676fe565-f398-4fda-a99b-eefa93cc7462 Function: file.accumulated Result: True Comment: Accumulator create_filesystem_mountpoint_676fe565-f398-4fda-a99b-eefa93cc7462 for file /etc/fstab was charged by text Started: 18:13:39.536742 Duration: 2.054 ms Changes: ---------- ID: mount_filesystem_mountpoint_676fe565-f398-4fda-a99b-eefa93cc7462 Function: mount.mounted Name: /srv/dev-disk-by-label-West Result: True Comment: Target was already mounted Started: 18:13:39.539152 Duration: 97.55 ms Changes: ---------- umount: Forced remount because options (user_xattr) changed ---------- ID: create_filesystem_mountpoint_a6ab3e26-5b1f-4aab-af98-130aab536433 Function: file.accumulated Result: True Comment: Accumulator create_filesystem_mountpoint_a6ab3e26-5b1f-4aab-af98-130aab536433 for file /etc/fstab was charged by text Started: 18:13:39.637173 Duration: 2.074 ms Changes: ---------- ID: mount_filesystem_mountpoint_a6ab3e26-5b1f-4aab-af98-130aab536433 Function: mount.mounted Name: /srv/dev-disk-by-label-Central100 Result: True Comment: Target was already mounted Started: 18:13:39.639517 Duration: 98.052 ms Changes: ---------- umount: Forced remount because options (user_xattr) changed ---------- ID: create_filesystem_mountpoint_48b7f432-18ae-43b4-b89d-5c24f6b316db Function: file.accumulated Result: True Comment: Accumulator create_filesystem_mountpoint_48b7f432-18ae-43b4-b89d-5c24f6b316db for file /etc/fstab was charged by text Started: 18:13:39.738494 Duration: 4.369 ms Changes: ---------- ID: mount_filesystem_mountpoint_48b7f432-18ae-43b4-b89d-5c24f6b316db Function: mount.mounted Name: /srv/dev-disk-by-label-East500 Result: True Comment: Target was already mounted Started: 18:13:39.743374 Duration: 116.101 ms Changes: ---------- umount: Forced remount because options (user_xattr) changed ---------- ID: create_filesystem_mountpoint_3b9395ab-aa22-4774-8749-4999e746d25d Function: file.accumulated Result: True Comment: Accumulator create_filesystem_mountpoint_3b9395ab-aa22-4774-8749-4999e746d25d for file /etc/fstab was charged by text Started: 18:13:39.863969 Duration: 4.165 ms Changes: ---------- ID: mount_filesystem_mountpoint_3b9395ab-aa22-4774-8749-4999e746d25d Function: mount.mounted Name: /srv/dev-disk-by-id-usb-SABRENT_DISK00_J2180053HDWYJC-0-0 Result: False Comment: mount: /srv/dev-disk-by-id-usb-SABRENT_DISK00_J2180053HDWYJC-0-0: /dev/sdc already mounted or mount point busy. Started: 18:13:39.868691 Duration: 59.783 ms Changes: ---------- ID: create_filesystem_mountpoint_b2124404-4a96-496f-b2d8-0c626ec3dfbf Function: file.accumulated Result: True Comment: Accumulator create_filesystem_mountpoint_b2124404-4a96-496f-b2d8-0c626ec3dfbf for file /etc/fstab was charged by text Started: 18:13:39.929066 Duration: 2.251 ms Changes: ---------- ID: mount_filesystem_mountpoint_b2124404-4a96-496f-b2d8-0c626ec3dfbf Function: mount.mounted Name: /srv/dev-disk-by-id-usb-SABRENT_DISK02_91CRCGGAT-0-2 Result: False Comment: mount: /srv/dev-disk-by-id-usb-SABRENT_DISK02_91CRCGGAT-0-2: /dev/sdh already mounted or mount point busy. Started: 18:13:39.931588 Duration: 56.705 ms Changes: ---------- ID: append_fstab_entries Function: file.blockreplace Name: /etc/fstab Result: True Comment: No changes needed to be made Started: 18:13:39.992449 Duration: 12.716 ms Changes: Summary for debian ------------- Succeeded: 11 (changed=4) Failed: 2 ------------- Total states run: 13 Total run time: 601.243 ms

    I can't seem to figure out how to diagnose correctly, and obviously don't want to lose data.


    My system: Linux omv5.atx.com 5.10.0-0.bpo.7-amd64 #1 SMP Debian 5.10.40-1~bpo10+1 (2021-06-04) x86_64 GNU/Linux

    Issues with the following drives

    Code
    /dev/sde1       3.6T  1.4T  2.3T  38% /srv/dev-disk-by-label-General3.   # this in particular
    /dev/sdc1       117G   61M  117G   1% /srv/dev-disk-by-label-Central100
    /dev/sdb1       586G  2.0G  584G   1% /srv/dev-disk-by-label-East500
    /dev/sdd1       458G  482M  457G   1% /srv/dev-disk-by-label-West

    At this point, I get a similar array of error messages when I try to stop/start NFS:

    Code
    The configuration has been changed. You must apply the changes in order for them to take effect.
     omv5.atx.com
    
    Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C.UTF-8; omv-salt deploy run --no-color nfs 2>&1' with exit code '1': debian: ---------- ID: configure_default_nfs-kernel-server Function: file.managed Name: /etc/default/nfs-kernel-server Result: True Comment: File /etc/default/nfs-kernel-server is in the correct state Started: 19:00:18.378722 Duration: 67.422 ms Changes: ---------- ID: configure_nfsd_exports Function: file.managed Name: /etc/exports Result: True Comment: File /etc/exports is in the correct state Started: 19:00:18.446371 Duration: 56.747 ms Changes: ---------- ID: start_rpc_statd_service Function: service.running Name: rpc-statd Result: True Comment: The service rpc-statd is already running Started: 19:00:18.530872 Duration: 58.788 ms Changes: ---------- ID: start_nfs_kernel_server_service Function: service.running Name: nfs-kernel-server Result: False Comment: Job for nfs-server.service canceled. Started: 19:00:18.591496 Duration: 165.592 ms Changes: Summary for debian ------------ Succeeded: 3 Failed: 1 ------------ Total states run: 4 Total run time: 348.549 ms

    I should mention, that I tried to follow this Reddit link, but I got similar errors..

    I can open all my dockers, but can't open the omv5 webgui directly. #It seems I miraculously fixed this sh*tshow...just posting for confirmation and "next steps"....thanks in advance.


    Code
    First error was getting the /var/log/nginx/openmediavault-webgui_error.log error: 2021/06/25 00:40:48 [error] 7207#7207: *1 directory index of "/var/www/openmediavault/" is forbidden, client: ::ffff:127.0.0.1, server: openmediavault-webgui, request: "GET / HTTP/1.1", host: "127.0.0.1"

    I looked here: forbidden

    I looked here: Team

    - tried to reinstall and failed with internal errors

    ran and apt update/upgrade command and got:

    Code
    I tried this: dpkg --configure -a # same error as above.

    ran apt remove lvm2 and this happened:

    Code
    Do you want to continue? [Y/n] Y
    (Reading database ... 100202 files and directories currently installed.)
    Removing openmediavault (5.6.10-1) ...
    Removing lvm2 (2.03.02-3) ...
    Code
    Now back to this: apt-get install openmediavault
    Code
    That generated similar errors. I couldn't just do the same steps as above, but following an "askubuntu" forum, I needed to rm -rf /etc/lvm2 and rm -rf /etc/lvm    

    Then I did an apt purge of the same:

    This worked, finally:

    Code
    root@omv5:/etc# apt-get install --reinstall openmediavault

    And surprise... I can now see the webgui!! (whew). Only thing missing now is omv5 extras--- all my dockers are working! (??)

    successfully ran:

    Code
    wget -O - https://github.com/OpenMediaVault-Plugin-Developers/packages/raw/master/install | bash

    And bingo I see everything I'm supposed to see there...finally was able to manage Portainer, etc...

    I think my installation had been broken for a while, as any upgrade from terminal or webgui gave some errors.. My system feels 100% clean. I am sorry for all the output, but this might help someone else who borked their system.

    My OMV5 upgrade is still not peachy. I'm considering rebuilding OMV5 from a fresh build, In doing that, can I safely detach storage drives during rebuild and then reattach with data intact? Is there a recommendation on this?

    This is related to the File System menu. Any idea how to address this?


    Code
    Error #0:
    OMV\Config\DatabaseException: Failed to execute XPath query '//system/fstab/mntent[uuid='2c8921f5-e052-4bf3-9264-77a4af82372d']'. in /usr/share/php/openmediavault/config/database.inc:78
    Stack trace:
    #0 /usr/share/openmediavault/engined/rpc/sharemgmt.inc(233): OMV\Config\Database->get('conf.system.fil...', '2c8921f5-e052-4...')
    #1 [internal function]: Engined\Rpc\ShareMgmt->get(Array, Array)
    #2 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)
    #3 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('get', Array, Array)
    #4 /usr/sbin/omv-engined(537): OMV\Rpc\Rpc::call('ShareMgmt', 'get', Array, Array, 1)
    #5 {main}

    ryecoaaron This is what I see:

    Code
    root@omv5:~# dpkg -l | grep -E "merg|openm|omv"
    ii  mergerfs                                  2.28.3~debian-buster                amd64        another FUSE union filesystem
    ii  omvextras-unionbackend                    5.0.2                               all          union filesystems backend plugin for openmediavault
    ii  openmediavault                            5.3.7-1                             all          openmediavault - The open network attached storage solution
    ii  openmediavault-apttool                    3.6                                 all          apt tool plugin for OpenMediaVault.
    ii  openmediavault-backup                     5.1                                 all          backup plugin for OpenMediaVault.
    ii  openmediavault-fail2ban                   5.0.4                               all          OpenMediaVault Fail2ban plugin
    ii  openmediavault-keyring                    1.0                                 all          GnuPG archive keys of the OpenMediaVault archive
    ii  openmediavault-omvextrasorg               5.2.5                               all          OMV-Extras.org Package Repositories for OpenMediaVault
    ii  openmediavault-unionfilesystems           5.1.1                               all          Union filesystems plugin for OpenMediaVault.

    Correction, this error is when I look at the shared folders menu:


    I guess I still have one final issue to get back to level ground.. I have NFS shares, when I attempt to mount from an ESXI test host, it mounts to a directory NOT in /srv/ but rather in /export/



    I still never see anything in "Filesystem" other than a "Loading" message, so I can't figure on where that is failing. Added syslog which I think is relevant. In either case, when I tried to delete and recreate the NFS, I got the error (also attached as error.txt), so I rolled the config back to where I am.




    Files

    • error.txt

      (6.39 kB, downloaded 162 times, last: )
    • syslog.txt

      (1.68 kB, downloaded 257 times, last: )

    outstanding!! (kiss the ground). Yes. All good. Now I can sanely rebuild by dockers, as I don't think they ported. Thank you again. love the improved forum. I'm glad I was patient.

    ryecoaaron I do see all in /srv/.

    Here is what is happening:

    I had followed the upgrades, fixed the nginx issue and now cannot see filesystem nor SMB. Attaching logs. Did this process wipe my (yes I know, backup) files? I don't think it did, but I don't see, except that when I "df -h" I see Used space. I'm kinda stuck and don't know if I can go forward, or if there is a way to "safely" rollback to v4...but as a validated Linux/Omv noob, I do need help.


    Files

    • syslog.txt

      (39.36 kB, downloaded 159 times, last: )

    I have purged php7.0*


    I get this:
    root@omv5:~# php --version
    PHP 7.3.14-1~deb10u1 (cli) (built: Feb 16 2020 15:07:23) ( NTS )
    Copyright (c) 1997-2018 The PHP Group
    Zend Engine v3.3.14, Copyright (c) 1998-2018 Zend Technologies
    with Zend OPcache v7.3.14-1~deb10u1, Copyright (c) 1999-2018, by Zend Technologies



    now, however, I am getting a 502 Nginx Bad Gateway error. I cleared the cache, tried to reopen, but to no effect.







    -- also note from the upgrade scripts:
    root@omv5:~# sed -i "/[Dd]ocker/d" /etc/apt/sources.list.d/omv-extras-org.list
    sed: can't read /etc/apt/sources.list.d/omv-extras-org.list: No such file or directory

    dpkg -l | grep php :

    Ok, good. So the shared folders are all there and mapped correctly---thank you. Finally, I have a question about the "FIle System" button just above UnionFS, as that screen just keeps spinning "Loading". Is there something I need to go back and install?


    This seems to be affecting smb and network shares accessibility. That is to say that the paths are there, but everything appears inaccessible.