Posts by blindguy

    On board NIC. Here is computer info:


    zed
    description: Desktop Computer
    product: MS-7641
    vendor: MSI
    version: 3.0
    serial: To Be Filled By O.E.M.
    width: 64 bits
    capabilities: smbios-2.6 dmi-2.6 vsyscall64 vsyscall32
    configuration: boot=normal chassis=desktop uuid=00000000-0000-0000-0000-8C89A55DA076
    *-core
    description: Motherboard
    product: 760GM-P23(FX) (MS-7641)
    vendor: MSI
    physical id: 0
    version: 3.0
    serial: To be filled by O.E.M.
    slot: To Be Filled By O.E.M.
    *-firmware
    description: BIOS
    vendor: American Megatrends Inc.
    physical id: 0
    version: V17.9 (03/23/2012)
    size: 64KiB
    capacity: 1984KiB
    capabilities: isa pci pnp apm upgrade shadowing escd cdboot bootselect socketedrom edd int13floppy1200 int13floppy720 int13floppy2880 int5printscreen int9keyboard int14serial int17printer int10video acpi usb ls120boot zipboot biosbootspecification
    *-cpu
    description: CPU
    product: AMD FX(tm)-4100 Quad-Core Processor
    vendor: Advanced Micro Devices [AMD]
    physical id: 4
    bus info: cpu@0
    version: AMD FX(tm)-4100 Quad-Core Processor
    serial: To Be Filled By O.E.M.
    slot: CPU1
    size: 3600MHz
    capacity: 3600MHz
    width: 64 bits
    clock: 200MHz
    capabilities: fpu fpu_exception wp vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt pdpe1gb rdtscp x86-64 constant_tsc nonstop_tsc extd_apicid pni pclmulqdq monitor ssse3 cx16 sse4_1 sse4_2 popcnt aes xsave avx lahf_lm cmp_legacy svm extapic cr8_legacy abm sse4a misalignsse 3dnowprefetch osvw ibs xop skinit wdt nodeid_msr arat


    *-network
    description: Ethernet interface
    product: RTL8111/8168B PCI Express Gigabit Ethernet controller
    vendor: Realtek Semiconductor Co., Ltd.
    physical id: 0
    bus info: pci@0000:02:00.0
    logical name: eth0
    version: 06
    serial: XX
    size: 1GB/s
    capacity: 1GB/s
    width: 64 bits
    clock: 33MHz
    capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
    configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=N/A ip=192.168.1.254 latency=0 link=yes multicast=yes port=MII speed=1GB/s
    resources: irq:25 ioport:e800(size=256) memory:fdfff000-fdffffff(prefetchable) memory:fdff8000-fdffbfff(prefetchable)

    Hello, I seem to be losing network communication after an unknown amount of time and then in order to resolve I have to go to the physical console and do a ifdown eth0 and then a ifup eth0.


    I know this sounds a bit vague but I can provide any log files that you guys request.


    Running the latest .5 OMV on a AMD64 with 8GB or RAM. I only the VirtualBox plugin and Plex plugin on the main box and then like 4-5 VM's with stuff inside them.

    Quote from "jhmiller"

    I don't know if you use newznab sites but if you or anyone else who uses XDM do then you can now leave auto comments on those sites after I fixed a but in their code :D


    Thanks to you script I'm running my own newznab site and I got in on one or two more and I love playing with new features!! Thanks again for this wonderful script!

    I am still unable to get XDM working, all I get is the following error:


    root@test:/djz/XDM# python2.7 XDM.py
    Traceback (most recent call last):
    File "XDM.py", line 54, in <module>
    from xdm import init, helper, actionManager
    File "/djz/XDM/xdm/init.py", line 25, in <module>
    from classes import *
    File "/djz/XDM/xdm/classes.py", line 28, in <module>
    from xdm import common, helper, profileMeMaybe
    File "/djz/XDM/xdm/helper.py", line 39, in <module>
    from babel.dates import format_timedelta
    ImportError: cannot import name format_timedelta


    Do I have to create a database with some other tools before I use it? I tried googling the error and that not a lot of help.


    Someone else had said that they didn't install pysqlite3 in the proper location and I haven't figured out how to change that either. Any assistance is appreciated.

    Quote from "jab2004"

    Sorted my problem out found that for some reason pysqlite3 wasn't in the lib folder when python2.7 was built i have uninstalled python2.7 compiled pysqlite3 and put it in the correct location then reinstalled python2.7 using the script again and everything appears to be working correctly


    Thanks for the assistance


    I'm having almost the same problem.


    root@app01:/djz/XDM# /usr/bin/python2.7 XDM.py
    Traceback (most recent call last):
    File "XDM.py", line 53, in <module>
    import xdm
    File "/djz/XDM/xdm/__init__.py", line 23, in <module>
    from peewee import *
    File "/djz/XDM/site-packages/peewee.py", line 51, in <module>
    raise ImproperlyConfigured('Either sqlite3, psycopg2 or MySQLdb must be installed')
    peewee.ImproperlyConfigured: Either sqlite3, psycopg2 or MySQLdb must be installed


    When you say you made sure to install pysqlite3 and put it in the proper location, can you please explain where the proper folder is and how to install it there? Thanks in advance.


    I upgraded to OMV 5 and have this same exact problem. I removed the 4.js files that I had in /var/www/openmediavault/js/omv/module/ but am still getting:


    Error #0:
    exception 'Exception' with message 'Failed to open file js/omv/NavigationPanel.js.' in /usr/share/php/openmediavault/htmlpage.inc:42
    Stack trace:
    #0 /usr/share/php/openmediavault/htmlpage.inc(49): OMVHtmlPage->scanFiles('js/omv/Navigati...', Array)
    #1 /usr/share/php/openmediavault/htmlpage.inc(70): OMVHtmlPage->scanFiles('js/omv/module/a...', Array)
    #2 /usr/share/php/openmediavault/htmlpage.inc(186): OMVHtmlPage->scanDir('js/omv/module/a...', Array, true)
    #3 /usr/share/php/openmediavault/htmlpage.inc(112): OMVWebGui->getJavascriptIncludes()
    #4 /var/www/openmediavault/index.php(37): OMVHtmlPage->render()
    #5 {main}



    Any thoughts?


    EDIT:
    I found the unofficial script at http://forums.openmediavault.org/viewtopic.php?f=3&t=2262 and that got me back up and running.

    I love your script it workes perfectly!! I would like to ask/suggest an addition. My OMV box sits at about 5%-10% CPU usage and I would like to set it up to contribute to the Folding@home project but I can't seem to install the current version for debian on my OMV box. Would it be possible for you to add that to your script?

    Quote from "jhmiller"


    The Apache module mod_rewrite is loaded even tho newznab wizard says it is not


    The MySQL error should not happen, try reinstalling to see if it fixes the issue. If not you may need to install a MySQL add-on manually.


    I tried uninstalling with the -14 but that didn't seem to do alo so i then deleted the folder and tried reinstalling and got the same error.

    when installing newznab i get some error when trying to se it up in the web interface.


    Checking for mysqli_connect():
    The PHP installation lacks support for MySQL(mysqli_connect).


    Checking for Apache's mod_rewrite:
    The Apache module mod_rewrite is not loaded. This module is required, please enable it if you are running Apache Warning



    any thoughts?