Posts by smandurlo

    I am getting a little bit crazy, help please!
    My setup:
    HP microserver N36L, OMV4, File System Union with 4 HDD ext4, NFS export with ro,subtree_check,insecure,no_acl


    Kodi 18 (but 17 was the same) on a FireTV Stick streaming files from the NFS share.


    When I start a video, after a couple of random seconds, the video stops and I return to the selection menu. I don't touch anything on the FireTV Stick nor in Kodi, I just reboot the OMV and when it returns online, I start again the play button and the video doesn't stop anymore. Then, when I watch another video hours later, I get again the video to stop again. Another OMV reboot fixes the problem.


    I didn't have this problem in the past, I did the same settings on my FireTV Stick and on OMV. I tried to reinstall from scratch omv in a new SSD, but I get the same problem.


    I am not a linux guru, I really don't know how to troubleshoot the problem. Any help will be very much appreciated!

    I solved the problem. So, for reference: I went to the shared folder, opened the ACL tab and removed the user "Felice". Root is write/read/execute, same for users and nothing for others. Replaced all the ACL, subdir included.


    This didn't fix the problem with Kodi, but at least made the ACL correct.


    To fix the kodi scraping, I added a "no_acl" into the NFS options near the insecure. So now it looks like subtree_check,insecure,no_acl


    Maybe it is not the best for security, but it is my lan only and it is to access movies and music, it doesn't need to be secure.

    Hello,
    Thanks for the amazing software. I have a weird problem and I narrowed it to the way files' attributes are written into my SMB shares.


    I am using OMV 4, ext4 file system with Filesystem Union as a big drive, SMB shares with Windows 10, NFS shares that all my Kodi devices read. The db is on mysql in OMV plugin.


    I can read and write to my SMB shares from windows and they actually are seen into the NFS shares, but something is missing with the attributes and Kodi devices don't update the libraries for that folder.


    I fond the problem. I add an image to show it better. Two different files, the one on the left is OK, kodi updates it. The one on the right has different security and kodi doesn't update it into the library. How to solve it?