Posts by drewgost

    Hi , big time screw up here. I was working from Windows Explorer organizing shared folders on my OMV, I deleted a file and did not notice I had a check in the box for a folder (elevators) hit delete and gone. is there a way to restore the folder from an external drive MyPassport connected with USB and backed up using USB Backup?


    thanks for any help


    Drew

    root@nas-dg:~# omv-release-upgrade
    Upgrading system to 4.0 (Arrakis) ...
    Ign file: InRelease
    Ign file: Release.gpg
    Ign file: Release
    Ign file: Translation-en
    Hit http://packages.openmediavault.org arrakis InRelease
    Hit http://packages.openmediavault.org arrakis/main amd64 Packages
    Ign http://packages.openmediavault.org arrakis/main Translation-en
    Reading package lists... Done
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Calculating upgrade... Done
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done

    Hi everyone this started and cant resolve it. simple command like /etc/passwd I get Permission denied
    logged in as root on PuTTY


    Also can't upgrade or get any Updates


    Thoughts?


    Thanks


    Drew

    Hi Rye I put it in in the way you said and yes it works I was following another thread to delete the spares=1 (which I did) due to keep getting email saying:


    This is an automatically generated mail message from mdadm running on nas-dg


    A SparesMissing event had been detected on md device /dev/md/NAS-**:Storage.


    Faithfully yours, etc.


    P.S. The /proc/mdstat file currently contains the following:


    Personalities : [raid6] [raid5] [raid4]
    md127 : active raid5 sdb[3] sdd[2] sdc[1]
    3907025920 blocks super 1.2 level 5, 512k chunk, algorithm 2 [3/3] [UUU]



    unused devices: <none>

    This post is copied from another area where I originally posted it to unintentionally:



    I log in through Putty as root. When I try to access the /etc/mdadm/mdadm.conf through Putty I get a "Permission denied"
    Any idea why root does not have access to that file.


    Thanks,


    Drew


    ryecoaaron responded with: Does it exist? What is the output of: ls -al /etc/mdadm/mdadm.conf


    I replied with: Hi Rye, Yes it does show it.


    root@nas-**:~# ls -al /etc/mdadm/mdadm.conf
    -rw-r--r-- 1 root root 873 Feb 25 14:43 /etc/mdadm/mdadm.conf

    I log in through Putty as root. When I try to access the /etc/mdadm/mdadm.conf through Putty I get a "Permission denied"
    Any idea why root does not have access to that file.


    Thanks,


    Drew

    Thanks macom


    I decided to go with 3.0.94 Erasmus new install, it went flawless and I did follow your thoughts on removing all data drives first. Next step will be to move on to 4.0 or maybe stick with this for awhile.

    After upgrade i cant get into Putty or the webgui
    Keeps saying connection refused?


    I have a ton of files on here should I just build a USB stick put 4.0 on it and install new? if so is there a complete article on steps to take to do that. Do i disconnect all drives for data first etc... thanks for your help


    Drew

    I get this message whenever I log into OMV, I also get it when I click on the "Apple Filing Services". Any thoughts would be great. Apple Filing services are not enabled


    Failed to get configuration (xpath=//services/afp)


    Error #3003: exception 'OMVException' with message 'Failed to get configuration (xpath=//services/afp)' in /usr/share/openmediavault/engined/rpc/afp.inc:65 Stack trace: #0 [internal function]: OMVRpcServiceAFP->getSettings(NULL, Array) #1 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array) #2 /usr/share/php/openmediavault/rpc.inc(79): OMVRpcServiceAbstract->callMethod('getSettings', NULL, Array) #3 /usr/sbin/omv-engined(500): OMVRpc::exec('AFP', 'getSettings', NULL, Array, 1) #4 {main}


    If I try to setup a share I get the following error after clicking Save: most likely due to not being able to turn on Apple Filing services


    Failed to set configuration
    Error #3002:exception 'OMVException' with message 'Failed to set configuration' in /usr/share/openmediavault/engined/rpc/afp.inc:297Stack trace:#0 [internal function]: OMVRpcServiceAFP->setShare(Array, Array)#1 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array)#2 /usr/share/php/openmediavault/rpc.inc(79): OMVRpcServiceAbstract->callMethod('setShare', Array, Array)#3 /usr/sbin/omv-engined(500): OMVRpc::exec('AFP', 'setShare', Array, Array, 1)#4 {main}

    So I logged into an alternative username and password and I get in but even though i know I have user in groups as root, adm, everything but it only list Access Right Management>User folder and a Information Folder.

    I was trying to uninstall Netatalk and came across an error ( E: Sub-process /usr/bin/dpkg returned an error code (1)), So i uninstalled Netatalk because it listed as the problem. Then I tried to install Netatalk 2.0 and got the error
    (Failed to get configuration (xpath=//services/afp))
    Any thoughts ?
    Thanks,
    drew