Posts by DiN0

    Hi,


    I want to do the same set up like yours.
    How do you use Omv LetsEncrypt plugin and LetsEncrypt Docker at the same time ?


    If you forward ports 443&80 from router to Docker, then what ports do use it for the LE plugin ?

    sorry for the late Answer,

    i bought an old house, so i had no time for OMV :)


    i think i didn't use OMV-LE-Plugin, just the docker. - but i can't check now, because system is offline due to moving...

    Hi,


    i have a problem to auto-renewing my LE-certificates.
    i get the following errors in /var/log/letsencrypt/letsencrypt.log


    i just edited the domain in the log to: my-domain.de
    my Domain is hosted @https://www.serverprofis.de/ and my-domain.de is an A-Record



    [EDIT]


    After modifying my LE-docker, OMV kicked my LE-docker-conf...
    so i had to make a new setup - thatswhy i actually have new cert's


    but i think i found the problem, i located my domain (without subdomain) directly to Heimdall @Port 80 - i think thatswhy i got the connection problems

    so,
    i found a solution.


    when i do all the tasks without the ENV "SUBDOMAINS", just with the "URL" - then it works!
    after first start of Docker with created cert, i can add "SUBDOMANS" - and now i can use it.


    thanks @Morlan for your hints by PM.


    INFO:
    i bought a TLD @ https://www.serverprofis.de , 5€/year - here you cann edit the ip for Domain/Subdomains - also possible by DDNS Tools / URL-Update / Fritzbox etc.
    Script to Updateseveral Domains / Subdomains by curl: CURL - DDNS-Update-Script

    If you are not getting a cert the reverse proxy also wont work.
    Is dynvpn a dyndns provider?

    Yes, it is. [https://www.twodns.de]


    With the OMV-Letsencrypt-Plugins i'm able to create a working certificate immediately, working with OMV-Webinterface.
    But i dont know how to use this with subdomain or /folder with my Docker-Apps... So i'm trying Letsencrypt-Docker...


    Gesendet von meinem SM-G973F mit Tapatalk

    no, i think because there is no server running ??? - and validation=http ...thatswhy it can't do it with my Domain.
    as i startet an extra http-server, i came to this point:


    but actually:

    Hi,


    i'm looking like a Photogallery-software with auto tagging.


    I sync my Photos from my Smartphone with Nextclound on my OMV4-NAS.
    No i'm looking for a software which i can use like google photos:

    • show all pictures
    • auto tag fotos:
    • sort by things: faces, persons, animals, cars, mountains, boats, skiing, cycling, ...
    • sort by places


    Synology also includes such features with deep-learning in Diskstations: Synology - Moments


    does anyone know such a photo-server?



    [EDIT]
    nearest tool i found: ownphotos


    very interesting project, not ready yet - release will be in 2019: PhotoPrism | PhotoPrism-github

    ok, i solved it by manual NC upgrade


    1. stopped Docker
    2. manual NC upgrade (https://docs.nextcloud.com/ser…nance/manual_upgrade.html)
    3. solved some DB-Problems (https://intux.de/2018/12/fehlermeldungen-in-nextcloud-15/)

    Code
    # open Docker bash
    docker exec -it nextcloud bash
    #add missing DB indices
    sudo -u abc php7 /config/www/nextcloud/occ db:add-missing-indices
    #convert filecache to bigint
    sudo -u abc php7 /config/www/nextcloud/occ db:convert-filecache-bigint

    and finaly i can access the "Overviewpage" again. Hope it will also work after next Letsencrypt renewal.

    Hi!


    First at all, thanks for the great tutorials!


    Last year i set up my Nextcloud with Letsencrypt in Docker on my OMV4 installation.


    Everything works great! Including OnlyOffice integration.


    Now i have the problem that my Nextcloud and the Letsencrypt-cert works while normal use of Nextcloud. (After my OMV4-PC was not used for 1-2 month i powered on my OMV4 again, and i think the LE-certificate was renewed automatically)




    I can use my NC-installation, but i tried to update my Nextcloud by using webupdater (NC à Admin àsettings à overview) and it failed with the following error:


    Docker-Network-Adapters:


    End-of-NC.error.log:

    Bash: error.log
    2019/02/05 12:26:24 [error] 311#311: *622 FastCGI sent in stderr: "PHP message: {"reqId":"FMbIm2LlzoEOLGDPk44i","level":3,"time":"2019-02-05T11:26:24+00:00","remoteAddr":"172.20.0.3","user":"test_user","app":"PHP","method":"GET","url":"\/index.php\/apps\/files\/","message":"count(): Parameter must be an array or an object that implements Countable at \/config\/www\/nextcloud\/apps\/onlyoffice\/lib\/appconfig.php#477","userAgent":"Mozilla\/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit\/537.36 (KHTML, like Gecko) Chrome\/72.0.3626.81 Safari\/537.36","version":"14.0.3.0"}" while reading response header from upstream, client: 172.20.0.3, server: _, request: "GET /index.php/apps/files/ HTTP/1.1", upstream: "fastcgi://127.0.0.1:9000", host: "domain_changed_for_log.dynvpn.de:443"
    2019/02/05 12:26:24 [error] 311#311: *622 FastCGI sent in stderr: "PHP message: {"reqId":"FMbIm2LlzoEOLGDPk44i","level":3,"time":"2019-02-05T11:26:24+00:00","remoteAddr":"172.20.0.3","user":"test_user","app":"PHP","method":"GET","url":"\/index.php\/apps\/files\/","message":"fopen(\/data\/nextcloud.log): failed to open stream: Permission denied at \/config\/www\/nextcloud\/lib\/private\/Log\/File.php#136","userAgent":"Mozilla\/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit\/537.36 (KHTML, like Gecko) Chrome\/72.0.3626.81 Safari\/537.36","version":"14.0.3.0"}" while reading upstream, client: 172.20.0.3, server: _, request: "GET /index.php/apps/files/ HTTP/1.1", upstream: "fastcgi://127.0.0.1:9000", host: "domain_changed_for_log.dynvpn.de:443"
    2019/02/05 12:26:31 [error] 311#311: *654 FastCGI sent in stderr: "PHP message: {"reqId":"VEGKWRkCrhzjSMCjDkZU","level":3,"time":"2019-02-05T11:26:31+00:00","remoteAddr":"172.20.0.3","user":"test_user","app":"index","method":"GET","url":"\/index.php\/settings\/admin\/overview","message":{"Exception":"TypeError","Message":"Argument 1 passed to GuzzleHttp\\Exception\\RequestException::create() must be an instance of GuzzleHttp\\Message\\RequestInterface, instance of GuzzleHttp\\Psr7\\Request given, called in \/config\/www\/nextcloud\/3rdparty\/guzzlehttp\/guzzle\/src\/Middleware.php on line 65","Code":0,"Trace":[{"file":"\/config\/www\/nextcloud\/3rdparty\/guzzlehttp\/guzzle\/src\/Middleware.php","line":65,"function":"create","class":"GuzzleHttp\\Exception\\RequestException","type":"::","args":[{"__class__":"GuzzleHttp\\Psr7\\Request"},"*** sensitive parameter replaced ***"]},{"file":"\/config\/www\/nextcloud\/3rdparty\/guzzlehttp\/promises\/src\/Promise.php","line":203,"function":"GuzzleHttp\\{closure}","class":"GuzzleHttp\\Middleware","type":"::","args":["*** sensitive parame" while reading response header from upstream, client: 172.20.0.3, server: _, request: "GET /index.php/settings/admin/overview HTTP/1.1", upstream: "fastcgi://127.0.0.1:9000", host: "domain_changed_for_log.dynvpn.de:443"
    2019/02/05 12:26:32 [error] 311#311: *664 FastCGI sent in stderr: "PHP message: {"reqId":"EJqG40W7eViKlyhtFnfm","level":3,"time":"2019-02-05T11:26:32+00:00","remoteAddr":"172.20.0.3","user":"test_user","app":"PHP","method":"GET","url":"\/index.php\/apps\/files\/","message":"count(): Parameter must be an array or an object that implements Countable at \/config\/www\/nextcloud\/apps\/onlyoffice\/lib\/appconfig.php#477","userAgent":"Mozilla\/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit\/537.36 (KHTML, like Gecko) Chrome\/72.0.3626.81 Safari\/537.36","version":"14.0.3.0"}" while reading response header from upstream, client: 172.20.0.3, server: _, request: "GET /index.php/apps/files/ HTTP/1.1", upstream: "fastcgi://127.0.0.1:9000", host: "domain_changed_for_log.dynvpn.de:443"
    2019/02/05 12:26:32 [error] 311#311: *664 FastCGI sent in stderr: "PHP message: {"reqId":"EJqG40W7eViKlyhtFnfm","level":3,"time":"2019-02-05T11:26:32+00:00","remoteAddr":"172.20.0.3","user":"test_user","app":"PHP","method":"GET","url":"\/index.php\/apps\/files\/","message":"fopen(\/data\/nextcloud.log): failed to open stream: Permission denied at \/config\/www\/nextcloud\/lib\/private\/Log\/File.php#136","userAgent":"Mozilla\/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit\/537.36 (KHTML, like Gecko) Chrome\/72.0.3626.81 Safari\/537.36","version":"14.0.3.0"}" while reading upstream, client: 172.20.0.3, server: _, request: "GET /index.php/apps/files/ HTTP/1.1", upstream: "fastcgi://127.0.0.1:9000", host: "domain_changed_for_log.dynvpn.de:443"


    Someone had this error or knows how to resolve?



    Best regards,
    Christian

    HeyHo,


    yesterday i tried to install an realtek_8111.deb (not full name) from 2016 - after this it worked with Kernel 4.18.0-0.bpo.1-amd64 --> reboot --> LAN, YEAH 8o


    then i tried updating through omv-web-ui Kernel 4.19...and realtek-firmware --> reboot, no LAN
    --> started with 4.18.0-0.bpo.1-amd64 --> working.


    in my case, i think the following update was/is the problem:


    firmware-realtek 20180825+dfsg-1~bpo9+1
    Binary firmware for Realtek wired/wifi/BT adapters



    so, actually i'm happy.
    can i forbid / blacklist this update ?


    [EDIT]
    found!


    apt-mark hold firmware-realtek

    Hi,I'm in trouble with my OMV4 installation.
    I did an update of my installiation via OMV-web-gui.


    actual Kernel: 4.18.0-0.bpo.3-amd64


    Problem after reboot: No network interface(s) available


    Hardware: Asrock J4105-ITX with Onboard Realtek


    last year i had some trouble with this Adapter - sometimes after wakeup by WOL there was no network, so i blacklisted the R8169 and installed R8168 (tutorial: link)
    sorry pictures - because of network Problem...

    lspci:


    iplink show:


    the next problem: i can't add an usb device to install firmware / driver / ...
    output:


    i tried to add Realtek RTL8111/RTL8168 firmware with following Result: --> kernel-header-Problem


    how can i handle this - i tried to add an RTL2800 wifi Stick to handle this - without sucess
    has anyone an idea how to solve this Problem, i have to much Docker-installations on this machine to make a new setup