Posts by Thoughtfission

    Hi,


    My OMV is up and running on my raspberry Pi 3B+. Everything seems to be working quite well except one thing. I can't get shellinabox to install/run. When I try, I get this error: 'omv_config_add_element' is deprecated.'


    Can anybody point me in the right direction?


    Thanks.


    Reading package lists...
    Building dependency tree...
    Reading state information...
    The following additional packages will be installed:
    shellinabox
    The following NEW packages will be installed:
    openmediavault-shellinabox shellinabox
    0 upgraded, 2 newly installed, 0 to remove and 1 not upgraded.
    Need to get 131 kB of archives.
    After this operation, 628 kB of additional disk space will be used.
    Get:1 http://cdn-fastly.deb.debian.org/debian stretch/main armhf shellinabox armhf 2.20 [118 kB]
    Get:2 https://dl.bintray.com/openmed…plugin-developers/arrakis stretch/main armhf openmediavault-shellinabox all 3.4 [13.3 kB]
    Fetched 131 kB in 0s (248 kB/s)
    Selecting previously unselected package shellinabox.
    (Reading database ... (Reading database ... 5%(Reading database ... 10%(Reading database ... 15%(Reading database ... 20%(Reading database ... 25%(Reading database ... 30%(Reading database ... 35%(Reading database ... 40%(Reading database ... 45%(Reading database ... 50%(Reading database ... 55%(Reading database ... 60%(Reading database ... 65%(Reading database ... 70%(Reading database ... 75%(Reading database ... 80%(Reading database ... 85%(Reading database ... 90%(Reading database ... 95%(Reading database ... 100%(Reading database ... 51495 files and directories currently installed.)
    Preparing to unpack .../shellinabox_2.20_armhf.deb ...
    Unpacking shellinabox (2.20) ...
    Selecting previously unselected package openmediavault-shellinabox.
    Preparing to unpack .../openmediavault-shellinabox_3.4_all.deb ...
    Unpacking openmediavault-shellinabox (3.4) ...
    Setting up shellinabox (2.20) ...
    Processing triggers for systemd (232-25+deb9u9) ...
    Processing triggers for man-db (2.7.6.1-2) ...
    Processing triggers for openmediavault (4.1.19-1) ...
    Restarting engine daemon ...
    Setting up openmediavault-shellinabox (3.4) ...
    shellinabox.service is not a native service, redirecting to systemd-sysv-install.
    Executing: /lib/systemd/systemd-sysv-install disable shellinabox
    Initialize configuration
    WARNING: The function 'omv_config_add_element' is deprecated.
    WARNING: The function 'omv_config_add_element' is deprecated.
    WARNING: The function 'omv_config_add_element' is deprecated.
    WARNING: The function 'omv_config_add_element' is deprecated.
    WARNING: The function 'omv_config_add_element' is deprecated.
    WARNING: The function 'omv_config_add_element' is deprecated.
    WARNING: The function 'omv_config_add_element' is deprecated.
    Processing triggers for openmediavault (4.1.19-1) ...
    Updating locale files ...



    >>> *************** Error ***************
    Invalid RPC response. Please check the syslog for more information.
    <<< *************************************
    Updating file permissions ...
    Purging internal cache ...
    Restarting engine daemon ...
    Done ...

    :) Thanks. Since I already have the n4310 (which is a really flakey NAS product) I thought it might save some money compared to buying two powered USB to SATA connections for the 2 disks I was originally going to attach to my Pi 3 b+. Guess I'll scrap that idea. Appreciate the feedback.

    Understood. For whatever reason, mine seems to be a very unique issue. Only experienced by one or two others. It took a lot of trial and error, with the help of a couple of really helpful guys on this forum to get it up and running. You obviously know way more than me. I'm very new to the Pi/OMV world so I'm just learning. I'm sure you're right. Was just trying to share what worked in case anyone else came across this.

    Recently I purchased a Raspberry Pi 3 b+ to act as my home NAS. I ran into a repeatable set of errors when trying to set up. Namely, I could not connect to the Web GUI and I Couldn't log in with SSH. Hopefully the following will be of some use to other people going through the same issues. This was all done using a macbook pro


    Required:


    Raspberry Pi 3 b+ with 32 GB SD card
    Keyboard for Pi (connected wirelessly through USB attached dongle)
    Attached monitor (I used my TV with an HDMI cable) - you'll need to use this because ssh doesn't work initially.
    latest version of OVM4 for Pi 3 b+
    Etcher


    Steps to Repair


    Get image from https://sourceforge.net/projec…/Raspberry%20Pi%20images/


    Download and install Etcher


    Use etcher on your mac or pc to burn the image onto the SD card


    Connect Pi to network using ethernet cable.


    Connect Pi to monitor/TV via HDMI


    Connect keyboard to Pi


    Insert the SD card into the Pi and boot. This can take quite a while. It may also reboot. Don't power off during this process!


    After boot is complete, log in as root using CLI (Command Line Interface) using attached keyboard. SSH does not work at this point.


    login: root
    password: openmediavault


    You should be forced to change your password at this point. Record it, you'll need it from this point forward.


    ping your router ie ping 192.168.xxx.xxx to make sure your network is functioning.


    Enter the following:


    • nano /etc/ssh/sshd_config
    • change PermitRootLogin to yes
    • Save and exit
    • systemctl restart sshd



    Enter the following:


    • xmlstarlet ed -L -u "/config/services/ssh/enable" -v "1" /etc/openmediavault/config.xml
    • xmlstarlet ed -L -u "/config/services/ssh/permitrootlogin" -v "1" /etc/openmediavault/config.xml
    • /usr/sbin/omv-mkconf ssh



    your should now be able to log into your pi using ssh from another computer (or putty if you are using a pc/laptop)


    ssh 192.168.xxx.xxx


    login: root

    password: YourNewPassword



    Enter the following:


    omv-firstaid


    select option 1 and just hit enter for the options already selected.


    Enter the following:


    omv-firstaid


    select option 2 and just hit enter for the options already selected


    Enter the following:


    shutdown -r now


    Wait for pi to reboot then log in.


    Login as root again


    Enter the following:


    apt upgrade



    apt update


    You should not be able to use a browser on another computer to access your pi via the Web Gui.


    Open a browser on a computer connected to the same network as your pi.


    Enter the IP address of your pi in the browser.


    You should now see a blue screen with a login prompt.


    Login details are:


    Login: admin
    Password: openmediavault


    Change your admin password immediately!


    Everything should now be working.


    I think I've got the order of this straight but I may have one or two things out of sequence. I wasn't documenting things as I tried to figure it out.


    HTH!

    Here's the error:


    Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; mount -v --source '/dev/disk/by-label/NTFS_WIN' 2>&1' with exit code '21': modprobe: ERROR: ../libkmod/libkmod.c:586 kmod_search_moddep() could not open moddep file '/lib/modules/4.9.80-v7+/modules.dep.bin'modprobe: FATAL: Module fuse not found in directory /lib/modules/4.9.80-v7+ntfs-3g-mount: fuse device is missing, try 'modprobe fuse' as root


    System is raspberry pi 3 b+


    After a lot of blood sweat and tears, and the help of two great guys in this forum, I was able to get OMV for installed. It wasn't straightforward. Issues with DHCP and access to the Web GUI.


    I know have new issues when trying to mount a usb connected disk and also enabling NFS (will post the latter seperately).


    Can someone help me with the error above? Happens when I try to mount and NTFS disk attached via USB.


    Thanks!

    Well, it's the one you changed before when you logged in locally. In case you don't remember you can edit it on another machine (/etc/shadow) but in such a situation I would better start from scratch, do not run omv-first-aid but only activating root login via ssh and provide the requested information.

    Update. With the change you suggested, I was able to get as far as the login prompt. But it doesn't like my password for root.


    Well, it's the one you changed before when you logged in locally. In case you don't remember you can edit it on another machine (/etc/shadow) but in such a situation I would better start from scratch, do not run omv-first-aid but only activating root login via ssh and provide the requested information.

    I am using the same password. I know it works because when I type this password to log in as root in the CLI, I have no problem logging in locally.It hasn't changed. This has been part of the problem form the beginning.

    Yeah, silly me should've thought a bit more. In case you're somewhat familiar with editing files via CLI:

    Code
    nano /etc/ssh/sshd_config
    systemctl restart sshd

    And in sshd_config change PermitRootLogin no to PermitRootLogin yes. Then please provide output via an SSH session.

    Can't ssh either I'm afraid. No problem with the nano stuff. I can use nano but nothing network related is functioning.

    So you got a local root shell with display/keyboard connected. Great.


    Can you please provide output from


    Code
    dig google.com
    armbianmonitor -U

    (uploaded to pastebin.com for example since too large to be pasted here)

    Hi tkaiser. I don't think I can. No network connectivity on the Pi so can't share/txfer anything. What ouput do you need? I can probably share manually if not too long.