Posts by fkafl

    No, neither ldap nor AD are enabled. How about some tips on how to reinstall OMV without losing stuff such as Docker configurations, my SQL database, VPN settings. Basically all of the stuff that took me hours and hours of research to configure but now I can't remember how I did it all.

    I recreated the key using ssh-keygen and I gave it the same name as the existing key. After I did that I continued to receive the "PAM" error so I commented that out and now I'm left with this:


    May 17 09:06:58 nas systemd[1]: ssh.service: Start operation timed out. Terminating.
    May 17 09:06:58 nas systemd[1]: Failed to start OpenBSD Secure Shell server.
    May 17 09:06:58 nas systemd[1]: ssh.service: Unit entered failed state.
    May 17 09:06:58 nas systemd[1]: ssh.service: Failed with result 'timeout'.
    May 17 09:06:58 nas systemd[1]: ssh.service: Service hold-off time over, scheduling restart.
    May 17 09:06:58 nas systemd[1]: Stopped OpenBSD Secure Shell server.
    May 17 09:06:58 nas systemd[1]: Starting OpenBSD Secure Shell server...

    How would I generate a new hostkey? Also, is there any other way to get to the command line other than SSH or dragging out my server and hooking it up to a monitor?

    I installed OMV over a year ago and I'm guessing that I installed the ISO with a bootable USB drive. And yesterday when I had the server pulled out and hooked up to a monitor I commented out the "UsePAM" option but I still had the "Could not load host key" error and at that point I was out of ideas.

    I don't have the output handy for the journalctl -xe because my server isn't easy to get to but I do have the output from the system log. If you absolutely need the other output then I will get it for you.


    May 16 11:24:17 nas systemd[1]: ssh.service: Start operation timed out. Terminating.
    May 16 11:24:17 nas systemd[1]: Failed to start OpenBSD Secure Shell server.
    May 16 11:24:17 nas systemd[1]: ssh.service: Unit entered failed state.
    May 16 11:24:17 nas systemd[1]: ssh.service: Failed with result 'timeout'.
    May 16 11:24:17 nas systemd[1]: ssh.service: Service hold-off time over, scheduling restart.
    May 16 11:24:17 nas systemd[1]: Stopped OpenBSD Secure Shell server.
    May 16 11:24:17 nas systemd[1]: Starting OpenBSD Secure Shell server...
    May 16 11:24:17 nas sshd[16979]: /etc/ssh/sshd_config line 23: Unsupported option UsePAM
    May 16 11:24:17 nas sshd[16979]: Could not load host key: /etc/ssh/ssh_host_ed25519_key
    May 16 11:24:17 nas sshd[16981]: /etc/ssh/sshd_config line 23: Unsupported option UsePAM


    May 16 11:24:17 nas sshd[16981]: Could not load host key: /etc/ssh/ssh_host_ed25519_key

    Out of the blue the SSH service stopped functioning and I'm at a loss. After I enable the service and click apply I get the errors shown in the attachment. I also can longer Remote into the server using RDP and I also cannot access Deluge through the web browser. Not sure if those issues are being caused by by SSH issue or not. Any help that can be provided would be greatly appreciated.

    Files