Posts by thegameksk

    Just like before connection timeout

    Once you get into the proxy-confs folder, and the ls command shows all the .conf.sample files... one of them is called "airsonic.subdomain.conf.sample"... we need to copy that and drop the sample extension with the following command...


    Code
    cp airsonic.subdomain.conf.sample airsonic.subdomain.conf

    then run ls again, and you should see your airsonic.subdomain.conf file (.sample will still be there also... just two separate files)


    When you get there come back

    Im there.

    root@debian:~# cd

    root@debian:~# ls

    openmediavault-omvextrasorg_latest_all5.deb

    OK, I guess we'll try it and see what happens, but that is strange...


    In Portainer, on the left... click on Networks. You should see a list of network names assigned to each container, look for the one assigned to swag (there's about a 99% chance it is swag_default .. but just verify it)

    Yes swag_default

    just give it a second, it takes it a sec to receive the key


    You did paste it into a new stack right, not the same one as airsonic?

    New stack


    Now it says

    New certificate generated; starting nginx

    Starting 2019/12/30, GeoIP2 databases require personal license key to download. Please retrieve a free license key from MaxMind,

    and add a new env variable "MAXMINDDB_LICENSE_KEY", set to your license key.


    Edit: It finished. Server is ready.


    Tried the link with my subdomain and it says site cant be reached

    Thats done. I pasted into sack with corrections. In Putty after running the command its stuck on


    [cont-init.d] 20-config: executing...

    This what I see under port forwarding. Sorry had to step away before.


    https://imgur.com/a/foPITOf

    OK...


    It looks like you're using Yacht, I have zero idea how to do this with Yacht. I'm sure it's possible, but I haven't the faintest clue. So if you want to install Portainer, I'm happy to talk you through this... but we'll need to delete your current airsonic container as well (we need to set a network mode on it)... but I can help you do all that with stacks.


    If you want to , let me know.

    I have portainer installed. Its what I use.

    Thanks! I see it. So im assuming the best way to listen on my devices is through the subsonic app? How do I go about setting up the reverse proxy?

    Did you use docker-compose or a stack? If so, could you provide that. It sounds like you didn't give it a volume.