Posts by acecombat2

    Good Day,


    I have no issue using original installation using iso provided. Which is running on old computer headless.


    I'm currently experimenting with the following tutorial, https://openmediavault.readthe…stallation/on_debian.html for another computer


    Instead of original debian 9, I'm installing on top of MXLinux 18.3 which was based on debian 9.6 stable branch.


    One of the irritating part during installation is hanging of starting service proftpd which i forcefully restart service with different tab in terminal (mxlinux terminal) then it continues until the last error.


    Note that the only error I see is the chmod else, no issue.
    Currently install on live usb for testing purposes.



    I'm having problem with chmod error with openmediavault package. any idea how do I solve it? ?(




    Asking why I'm not installing on top of debian 9 os, basically mxlinux has interface and tools that helps administering omv in gui way (Especially snapshot).

    I haven't watched the video but newer versions of mysql and mariadb don't use a password when you are logged in as root. So, you should just try mysql instead of mysql -u root -p

    technodad life's tutorial using linuxserver/mariadb docker image. I have yet to understand the puid and guid part of what is the role and issue without it. the original author of nextcloud and mariadb docker image does not state to define those variables for their docker image.

    @acecombat2 I may try that soon, but somehow I managed to get everything to work. I think it was some permissions issue, although MariaDB still complains about "World Writable." My next problem is when I try to use nextcloud with the DB setup, I eventually get a "504 gateway time-out " when trying to setup eveything for the first time on nextcloud. I know Technodad had us uncomment binding the addresss to 0.0.0.0 in the custom.cnf for MariaDb, so maybe MariaDB isn't communicating, thus causing a delay? I'm still new to linux, trying to understand.:/

    like I said, on the first line. I don't touch custom.cnf file due to nature it changes(corrupt) the original permission when you saved the file under windows os. I remember something along the line that you need to change the ownership chmod from root to www-data (within docker container). I forgot how I did it. to nextcloud files and folder. I never had the world writable issue and I don't have solution for it since it never occur to me.

    Can you let me know the solution. I combed through all the comments & saw others with the problem, but no solution.


    I don't follow technodad life's tutorial 100%, I had some issue with editing on nextcloud config and custom cnf.


    I use original developer docker images and phpmyadmin to administer mariadb database via webui. and I assume you already able to use shellinabox, create 'user-defined' bridge network,know how to mount volume docker.




    #First Download/pull
    https://hub.docker.com/_/mariadb


    https://hub.docker.com/r/phpmyadmin/phpmyadmin



    #Second run the following command with your desire bridge name via shellinabox plugin page.


    docker network create -d bridge my-nextcloud-network #edit the 'my-nextcloud-network'



    #third in docker plugin page


    1.Then Run Image of mariadb with the following setting:


    a. Easy to type container name like 'maria-db'


    b. under Restart policy choose unless-stopped
    c. under Networking choose 'Bridge' Network Mode.


    d. under Environment Variables add the following variable 'MYSQL_ROOT_PASSWORD' with the value of your own password 'mypasswd' #use easy to remember password better.


    e. Under Volume and bind mounts choose your host path (after you have created the folder that is) and the Container path is /var/lib/mysql


    f. under Extra Argument type in '--network my-nextcloud-network' #refer to #second para


    Then save the setting. to run the container.


    #Fourth
    2. Run Image of phpmyadmin/phpmyadmin with the following setting:
    a. Container name 'phpmyadmin'
    b. same as 1.b
    c. same as 1.c and add port forward with the following value
    Host IP = 0.0.0.0, Host port = 82, Exposed port=80/tcp then press ADD (+).
    d. under Environment Variables add the following variable 'PMA_HOST' with the value of 'maria-db' container name.
    e. under Extra Argument type in --'network my-nextcloud-network' #refer to #second para
    Then save the setting. to run the container.


    #Fifth
    1.open your webbrowser and point to your server ip and port 82 = 192.168.xxx.xxx:82 to access phpmyadmin webpage.
    2.Login ID: root, Password: refer to 1.d
    3.Create your 'nextclouddb' database.
    4.Create a user with Global Privilege.



    Done


    I hate command lines to administer database. that is why I recommend phpmyadmin.
    The rest you may follow technodad life's tutorial. I recommend using caddy docker image by abiosoft instead letsencrypt docker image used by technodad life's. Google caddy webserver. if you need my caddy config example. do tell me.


    When you succeed reached at nextcloud's installation webpage, in database host just type 'maria-db' for database username and password refer to #fifth paragraph. However, make sure the nextcloud docker has the same extra argument as 1.f and 2.e.

    Files

    • NC.png

      (141.16 kB, downloaded 223 times, last: )

    Just to mentioned, I'm started clean installed from 4.1.13-1 to 4.1.16-1 which, originally it had filesystem attached however..... cannot backup as the error shows it could not find directory (despite it was created before) version 4.1.13-1. From update onwards, specifically from 4.1.16-1 to 4.1.16-2 the filesystems section which was missing came back and I'm able to backup the OS (one of my main issues since beginning).


    @canadavault be specific what you did and expect it to happen. with screenshot of error or the part it suppose to happen.

    some of it monit.system, localhost:2182 connection refuse, some RPC errors, some are ethernet not being detected (after switch between wifi and ethernet using omv-firstaid configuration), then when using omv-firstaid to change it to ethernet back, connection refused, it won't apply the configuration, some are, mobile version of omv administration webui, came back validation error, which had to request for desktop instead mobile version for the page.


    I think I will open the thread when errors/bugs resurface again.

    I'm a bit frustrated that I had issues with the following errors with backup plugin despite created and chose sharefolders created in sdb 500Gb drive with EXT4 format,


    Error #0:OMV\ExecException: Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C.UTF-8; omv-mkconf backup 2>&1': Method: fsarchiverDevice file: /dev/sda1Root drive: /dev/sda/usr/share/openmediavault/mkconf/backup: line 82: /srv/dev-disk-by-label-OVM Storage/OMVbackup2/omvbackup/backup-omv-24-Dec-2018_16-53-48.fdisk: No such file or directory in /usr/share/openmediavault/engined/rpc/backup.inc:72Stack trace:#0 /usr/share/php/openmediavault/rpc/serviceabstract.inc(565): OMVRpcServiceBackup->{closure}('/tmp/bgstatusO6...', '/tmp/bgoutputFr...')#1 /usr/share/openmediavault/engined/rpc/backup.inc(74): OMV\Rpc\ServiceAbstract->execBgProc(Object(Closure))#2 [internal function]: OMVRpcServiceBackup->doBackup(NULL, Array)#3 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)#4 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('doBackup', NULL, Array)#5 /usr/sbin/omv-engined(536): OMV\Rpc\Rpc::call('Backup', 'doBackup', NULL, Array, 1)#6 {main}


    I have 2 hard drives 1 with OMV installed in 160GB (sda) and another for storage 500Gb (sdb).


    This happened before When I have Windows 10 installed in to try out OMV, decided to redo by reformat everything start fresh, with just omv. I still get this error. Now I'm stuck. I don't want to re-setup again from scratch..... ;(


    I'm appreciate if anyone can point out what should I need to do to make it work.


    I assumed backup plugin intended to backup os partition. or I misunderstood the sharedfolders was meant by backup intended for designated folder and not destination for os backup?