Posts by Sensiva

    Hello everyone,


    I installed OMV5 using the official installation media version 5.5.11 on a virtual machine using Proxmox qemu. I have pfSense router that handles hostnames resolution in local network.


    I noticed the following two scenarios:


    Scenario ONE:

    • Fresh install of OMV, hostname set during installation to "nas"
    • I can ping/access OMV using hostname from any other workstation in local network
    • Upgrade to the latest release using omv-update
    • Open WebGUI, I see notification to apply for new configuration. I click apply, after one minute "communication error occurred" and the notification disappears
    • Enable WOL in network interface, then apply.
    • Network connectivity is lost, a new IP is acquired
    • Unable to ping/access OMV using hostname
    • I can ping/access OMV using the new IP address
    • pfSense shows the following two entries in DHCP list
    • It shows that after upgrading, a new IP has been acquired but it is not reporting its correct hostname

    Scenario TWO:

    • Fresh install of OMV, hostname set during installation to "nas"
    • I can ping/access OMV using hostname from any other workstation in local network
    • Enable WOL, then apply... all goes well
    • I can still ping/access OMV using hostname from any other workstation in local network
    • Upgrade to the latest release using omv-update
    • Open WebGUI, I see notification to apply for new configuration. I click apply, after one minute "communication error occurred" and the notification disappears
    • reboot to verify network configuration is working correctly..
    • Disable WOL in network interface, then apply.
    • Unable to ping/access OMV using hostname


    UPDATE: This issue isn't present when installing OMV 5.6.5 on top of a fresh install of Debian Buster 10.9


    I can do any suggested further tests and provide information to confirm if it is a bug or not.


    Thanks in advance

    I managed to achieve what I wanted. Here is how..


    1- Create a user with privileges enough to send mail

    2- Create a service file nano /etc/systemd/system/email-notifications.service

    3- Enable the created service systemctl enable email-notifications.service


    Notes/Findings:

    • Those steps assumes you already configured email configurations in OMV webGUI
    • That service file worked for me after several try/error attempts. It is not guaranteed that it would work for everyone else
    • I think It needs tweaking (I am not familiar enough with systemd)
    • systemd is very fast in stopping/killing services/processes during shutdown. Thats why 5 seconds delay is needed
    • The main issue/challenge is that postfix doesn't send emails currently in queue before it gets stopped by systemd
    • systemd is complicated and messing with it is likely going to break your OMV installation. I suggest reading its manual pages carefully
    • It would be great if the function of shutdown notification be added in OMV webGUI


    Thanks for all your hints and for OMV :)

    Thanks for your reply. I tried to do a systemd service to send the shutdown email. But it is never sent on time because the message goes to queue first. And I am unable to find a way to make this service execute that script before stopping postfix

    Hello Everyone,

    I am using OMV 5 as a backup server for daily automated backups. And it is doing an awesome job. Thanks for everyone contributing to this great project.

    I would like to receive an email notification once OMV startup and shutdown. Any ideas how to do this in clean way?
    I already configured SMTP for other notifications using OMV webGUI, and I can receive all other notifications. The only extra I need is to receive an email upon startup and shutdown.


    Thanks in advance:)

    This is configured in Notification as Sender email. However, if you are using gmail as your SMTP server, it will automatically rewrite the address to be that of the account holder.

    I am using the email provider SMTP server. Please, note that I want to specify the name not a different address.


    Sender email in Notification configuration doesn't accept any input other than an email format.