Posts by deejc

    did anyone find an answer ?
    i too have this issue, trying to remove the bond on a HP microserver.


    i just removed all references to bond0 in config.xml's interface block, and removed the bond options in the same interface code block and changed it to eth0


    This is my docker config for muximux, I can connect on port 8099 and my files are at /media/muximux


    docker create \
    --name=muximux --restart=unless-stopped\
    -v /media/muximux:/config \
    -e PGID=378 -e PUID=380 \
    -e TZ=Europe\London \
    -p 8099:80 \
    -linuxserver/muximux

    I don't buy from eBay or Ali, only from my memory.co.uk I don't buy cheap either, I'm also not sure where the fake card idea came into the conversation as the op wants to use a card that is already in use , no mention of size, make, manufacturer etc... My message was around issues I saw with my cards in this particular server using monitoring, once I turned off monitoring the server ran for months no problem... I didn't blame a plugin or the OS or OMV I merely stated an issue I had.

    I had trouble with the SD card method, I was using monitoring and after some time the server would lock up, need a hard reboot and the monitoring data would all be lost
    See my posts for the issue, you may be ok if you do not use monitoring / graphs



    Sent from my iPad using Tapatalk

    It's not real hardware raid, so you probably won't get much benefit, although you will be able to boot from it if you use the built in raid controller but then you will need to do some work as OMV will take the whole partition on install.
    These servers don't boot from a 5th drive on the optical port but can do if you use the USB boot method, if you have data on the drives already be very careful!!



    Sent from my iPad using Tapatalk

    I completely understand, but a full reinstalling was exactly what I was hoping not to do.
    I run all my apps in docker but not through OMV as I have had other issues in the past where I had to reinstall and lose all my config.
    I won't be reinstalling.

    So, its nearly fixed....


    i got php5 installed following these instructions Install PHP5 on stretch but i cant login to the web ui and i am getting some rrdcache errors in the syslog and also collectd not started.
    needs more investigation later..



    Bash
    Error #0:
    exception 'OMV\Rpc\Exception' with message 'Failed to connect to socket: No such file or directory' in /usr/share/php/openmediavault/rpc/rpc.inc:140
    Stack trace:
    #0 /var/www/openmediavault/rpc/session.inc(56): OMV\Rpc\Rpc::call('UserMgmt', 'authUser', Array, Array, 2, true)
    #1 [internal function]: OMVRpcServiceSession->login(Array, Array)
    #2 /usr/share/php/openmediavault/rpc/serviceabstract.inc(124): call_user_func_array(Array, Array)
    #3 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('login', Array, Array)
    #4 /usr/share/php/openmediavault/rpc/proxy/json.inc(95): OMV\Rpc\Rpc::call('Session', 'login', Array, Array, 3)
    #5 /var/www/openmediavault/rpc.php(45): OMV\Rpc\Proxy\Json->handle()
    #6 {main}

    Having stable in your sources.list means your machine upgraded to Debian 9 Stretch when you did the omv-update. You will need a backup to recover from this because OMV 3.x will not work on Debian 9.

    ahh..... well thats not going to happen, i only crashplan my data.
    never mind, thanks

    Code
    this is with stable
    The following packages have unmet dependencies:
    openmediavault : Depends: php5-fpm but it is not installable
    Depends: php5-cgi but it is not installable
    Depends: php5-cli (>= 5.6) but it is not installable
    Depends: php5-pam but it is not going to be installed
    Depends: openssh-blacklist-extra but it is not installable

    ~ $ uname -mrs
    Linux 4.9.0-0.bpo.3-amd64 x86_64