Posts by deejc

    i cant see how it isn't installed, i have been very careful not to install anything in debian as i want to keep OMV as vanilla as possible and only use docker for installing apps so that uninstalling or upgrading doesnt hose the OS

    not in mine, only python 3 seems to be installed


    Code
    ~ $ dpkg --get-selections | grep python
    python-apt-common install
    python3 install
    python3-apt install
    python3-minimal install
    python3.2 install
    python3.2-minimal install

    i want to run plexpy with my manually installed plex pass media server, it doesn't run with python 3 which is the version i appear to have installed on my vanilla OMV install, Is it safe to install pyhon 2.7 ?


    the only plugin i use is docker / afp / smb

    i am running the same version, looking further into it i am wondering if it is the camera as one camera seems to beok and it only seems to happen with the other one.
    i'll let you know if i figure it out

    hello everyone,
    i have managed to install the latest zoneminder but i am getting errors with nginx and the zm gui but also with the OMV gui
    i have tried rebooting etc.. restarting ZM..


    in the logs i get the following over and over, the omv gui stops responding and will only load again if i close it and reopen.


    Code
    2016/01/03 21:52:08 [error] 25729#0: *1020 FastCGI sent in stderr: "PHP message: ERR [socket_bind( /var/run/zm/zms-404108w.sock ) failed: Address already in use]" while reading response header from upstream, client: ::ffff:172.16.30.5, server: openmediavault-webgui, request: "POST /zm/index.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm.sock:", host: "172.16.30.100", referrer: "https://172.16.30.100/zm/index.php?view=watch&mid=3"
    2016/01/03 21:52:11 [error] 25729#0: *1020 FastCGI sent in stderr: "PHP message: ERR [socket_sendto( /var/run/zm/zms-404108s.sock ) failed: No such file or directory]" while reading response header from upstream, client: ::ffff:172.16.30.5, server: openmediavault-webgui, request: "POST /zm/index.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm.sock:", host: "172.16.30.100", referrer: "https://172.16.30.100/zm/index.php?view=watch&mid=3"

    i think it only works with certain sd cards, i remember reading somewhere that HP sell the cards!!!
    here it is : http://h20195.www2.hp.com/v2/GetPDF.aspx/4AA4-9872ENW.pdf


    Prerequisites
    The following elements are required for using Intelligent Provisioning to deploy an OS to an SD card for an HP ProLiant Gen8
    server:
    HP ProLiant Gen8 server with Intelligent Provisioning v1.50 or later
    Host ROM dated August 20th, 2013 or later
    iLO 4 v1.30 or later
    HP 32GB SDHC Enterprise Mainstream Flash Media Kit (Part Number 700136-B21) or HP 32GB microSDHC Enterprise
    Mainstream Flash Media Kit (Part Number 700139-B21) installed in the server.

    Hello,
    i am using the webdav plugin and Photosync on IOS to auto upload photos when i return home, but if it tries to upload videos i get the following error :

    Code
    413 Request Entity Too Large


    googling shows that i should change certain request sizes in php.ini etc which i have done but this doesn't seem to have fixed it, does anyone have a suggestion to allow the uploading of videos from the phone ?
    thanks


    by the way, i searched and found a few php.ini files and am not sure the exact files i should be editing
    also

    Quote

    grep -E "upload_max_filesize|memory_limit|post_max_size" /etc/php5/fpm/php.ini

    shows


    i also set :

    Quote

    client_max_body_size 0;


    in /etc/nginx/nginx.conf as noted here

    Hello,
    my syslog is flooded with the following line over and over, 100's or 1000's of times a day.

    Code
    omv kernel: [926534.282070] Loading kernel module for a network device with CAP_SYS_MODULE (deprecated). Use CAP_NET_ADMIN and alias netdev- instead.


    i can't work out whats causing it, google says maybe openvpn which is running but i am also running the HP tools on my gen8 along with hpsmhp and snmp etc, any ideas how i can stop this message form flooding the syslog ?
    im not worried about the cause of it, just to stop it being logged would be enough
    thanks



    *********FIXED*********
    added this to /etc/rsyslog.conf


    Code
    :msg, contains, "Loading kernel module for a network device with CAP_SYS_MODULE (deprecated)" ~

    OMV has a recovery option included in one of the plugins I can't remember which, sorry but it boots from the same grub boot menu once it is installed maybe someone else can give you the direction for this as I am not near my machine right now
    you are correct about the ilo only allowing access during boot so maybe you will need to find an external monitor just for the install