Posts by lons

    Hi


    How to lock a encryptet HDD?


    I have created a encryption device.
    - unlocked it
    - created a filesystem EXT4
    - mount HDD
    - create a shared folder
    - create a SMB share
    Everything works great!


    Whats the best way to lock the device?
    The only way i found:
    - delete the SMB share
    - delete the shared folder
    - unmount the HDD
    and only then i can lock the device...


    Why cant i go to Luks plugin and lock the device directly?

    Hello


    I have delete all my docker container and startet from new...
    The Host's starts normal and i can see the uptime, but i cant connect to them.
    In the Log of every Docker Host the error message is:


    Code
    /usr/bin/python2: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory

    Sabnzbd, Radarr, Sonarr everthing the same error
    OpenHAB and Squeezebox Server works.


    So what can i do?


    Thanks

    Hello


    I have the following problem:
    I created a new LVM volume and try to mount, but when i try to save the config i get everytime the error "/dev/sdc is already mounted".
    (sdc is a BTRFS Raid1 with /dev/sdb)
    Everytime i try to mount, unmount or delete a HDD i get an error.
    The Raid1 shows up 2 times in the list?


    Ich hab folgendes Problem:
    Ich hab mir in einem bestehenden LVM ein neues Volume erstellt und wollte dieses mounten, leider bekomme
    ich da immer wieder die Fehlermeldung das /sdc/ (bei sdb & sdc handelt es sich um ein BTRFS Raid1)
    schon gemountet wäre und ich kann nichts entfernen oder neu mounten.
    Komischerweise taucht diese Raid1 in der Liste auch doppelt auf.


    Clipboard03.jpg


    Details:


    Clipboard02.jpg



    Thanks, Marcel

    Hello


    How can i create a BTRFS Raid1 set?


    * Go to Raid Management
    * Select "Mirror" and the 2 Hdds
    * Wait until Raid1 is ready
    * Go to FileSystem
    * Select the Raid1 and create a BTRFS filesystem


    Is this correct?
    Or must it be made in commando shell with "mkfs.btrfs -d raid1 /dev/sda /dev/sdb"


    Thanks, Lons

    I mount it with the LVM Plugin in OMV and not by myself in fstab.
    The OMV system works 4 days perfect and the only thing i changed today was install the couchpotato plugin and the update...


    fstab:

    Reboot several times & no errors except smb log


    Syslog:


    When i try to open SMB log, i get this error message:


    Code
    Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; export SYSTEMD_COLORS=0; journalctl --quiet --no-pager --priority='notice' SYSLOG_FACILITY=23 SYSLOG_IDENTIFIER='smbd_audit' --output=short 1>/tmp/logfilemShjxe 2>&1' with exit code '1':
    Code
    Fehler #0:
    exception 'OMV\ExecException' with message 'Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; export SYSTEMD_COLORS=0; journalctl --quiet --no-pager --priority='notice' SYSLOG_FACILITY=23 SYSLOG_IDENTIFIER='smbd_audit' --output=short 1>/tmp/logfilemShjxe 2>&1' with exit code '1': ' in /usr/share/php/openmediavault/system/process.inc:175
    Stack trace:
    #0 /usr/share/openmediavault/engined/rpc/logfile.inc(73): OMV\System\Process->execute()
    #1 [internal function]: OMVRpcServiceLogFile->getList(Array, Array)
    #2 /usr/share/php/openmediavault/rpc/serviceabstract.inc(124): call_user_func_array(Array, Array)
    #3 /usr/share/php/openmediavault/rpc/rpc.inc(84): OMV\Rpc\ServiceAbstract->callMethod('getList', Array, Array)
    #4 /usr/sbin/omv-engined(516): OMV\Rpc\Rpc::call('LogFile', 'getList', Array, Array, 1)
    #5 {main}

    Hello


    I have installed OMV 3 on my test hardware (Asrock B75M, Intel G550, 4GB Ram).
    Everyting works perfect with these plugins Snapraid, Sabnzdb, MySQL for the last 3 days.
    Today i made an update and now my tabs: File Systems, UnionFileSystems and Shared Folders are empty and the only thing i see is the "loading" symbol.
    SMB shares are working.
    So whats wrong?


    Thanks for help, Lons

    Problem solved!


    changed the UID for sabnzdb from 113 to 1007 with

    Code
    usermod -u 1007 sabnzbd


    changed the user for "/var/opt/sabnzbd" from sabnzbd [113] to sabnzbd [1007]
    changed the user for "/run/sabnzbd" from sabnzbd [113] to sabnzbd [1007]
    Now the user is in OMV userlist

    Hello


    I have installed sabnzdb, sickbeard and squeezeboxserver.
    Every app has created a new user, but they are not in OMV user list, so i have some troubles with the ACL.


    with "cat /etc/passwd" i get this:


    Code
    sabnzbd:x:113:100::/home/sabnzbd:/bin/false
    sickbeard:x:114:100::/home/sickbeard:/bin/false
    squeezeboxserver:x:115:65534:Logitech Media Server,,,:/usr/share/squeezeboxserver:/bin/false


    This two samples i see in OMV User list:

    Code
    couchpotato:x:1005:100::/home/couchpotato:/usr/sbin/nologin
    kodi:x:1003:100::/home/kodi:/bin/dash


    So how can i change this?


    Thanks, Lons

    Hello


    I have a big problem
    I think i was on OMV 2.?? and tried a update via
    apt-get update && apt-get dist-upgrade && omv-update


    Now are all commands not found
    omv-update -bash: omv-update: Kommando nicht gefunden.
    omv-release-upgrade -bash: omv-release-upgrade: Kommando nicht gefunden.
    omv-firstaid -bash: omv-firstaid: Kommando nicht gefunden.


    WebGUI says
    403 Forbidden


    Samba is working


    So what can i do?
    I dont want to reinstall and configure all new.


    Really big thanks

    Sorry, doesn't work for me.
    I have 4 Clients and on 3 there are mounted network drives.
    This works (modified Auto Off from Ubuntu - works very well on my Ubuntu server)
    This searches "no locked" files/directorys with smbstatus:

    Code
    # Samba
    if [ `/usr/bin/smbstatus | grep -i no | grep -i locked | wc -l ` != "1" ]; then
    logit "samba connected, auto suspend terminated"
    return 1
    fi


    Can you add something like this in your Skript?


    Thanks, Lons

    Hi


    Autoshutdown works great, but i cant use the function Network IP array because my Workstation is 24/7.
    Autoshutdown see the Workstation and doesnt shutdown, but if i dont use this function, my server shutdown although a samba connection is in use!
    How can i change this?