Posts by legolas08

    Puoi eseguire il comando


    [tt] smartctl --nocheck standby -i / dev / sdb [/ tt]


    come lavoro pianificato per ogni unità al riavvio e vedere se funziona.

    disabling all the options concerning the S.M.A.R.T. I still have the smartctl service that queries the disks and who knows which option ... I don't understand how it is possible that with everything disabled the service goes on.

    I meant, executing this

    would be the same as this


    I thought that is what you wanted to achieve with

    tried this too, the option that comes up is this:

    Code
    /dev/disk/by-id/ata-ST2000DM008-2FR102_WFL2KBPS -a -o on -S on -T permissive -W 0,0,0 -I 190 -I 194 -I 231 -n standby,q

    but he wakes up anyway

    I did another test, I sent the disk to standby and I sent the following command:

    Code
    smartctl --nocheck standby -i /dev/sdb
    smartctl 6.6 2017-11-05 r4594 [x86_64-linux-5.8.0-0.bpo.2-amd64] (local build)
    Copyright (C) 2002-17, Bruce Allen, Christian Franke, www.smartmontools.org
    Device is in STANDBY mode, exit(2)
    root@SmartHome:~# hdparm -C /dev/sdb

    The hd did not wake up. is there any way to set the following parameters as above? Since the changes the file is deleted

    Code
    # This file is auto-generated by openmediavault (https://www.openmediavault.org)
    # WARNING: Do not edit this file, your changes will get lost.
    /dev/disk/by-id/ata-Hitachi_HDS723030ALA640_MK0311YHG7KKJA -a -o on -S on -T permissive -W 0,0,0 -I 190 -I 194 -I 231 -n idle,q
    /dev/disk/by-id/ata-PNY_CS900_120GB_SSD_PNY44191911011504766 -a -o on -S on -T permissive -W 0,0,0 -I 190 -I 194 -I 231 -n idle,q
    /dev/disk/by-id/ata-ST2000DM008-2FR102_WFL2KBPS -a -o on -S on -T permissive -W 0,0,0 -I 190 -I 194 -I 231 -n idle,q
    /dev/disk/by-id/ata-Samsung_SSD_840_EVO_120GB_S1D5NSAF925610T -a -o on -S on -T permissive -W 0,0,0 -I 190 -I 194 -I 231 -n idle,q
    /dev/disk/by-id/ata-WDC_WD10EACS-00D6B0_WD-WCAU40622400 -a -o on -S on -T permissive -W 0,0,0 -I 190 -I 194 -I 231 -n idle,q
    /dev/disk/by-id/ata-WDC_WD40EZRX-00SPEB0_WD-WCC4ENA8P2CU -a -o on -S on -T permissive -W 0,0,0 -I 190 -I 194 -I 231 -n idle,q

    I idle a hd with hdparm -y and in the meantime I checked the same with btrace, this is what comes when he wakes up:

    Mhm, maybe I was not patient enough.

    After some time I have


    Code
     8,32 0 1 0.000000000 15883 D N 0 [hdparm]
    8,32 1 1 0.000120564 15884 C N [0]
    8,32 2 1 900.079870273 16201 D N 0 [hdparm]
    8,32 2 2 900.079998481 16202 C N [0]

    I don't know enough about btrace to say if an entry means that the drive will spin up.

    the hdparm entry comes out to me too, but it doesn't revive the disk unlike smartctl. Every minute comes out and the hdd goes into spinup

    No failure, so seems ok.

    How do you know it is smartctl that wakes the drive?

    i use blktrace:

    You can check if

    omv-salt deploy run smartmontools

    throws any error.

    this is the result

    I have enabled the smart for each single hard disk now in the file I find this:

    I tried to stop the hd with the command hdparm -Y / dev / sd [abcdef], but after 1 minute they are reactivated by smartctl

    You can check, if you changes are written to /etc/smartd.conf.

    this is what I find inside the file


    # This file is auto-generated by openmediavault (https://www.openmediavault.org)

    # WARNING: Do not edit this file, your changes will get lost.

    Hello everyone! on omv5 I have 4hd that I use for viewing multimedia files, I'm trying to activate the spindown for all 4, but it does not activate due to the smartctl process that every minute sends the reading to the disks. I brought from the gui to disable the S.M.A.R.T. to no avail, or to keep it active with high scan times but the problem remains the same. Any suggestions?

    p.s: on omv4 everything worked fine