Posts by Erikk

    kolyanick I also think gderf's advice is worth paying attention. I'd have done the same.

    But there's something else I got to tell you.
    I recognized Russian on your the very first screenshot and thought you probably want to check out the following article: (rus).
    It's about NAS configuration with no swap and RAM-based tempfs. However, it requires advanced "linuxing" skills. And if you are confident, you could take a chance and try ;)

    Ok. After a bit deep googling I found out the message "shopt: not found" could appear in case of using /bin/sh instead of /bin/bash

    I changed the first line of the /etc/cron.weekly/openmediavault-update-smart-drivedb script to #!/bin/bash and the script worked properly, without any error.

    But I really not sure it was a correct solution. Any ideas are welcome :)


    I noticed my OMV have a quite old issue: weekly cron task ends with an error:

    /etc/cron.weekly/openmediavault-update-smart-drivedb: 11: /etc/cron.weekly/openmediavault-update-smart-drivedb: shopt: not found

    Seems some script tries to set or unset some shell option by shopt - shell built-in command. But it's not clear which one option...

    Does anyone have any guess what might have caused it?

    Debain 10 (SMP Debian 5.2.9-2~bpo10+1)

    OpenMediaVault 5.4.2

    Here's the script output with sh -x option:

    And shopt output

    I you can see, the error is:
    Could not connect to (, connection timed out

    I checked the site and it accessible from my workstation with no problem. Please make sure your OMV has access to the internet and you can connect to the site from it (for example login to OMV with ssh and try to connect to the site).

    As I can see it tries to unmount shared mount point, but with no luck.
    Probably /sharedfolders/appData are in use by some user, device, process, daemon, etc.
    Try to run this as root in CLI to check who is using this folder.

    lsof +D /sharedfolders/appData
    lsof -i 4 /sharedfolders/appData

    It will gives you a list of processes using the folder. Try to reset connection or stop daemon (or disable whatever else which blocks the folder).
    Then try to change privileges again.

    Well, actually I've install OMV on the same MB recently. And I can say I didn't change default settings. So if you are worring whether you run into a problems during OMV/Debian installation, you can be pretty sure it won't happen.

    I had a problems, but my configuration a bit exotic and moreover I used Debian 10+OMV5, so it was rather because I love challenging projects, not because hardware caused an issues.

    Um.. but what are you really concerned about?
    Because, you know, CSM is just a part of UEFI to provide legacy BIOS compatibility for legasy OS (wiki)
    And as OMV is not legasy OS, so using this option is not very useful either, is it?

    @Erikk This is what I got:

    /usr/sbin/omv-confdbadm populate
    /usr/share/openmediavault/confdb/populate.d/ 27: /usr/share/openmediavault/confdb/populate.d/ omv-confdbadm: not found

    Well, seems it still wants to know the path to omv-stuff... Ok, try to add '/usr/sbin' into your PATH environment variable

    export PATH=$PATH:/usr/sbin

    Then run 'omv-confdbadm populate' and see if it finished properly.
    If it's not, see ryecoaaron's comment above.

    If you check your log carefylly, you will find following:

    Try to run "systemctl status sharedfolders-docker.mount" and check why it failed.
    For additional information you can also check "journalctl -xe", but make sure you read the log at exactly the time the error occurred.

    That command wouldn't help this problem. Did you mount your filesystems using the omv web interface? See problem #2 here -https://forum.openmediavault.o…tions-to-common-problems/

    Thank you for the link! This confirmed my guesses.
    As for question whether I mount via OMV - no, I didn't.
    However please note that I installed Debian 10 and mount all partitions first, and then rolled up OMV. Do I understand correctly that this is a valid way? And if so, is there a way for me to populate dropdown?

    ext4 on my system /dev/sda and btrfs on my storage /dev/sdb
    and btw I can see all partitions in Storage->File systems.
    Do you think it's important which filesytems contain the disks? I thought it's rather about hardware detaction, than logical volume.

    But I noticed one guy published OMV5 (usul) has been installed in debian 10 (Buster) for test
    and it seems quite usefull, at least I found that I forgot to run "omv-confdbadm populate". First run was unsucessfull and failed with errors, so I'll continue trying to fix it and will inform if it helped.

    Hi there.
    Not sure if I should open new one thread... Anyway, I have the same problem as it described by thread starter - just can't see any disks in dropdown list while creating shared folder.
    But it's seems different.
    I have fresh Debian 10 (with no GUI) installed with OMV 5.0.5 and it's real hardware, not virtual machine (yes, I know this is a great chance to have a headache using OMV5 right now, and please bealive me I do have all headache I could find or create myself about that, but it's another story :) )
    So I do see my both disks in Storage->Disks as /dev/sda and /dev/sdb
    But I suffer from the lack of them in dropdown list.

    Maybe someone has an idea where I should start?