Posts by heinsenberg82

    Unmount Disks 1-4. Then look inside their mount point directories in /srv. They should be empty, but if they aren't that's your problem.

    Hi, thanks for the input. I've unmounted all drivers, and after that the mount point directories have vanished.



    Code
    pi@NAS:/srv $ ls -l
    total 12
    drwxr-xr-x 2 ftp nogroup 4096 Dec 3 2020 ftp
    drwxr-xr-x 3 root root 4096 Jul 18 00:01 pillar
    drwxr-xr-x 5 root root 4096 Jul 18 00:01 salt
    pi@NAS:/srv $

    So apparently that's not the issue.


    EDIT: LOL, I just noticed that the remaining space in root disk is now correct, as the image shows. Let me mount all drives again and see if the issue is fixed!

    OMV says my root sd card partition is almost full (see image below):



    However, I can't figure it out why. Things I've already done:


    1) Running ncdu -x /:



    2) Running docker system df (btw, my Docker stuff is on an external hard drive):

    Code
    TYPE TOTAL ACTIVE SIZE RECLAIMABLE
    Images 12 12 2.479GB 104.9MB (4%)
    Containers 12 12 891.4MB 0B (0%)
    Local Volumes 34 1 336.3kB 0B (0%)
    Build Cache 0 0 0B 0B


    So I just can't figure it out the reason at all. Any help will be appreciated, thanks.

    I've searched this forum and I still can't find a solution to this.


    After a fresh install of OMV5, I can't access my samba shares anymore. I've already checked permissions and I don't think it's a permission issue. Here is the /etc/samba/smb.conf content:


    After I enable SMB, I can see my device on Windows listed among the network devices:


    When I double click it, it asks for my credentials. I'm trying to login as user "Pi", which has access to all my shared folders and it's on sambashare group. But then the error "\\NAS is not accessible. You might not have permission to use this network resource..." is thrown.


    Any help will be appreciated. Thanks.

    Two things... It doesn't have any config, so it shouldn't cause any harm. And you should have your omv system behind a firewall/router meaning the port doesn't matter unless you open that port on the firewall/router.


    But I maybe the following would fix it.


    sudo systemctl disable proftpd
    sudo systemctl stop proftpd

    Hey man, thanks for the reply! My ISP gives me an ipv6 address with two options: firewall enabled or disabled. That's it, the ONT has no firewall customization at all for ipv6 (on ipv4, I could manage port forwarding, but it's not the case with ipv6). That's why I'm a little concerned about these open ports.


    I appreciate the suggestion about how to close the port 21, it worked! Could you also give me a hint about how to close the remaining ports? - 111, 139, 445 and 2049.

    I have several open ports on OpenMediavault, that I don't want to be open, like the FTP port (21).


    That's insecure and specially weird, since, for example, I have FTP disabled on OMV GUI. After searching the forum, I have even tried to enable FTP and then disable it, but this trick does not work: the port continues open, no matter what.


    Is this happening only to me? Is there any fix for this?


    Thanks.

    I have five disks inside a HDD enclosure (ORICO DS500U3) plugged on one USB 3.0 port of my RPi 4. Four of them are 3.5" HDDs, and one of them is an 2.5" SSD.


    I have several shared folders created from the HDDs, no problem here. However, I can't create a shared folder from my SSD, because it does now show up in the dropdown list.


    The SSD was previously wiped and formatted (EXT4) through OMV GUI. I can mount it through the GUI, and I can access it through SSH/SFTP using WinSCP. The only thing I can't do with it is creating a shared folder.


    file systems.jpgadd shared folder.jpg


    I'd appreciate any help, thanks.

    Hey, I just had the same issue here and your solution worked. Thank you for sharing!

    I finally figured this out, so let me share with you.


    1) I was not able to update my repositories or install anything because my freaking clock had the wrong time and date. When I fixed the clock, I could finally install Docker and Portainer.


    2)

    That's absolutely right. I had my Docker storage set on my external HD (/sharedfolders/docker), and Docker was running before my storage was mounted. I fixed this by creating a file named docker-wait-sharedfolders.service in the /etc/systemd/system directory, with the following content:


    [Unit]
    Description=Wait for SHAREDFOLDERS-DOCKER.MOUNT before starting Docker
    RequiredBy=docker.service
    Before=docker.service
    Requires=sharedfolders-docker.mount
    After=sharedfolders-docker.mount




    [Service]
    Type=oneshot
    ExecStart=/bin/true
    RemainAfterExit=yes




    [Install]
    WantedBy=multi-user.target



    then systemctl enable docker-wait-sharedfolders.service .
    Now Portainer is firing up after I reboot :) Thank you for all the tips!

    That's fine, run the apt clean again and the error message should resolve itself.

    Already did it multiple times, but it doesn't help me.



    That's fine, run the apt clean again and the error message should resolve itself.

    Thanks for the hint. But now, as I mentioned, I can't even install Docker.


    The "Failed to update apt repos" error makes me suspect it would be something wrong with my network, but I already have reconfigured my network with omv-firstaid, and I can ping http://www.google.com just fine.

    My previous post was subjected to moderation (i don't know why), so let me try again.


    OK, this is what I did now.


    First, i ran service docker restart and BAM!, Portainer started! When I rebooted the machine, though, Portainer was not initialized. It only starts if i restart Docker service.


    Then I uninstalled Portainer, uninstalled Docker, ran an apt clean (through GUI), then an sudo apt-get autoremove (through bash). Btw, sudo apt-get autoremove didn't remove anynthing.


    Now, I can't even install Docker through OMV Extras GUI. The error appears to be similar with the error I got when tried to install Cockpit. Here's the full log: