Posts by Shperrung

    My install suppose a use of SSD for Nextcloud web-server with apps, user's accounts, services and database. Users data is located on ZFS raid.

    SSD paths:

    /docker/nextcloud/db:/var/lib/mysql

    /docker/nextcloud/nc:/var/www/html

    HDD paths:

    /mnt/raid/nc:/var/www/html/data - this is user's default folder in Nextcloud.

    /mnt/pool/photo:/mnt/pool/photo:ro - this is folder for "external storage". I mounted it with the same folders paths to avoid mistakes.

    I have now enough fast reaction from Nextcloud in this configuration rather than in my previous setup with all Nextcloud & DB folders located on HDDs.

    That is good practice when datasets/filesystems are disconnected from any Debian-OMV services before export or any action lead to mountpoint relocation. It includes sharedfolders, smb/cifs, docker volumes and other.

    Yesterday I couldn't export pool because of "the pool is busy" due running docker containers whish wasn't binded to this pool.

    Thank a lot!

    You directed me on the right way.

    I meant "Previous version" tool in Windows 10 explorer and I got it.

    My problem was in unpriveleged user (non-root) who can't get access to .zfs/snapdir. I just added "root" for the user and it works

    Hi, everyone!
    I'm trying to reach zfs support on fresh omv install but can't do this due to errors.
    [Resolved] see my next post below
    My system is 5.0.5-1 (Usul)
    OMV-extras are installed
    openmediavault-zfs 5.0.4 plugin was started to be installed.
    Installation went well until first error

    Code
    Loading new zfs-0.8.3 DKMS files...
    Building for 4.19.0-5-amd64
    Module build for kernel 4.19.0-5-amd64 was skipped since the
    kernel headers for this kernel does not seem to be installed.


    Then appears this

    Code
    Setting up zfsutils-linux (0.8.3-1~bpo10+1) ...
    modprobe: FATAL: Module zfs not found in directory /lib/modules/4.19.0-5-amd64

    and this

    I tried to install "Proxmox kernel" from OMV-extras - Kernel but my system failed down: no ethernet, no gui, no ssh. Just cmd on monitor.


    I feel that versions of OMV, zfs-plugin and Proxmox kernel are not compatible.
    Please share your combination of OMV and zfs stuff that works.
    Thanks!