Posts by nex86

    Trying to clone my openmediavault ssd to a bigger one because I'm running out of space on root (/).
    using dd to clone it to a bigger drive didn't work.
    and using clonezilla gave me and error (invalid argument during seek. program terminated with error.)


    whats the issue here?


    both SSDs are connected to two Sata to USB adapters.

    I could try that too. but does it reload the configuration as well?


    edit: yep. works.



    proftpd wasn't the only service that had this issue for me.
    there were other services that couldn't establish an internet connection at the time there were executed.
    looks like this machine just takes a longer time til the connection is established.

    I'm trying to use the scheduled jobs to run a script to fix an ftp issue.. so
    I tried to set it up like this:


    chrome_av9NAZJ6df.png


    but when I try to execute it it fails with this error:


    any ideas?


    The issues I'm actually having is described here, but nobody seems to know how to fix it except for manually restarting the service:


    https://forum.openmediavault.o…?postID=219161#post219161





    edit: nevermind, it somehow, just works after rebooting, guess I can just ignore that error.

    I deleted around 700GB of files, I had the recycle bin enabled, which I cleared later on.
    Now it still shows that the drive uses over 750GB, but all the files that are on there at the moment are only 50GB.
    even after disabling the recycle bin for the specific share and rebooting it still shows used space of files that I can not see.


    nevermind, I had to delete them manually with rm -rf. there were in /sharedfolders/storage/.recycle.

    I'm having the same exact problem.
    So the issue is reported on debian bug tracker since 2014 and still not fixed to this day?
    Can't we just delay this script that starts proftpd so it waits until the network connection is fully established?


    this is probably a hacky workaround that might not even work but I'll try to add a sleep 5 to the beginning of the script in /etc/init.d/proftpd


    update: didn't work.

    this happened the third time today after I've been wiping my SSD and reinstalling OMV.
    I've been trying to set up OMV with smb, ftp, omv-extras5.14, docker and cockpit
    after some time it just stops responding to anything outside of my local network.
    meaning, I can't do apt-get update, nor install anything with apt-get. or even ping google.
    local network, web interface and ssh is all working.
    Last time I had this issue all I was using was stock OMV 5, latest update, and set up smb. no plugins.


    doing apt-get update gives me stuff like Temporary failure resolving 'deb.debian.org'
    and all /etc/resolv.conf shows is
    "# No DNS servers known."


    tried to add dns-nameservers 1.1.1.1 1.0.0.1 to /etc/network/interfaces. No luck.


    my Ubuntu Installation from my other SSD works just fine.


    any ideas?




    update:
    anyways, I fixed it.
    Whoever has the same issue as me, run omv-firstaid and do the network setup.
    make sure you select your actual network adapter and not docker.
    it looks like docker uses a virtual adapter that somehow got prioritized over my actual network adapter.

    I want to set up a user restricted SMB folder.
    what I have done so far:


    I created users and gave them the "user" and "sambashare" group
    then I enabled SMB with the following settings and share options:
    chrome_qqJhTMaLEX.pngchrome_SblxJwo3pV.png


    now, when I'm on my Windows 10 PC I can see "OPENMEDIAVAULT" in the network.


    after entering username and password I can also browse it and see the "nas-storage"
    but when I try to open it it gives me an error that I'm not permitted to access that folder.


    what did I do wrong, are the users may be set up incorrectly?


    I also tried this which is not working either.
    chrome_HhPbiHgCHq.png

    I just reinstalled OpenMediaVault on my Optiplex 3020 since I have used it with Ubuntu for a while.
    Now after installation it can't find any bootable media.


    UEFI is enabled
    Secureboot is disabled

    I forced the set up in UEFI mode since it was detecting an OS installed in legacy mode.
    All drives have been wiped and re initialized in GPT, so I'm guessing its counting my USB that I created with Rufus 3.8 and formatted in MBR, as always.


    Grub exists on the system SSD in the first fat32 partition, in "EFI/debian/grubx64.efi"
    followed by the Ext4 partition and a swap partition.


    I tried to add "EFI/debian/grubx64.efi" as a boot option in the bios, but it doesn't stick after applying and rebooting and goes back to "no bootable devices found"



    Any ideas?

    might probably do that but I was wondering if there was a plugin to freely change this as graphical settings in the web interface.
    I could make one though if I knew how... how does the interface work php/css/js?

    is there a way to limit the CPU performance for example using Intel Speedstep to limit the CPU to a minimal frequency ?
    I'm sure the Linux Kernel can do this by default by changing values like max_freq or governor in the systree but can this be set through the web interface?
    I don't really want the CPU to consume too much if I don't really need all its power for simple things like file transfer etc..


    And the bios also doesn't have much options since its a Dell Optiplex, I can only enable or disable turboboost or speedstep, but not manually edit the clock speed.

    Uh, yes it is. Proxmox and ESXi both have free versions. I have used both for years.

    it complains about me having no subscription when I try to run updates and says that me IP is not permitted to retrieve updates.
    And when I click on the link it leads me to their subscription page for yearly/monthly payments.