Posts by Komerad

    nfs shares not working. Resaving = nada.
    Trying to delete te recreate :



    Gues its all part of the same crap?

    I had this kind of issue too.


    Check :

    Code
    /etc/samba/smb.conf


    See if the shares are still there (below this line) :

    Code
    #======================= Share Definitions =======================


    Not sure but I tought mine were gone. I had to resave one to make them all come back.
    But then all paths got an extra trailing / witch had to be removed.



    I did not get any "keep or replace config" questions during update. :(

    All seemed to go well. Got this error for almost all disks. Only 2 mounted correctly.



    Fstab :


    Those are the only two mounted. the rest is empty?

    What's the deal with disks going offline?
    I had this problem in the beginning, i changed the sata controller. Did not have this problem anymore.


    Today I'm having it again. plugged in a new disk and bam. As soon as some larger files (even just cd size) are put on it happens.
    At devices serial number becomes N/A.
    In console it say its read only but even reading is problematic.
    The disk is ought to be ok.

    Autosub (installable with the script) connects to bierdopje to fetch subtitles.
    Under pressure of a lawsuit bierdopje is not offering subtitles anymore so autosub is not fetching any subtitles anymore.
    This is permanent.
    http://tweakers.net/nieuws/928…-van-stichting-brein.html


    English
    For the full version you may want to use Google Translate to translate this page


    Quote

    Sorry guys, there won't be any more subtitles on this site (or API) since we have been threated with lawsuits by a Stichting BREIN to stop with subtitles and are forced to pay them a fine to prevent those.
    We simply do not have the time, energy or money to go to court to battle them on this nonsense (which is exactly what they're after).
    Please ensure your API/RSS consuming applications are updated to not to use our - not longer existing - subtitle feeds/functions in our API and RSS feeds. We can also disable your API key, please open a topic for that in the "Lieve Adjes" forum.


    Full :
    http://www.bierdopje.com/forum…et-ondertiteling/1#259016


    autosub :

    Quote

    Auto Sub


    Automated bierdopje.com subtitle download written in Python! Because of the closedown of the subtitle department of bierdopje.com, this project is deprecated. Also this project is looking for a new lead programmer who is ready to take this application to the next level.


    http://code.google.com/p/auto-sub/


    So unless other places take it over its game over for autosub :evil:

    Backed up stuff and did a new install.
    Not much later another error popped up.


    Apt :


    Note that I have NOT installed the openmediavault-owncloud.
    It is also shown as not installed in the plugin overview.
    So no clue what installs owncloud.


    Trying to remove a plugin (latest i installed) :
    Header :

    Code
    Failed to execute command 'export LANG=C; apt-get --yes --auto-remove --purge remove openmediavault-rsnapshot 2>&1': Reading package lists... Building dependency tree... Reading state information... The following packages will be REMOVED: openmediavault-rsnapshot* 0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded. 1 not fully installed or removed. After this operation, 176 kB disk space will be freed. (Reading database ... 67855 files and directories currently installed.) Removing openmediavault-rsnapshot ... Purging configuration files for openmediavault-rsnapshot ... Processing triggers for openmediavault ... Restarting engine daemon ... Updating file permissions ... Updating locale files ... Setting up openmediavault-owncloud (0.5.2) ... chmod: cannot access `/var/www/owncloud/cgi/php.ini': No such file or directory dpkg: error processing openmediavault-owncloud (--configure): subprocess installed post-installation script returned error exit status 1 Processing triggers for openmediavault ... configured to not write apport reports Restarting engine daemon ... Updating file permissions ... Updating locale files ... Errors were encountered while processing: openmediavault-owncloud E : Sub-process /usr/bin/dpkg returned an error code (1)


    Body :

    Code
    Error #4000: exception 'OMVException' with message 'Failed to execute command 'export LANG=C; apt-get --yes --auto-remove --purge remove openmediavault-rsnapshot 2>&1': Reading package lists... Building dependency tree... Reading state information... The following packages will be REMOVED: openmediavault-rsnapshot* 0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded. 1 not fully installed or removed. After this operation, 176 kB disk space will be freed. (Reading database ... 67855 files and directories currently installed.) Removing openmediavault-rsnapshot ... Purging configuration files for openmediavault-rsnapshot ... Processing triggers for openmediavault ... Restarting engine daemon ... Updating file permissions ... Updating locale files ... Setting up openmediavault-owncloud (0.5.2) ... chmod: cannot access `/var/www/owncloud/cgi/php.ini': No such file or directory dpkg: error processing openmediavault-owncloud (--configure): subprocess installed post-installation script returned error exit status 1 Processing triggers for openmediavault ... configured to not write apport reports Restarting engine daemon ... Updating file permissions ... Updating locale files ... Errors were encountered while processing: openmediavault-owncloud E : Sub-process /usr/bin/dpkg returned an error code (1) ' in /usr/share/openmediavault/engined/rpc/pluginmgmt.inc:254 Stack trace: #0 [internal function]: OMVRpcServicePluginMgmt->remove(Array, Array) #1 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array) #2 /usr/share/php/openmediavault/rpc.inc(62): OMVRpcServiceAbstract->callMethod('remove', Array, Array) #3 /usr/sbin/omv-engined(495): OMVRpc::exec('Plugin', 'remove', Array, Array, 1) #4 {main}


    Might be me but looks like something is just screwed up as is.
    It was possible to apt-remove openmediavault-owncloud. Error is gone.

    I did not apt-get anything recently (error might be around longer aswel as i had no need to apply changes recently neither.).
    I spotted it with an apt-get update to see if there was something.


    nfs section :




    Apt history (last succesfull + first one with error):



    I'm patient, no clue what went wrong nor how to fix it. (apt-get clean, apt-get -f install,..) no succes.

    Today i created an nfs share.
    I have the yellow "configuration changed, apply" bar.
    But I always get error :


    Failed to execute command 'export LANG=C; monit restart collectd 2>&1': monit: Cannot connect to the monit daemon. Did you start it with http support?


    Code
    Error #4000: exception 'OMVException' with message 'Failed to execute command 'export LANG=C; monit restart collectd 2>&1': monit: Cannot connect to the monit daemon. Did you start it with http support?' in /usr/share/php/openmediavault/monit.inc:92 Stack trace: #0 /usr/share/php/openmediavault/monit.inc(58): OMVMonit->action('restart', 'collectd', false) #1 /usr/share/openmediavault/engined/module/collectd.inc(53): OMVMonit->restart('collectd') #2 /usr/share/openmediavault/engined/rpc/config.inc(198): OMVModuleCollectd->startService() #3 [internal function]: OMVRpcServiceConfig->applyChanges(Array, Array) #4 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array) #5 /usr/share/openmediavault/engined/rpc/config.inc(247): OMVRpcServiceAbstract->callMethod('applyChanges', Array, Array) #6 [internal function]: OMVRpcServiceConfig->applyChangesBg(Array, Array) #7 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array) #8 /usr/share/php/openmediavault/rpc.inc(62): OMVRpcServiceAbstract->callMethod('applyChangesBg', Array, Array) #9 /usr/sbin/omv-engined(495): OMVRpc::exec('Config', 'applyChangesBg', Array, Array, 1) #10 {main}


    When apt-getting :




    This is caused by and solved with?

    Updated sickbeard and got hell with it, problem solved.
    With rebooting i stubled upon a minor issue with mysql this locking the xbmc out. Problem solved.


    Now :)


    1. Ok so confirmed scanning/editing through browser does not work. Dont need to look further into it then.
    2. For app I'm using yatse, it looks shit on my very small screen (seems more designed for tablets or at least bigger screens) but it works like a charm.
    3. Detection of moving files : I'm using watchdog addon for this seems to work fine altho i think it does not realy scans on every change when the pi is in screensaver mode.
    4. Thx, might just cron those.
    5. Client updates with its scraper, putting plot into mysql. Wont work like that if i would update from server.
    6. Testing ember, will check filebot too!



    EDIT :


    I have tested openelec. It loaded the library from the mysql, i had no artwork. Cleaned the library and totaly lost it in the process (was trying to get the artwork there.)
    How to do this properly? I mean i can connect but then what? Without breaking it.

    Ok its kind of working :


    When i update on the client the movies are stored on the sql server.
    Still a few questions. (almost morning, but its on todo for next weekend.)


    1. Neither client nor server allow to update through the web browser.(only remote, movie lists, play movies etc) anything special on that?
    2. The app(xbmc remote) on the smartphone cant retrieve the movies. remote function still works normal. Is this normal?
    3. If movie paths change (will happen) does an update change the paths then?
    4. How exactly do I perform an update?
    5. Can i set the scraper stuff somewhere so it uses the correct ones?
    6. Is there an editor to rename, rescrape, get artwork etc?
    7. Webgui from the server does not open in ff. Does work in ie.
    8. I have old paths that seem sticky (removed the movie34.db or whatever its called.) i can live with that but i found out that the artwork from those old paths isnt in the sql now. (client has them, server does not.)


    regards.

    Aha right an xbmc to share.
    Full automation nice, im at step 5 for the raspberry.
    have step 5 with yamj for the popcorn hour but might replace with a rasp aswel (if the rasp performs well, have thrown some very hq h264 stuff at it it doesn seem to like.)
    Gues friday night will be the night :)


    *edit gona be a long night indeed. Steps done but no web interface.
    Log :