Posts by topi

    Hi geaves,
    you may first check and install the necessary Linux Headers for virtualbox.

    apt-get install linux-headers-$(uname -r)

    and then try this three commands:

    dpkg-reconfigure virtualbox-dkms
    dpkg-reconfigure virtualbox
    modprobe vboxdrv

    Hope this helps.

    Hi David,
    I really would second your suggestion.
    I tried to update from OMV 2-->3 with the advised "fresh install" way but it took me hours fiddling around in different configs from plugins Samba shares , monitoring etc. I gave up, frustrated and seeing no end. Then weeks later I tried it again via an in-place update. Finally I succeeded there, but again with the cost of approx 5 hours to detect, analyse and fix several issues related to the update. Moreover, it was only possible with the help of the friendly folks here in the forum and at one point even the help of of the main developer was necessary.
    However, I think it would be a good invested time to develop such a sort of centralized settings file which could be ex- and imported. However I do not know how complex this task might be nor how much development time it would consume.

    Dear votdev,
    thank you very much for getting in this issue and finally fix it.
    It was:

    -rw-r----- 1 root root 55419 Dec 10 11:42 config.xml

    After applying your fixes (updating database permissions) it is:

    -rw-rw---- 1 root openmediavault-config 66344 Dec 14 15:16 config.xml

    No more error messages in /var/log/nginx/openmediavault-webgui_error.log and setting the session timeout to 0 disables the timeout now as intended :-)

    So, I have tested the following docker images from

    - Piwigo. Great piece of software, but it needs a database and it duplicates all my files, forcing me to maintain 2 copies of all the pictures, one in the sourcer folder and another one in the cache disk where the container is running.

    I gave up upon this situation a few weeks ago due to my limited technical know how. I always thought that there must be a way to "connect both worlds" without having to duplicate all the images but I did not find a way. Installing Piwigo on OMV/Debian might be demanding, I don't know (own database, own nginx in parallel to OMV?). But perhaps you will find a good way to go. Thumps up!

    Thanks votdev for diving into this issue.
    52% of my root file system are used. Following your suggestion, I took a look into /var/log/nginx/openmediavault-webgui_error.log and yes, I find several, repeating error messages there (see below).
    The permissions are:

    -rw-r--r-- 1 root root 1167 May 5 2017
    -rw-r--r-- 1 root root 15279 May 5 2017
    -rw-r--r-- 1 root root 18383 May 5 2017
    -rw-r--r-- 1 root root 9297 Dec 1 15:32
    -rw-r--r-- 1 root root 1036 May 5 2017
    -rw-r--r-- 1 root root 16513 May 5 2017
    -rw-r--r-- 1 root root 11730 May 5 2017

    How would I fix the permission (?) issue which is mentioned there?
    Thanks in advance,

    Hi there,
    when I select a rsnapshot job and press "Run" the popup window "Execute Backup Job" shows first "Please Wait" and stays then blank. In the rsnapshot log there is a corresponding log entry which shows the executed job without error.
    Does someone has a hint how to bring back the content (rsnapshot status messages) in the blank window?
    Thanks in advance,

    thanks @Wolf2000 and @votdev for your hints.
    I emptied the browser cache several times and I applied the settings change after pressing the save button. I even moved to a PC which has not had any contact to my OMV Erasmus system before. Unfortunately the issue remains. Meanwhile I could count the minutes after the OMV session in the web GUI times out: it is 5 minutes.
    It seems to me that value <timeout>0</timeout> in the config.xml is not taken in account. However, you may have some more hints for me?

    Hi there,
    in the section "General Preferences" I set session timeout to 0 expecting the the automatic logut to be disabled. In/etc/openmediavault/config.xml I find this section:

    <!-- Web administration configuration - Do not add any configuration here -->

    So it seems ok for me. However, after a few minutes (I did not count it) of inactivity I am getting logged out from the OMV GUI. After rebooting the OMV system the situation does not change.
    Has someone a hint for me how to disable automatic logout?
    Thanks in advance,

    Yes tacioandrade I would opt for that functionality, too. However, it seems to be not that easy to accomplish and OMV seems to have tight developer ressources.