Posts by pug_ster

    There's nothing wrong with your nextcloud docker. Rather with your nextcloud.subfolder.conf file. Change the "proxy_max_temp_file_size from 2048m to 1024m. That's what's worked for me.

    There's nothing wrong with your nextcloud docker. Rather with your nextcloud.subfolder.conf file. Change the "proxy_max_temp_file_size from 2048m to 1024m. That's what's worked for me.

    I have a similar issue with emby where the metadata is not downloading and it is probably due to me how I name my files and emby would not recognize them. IE. if you have your movie like yourmovienamehere.mp4, it would not work because there are no space or period between the words. I ended up installing radarr, add the movie, click on "wanted" sign, and do a manual import of the movies folder and then radarr will put the metadata back to emby. There's a whole process of installing linuxserver/radarr:arm32v7-latest, linuxserver/jackett:arm32v7-latest and getting to work with plex. You can watch techno dad life in youtube on how to get this configured.

    Assuming that you have letsencrypt installed properly, it is easy to install nextcloud and even get it working in your existing server. I installed mariadb and then created the database. When I installed nextcloud, I didn't use my precious port 443 or 80, but you can use something like this.


    -p 3443:443 \
    -p 3080:80 \


    I didn't use nextcloud's official build but from linuxserver\nextcloud because their builds are compatible with my raspberry pi.


    Assuming that you mapped your nextcloud subdomain via letsencrypt, you can configure your nextcloud.subdomain.conf like this.


    I don't know what kind of server are you running, but on my raspberry pi, I put in proxy_max_temp_file_size should be configured as 1024m; instead of 2048m for some reason. Don't forget to configure your proxy_pass to https://<yourIp>:3443 to match what you have in your nextcloud docker.

    https://www.raspberrypi.org/forums/viewtopic.php?t=244130


    Thanks for replying. I ran free-m command and it turns out that it was using 100mb of swap file. This was installed by default when putting in the raspian buster's image and I don't need it because I got the 4gb version of the rpi4. According to this thread in rpi's forums, I was able to disable and remove the swap file partition using this command. Thanks for replying.


    sudo dphys-swapfile swapoff && \
    sudo dphys-swapfile uninstall && \
    sudo update-rc.d dphys-swapfile remove

    Running OMV 5 on Raspberry Pi 4. I would like to decrease the wear and tear of the micro sd card so I won't have to replace it soon. I have an usb 3 mechanical hard drive attached so it is possible to change the swap file there or I should disable it altogether. Thanks. Also, does the flashmemory-plugin in OMV work at all for this? Thanks.

    In the thread, you have to go to the GUI interface in OMV,


    System | Network | Interfaces | select interface, press Edit, scroll down to Advanced settings | Enter DNS Servers separated with commas.

    I realized the letencrypt, radarr, sonarr is using the same network so maybe that's why it works. For the portainer.subfolder.conf, I changed the proxy_pass http://$upstream_portainer:9000 to http://<myinternalip>:9000 and it works fine now. But for transmission, I did the same and it gave me a different message.



    409: Conflict


    Your request had an invalid session-id header.
    To fix this, follow these steps:

    • When reading a response, get its X-Transmission-Session-Id header and remember it
    • Add the updated header to your outgoing requests
    • When you get this 409 error message, resend your request with the updated header

    This requirement has been added to help prevent CSRF attacks.
    X-Transmission-Session-Id: 7BZE6tRGs7claK7lNJ1veapsqGRT4AV3ifWX4aVHMlZlibju

    Just had some time. First of all, many thanks to everyone for helping. I was able to put a password and put in reverse proxy subfolder and it worked great for https://mysubdomain.duckdns.org /radarr/ and https://mysubdomain.duckdns.org /sonarr/.


    However, for some reason when I tried it for other websites like https://mysubdomain.duckdns.org /portainer/ and https://mysubdomain.duckdns.org /transmission/ it does not work, it give me "502 bad gateway" error. Both dockers uses the default ports 9000 and 9091 respectively and both subfolder.conf has those ports listed. Both containers' conf file says "portainer does not require a base url setting" Is there a reason why this is happening?

    So this is the contents of my /etc/fstab file. I am using a raspberry pi 4 with OMV 5 but the commands to disable using my sd card as swap file here:


    • Add noatime and nodiratime to root options. See before and after example lines:
      BEFORE:UUID=ccd327d4-a1ed-4fd2-b356-3b492c6f6c34 / ext4 errors=remount-ro 0 1AFTER:UUID=ccd327d4-a1ed-4fd2-b356-3b492c6f6c34 / ext4 noatime,nodiratime,errors=remount-ro 0 1
    • Comment out the swap partition. See before and after example lines (only need to add a # to beginning of the line):
      BEFORE:UUID=a3c989d8-e12b-41d3-b021-098155d6b21b none swap sw 0 0AFTER:#UUID=a3c989d8-e12b-41d3-b021-098155d6b21b none swap sw 0 0

    But I don't see what to comment out or edit in my fstab file. Thanks.


    pi@raspberrypi:/etc $ more fstab
    proc /proc proc defaults 0 0
    PARTUUID=6c586e13-01 /boot vfat defaults 0 2
    PARTUUID=6c586e13-02 / ext4 noatime,nodiratime,defaults
    0 1
    # a swapfile is not a swap partition, no line here
    # use dphys-swapfile swap[on|off] for that
    # >>> [openmediavault]
    /dev/disk/by-label/HDA /srv/dev-disk-by-label-HDA ext4 defaults
    ,nofail,user_xattr,noexec,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfs
    v0,acl 0 2
    # <<< [openmediavault]
    pi@raspberrypi:/etc $

    Okay, I think I am getting the hang of this. I have 2 questions. Let's say that I have my mysubdomain.duckdns.org and domains radarr.mysubdomain.duckdns.org registered. I can see in let's encrypt's cert saying that subject alternative name in my letsencrypt cert has this subdomain exist. I just simply have to rename the file radarr.subdomain.conf.sample to radarr.subdomain.conf and restart the letsencrypt docker and it should work, right?


    2nd question, is going back to the first question. I would like to secure my domain https://radarr.mysubdomain.duckdns.org site with a username and password. I read everywhere about creating an account with the .htpasswd file, but I don't know the command to create an account and the location of where this .htpasswd file to put in. How do I do that? Thanks.