Posts by andy26

    Hi @TechnoDadLife


    I went through your videos and I must say awesome work you have done by creating these videos....!!
    And by looking @ your videos I am also exploring (nextcloud, letsencrypt) using docker


    BTW i went thru your latest one
    https://www.youtube.com/watch?v=T_2csDJFa2k&t=762s
    in this video when @ around 22 mins..you connected the nextcloud on a tablet
    May i ask what is the source of internet connection -Is the connection used while setting up the nextcloud + and configuring it on tablet is same or they both are in entirely different networks


    Reason of asking is I am having an issue while accessing the nextcloud from outside my home network.


    Thanks,
    Andy

    Brief till now:-
    I was able to create a new cert and able to host the nextcloud -it is working from my home network
    When i try to access the same using my phone in chrome with the LTE network, it is throwing an error as


    The site can't provide a secure connection
    <mydomainname.URL> sent an invalid response
    Err_SSL_Protocol_Error


    Not sure if the cert is fine, but I can see all the relevant files in the letsencrypt container.


    Can someone throw any pointers on the same ,as to how to resolve this problem





    Meanwhile I have a quick question--
    docker logs -f letsencrypt
    This command checks the logs of letsencrypt, but at the end it went to create the cert for the domain.
    Is there a way by which I can skip the cert creation as I think because of the same reason I went out of limits.

    Thanks a lot @ Agricola
    In the heat of hit and trials I deleted my environment and created it back again and then after multiple attempts I reached at the rate-limits
    https://letsencrypt.org/docs/rate-limits/


    So now I am waiting to reach at a point where in I will be able to create a certificate.
    Meanwhile I check and find that port 80 is being blocked by my ISP, and they are not going to open it.


    Hopefully, very soon I will be back again with the results ...


    Will let u know how it goes ...

    Thanks @Morlan
    Initially i changed the value to 1024 as i was getting the error while checking the letsencrypt error, however I changed it back to 2048, and ran it again
    And finally it worked for me.


    And for the first time I am able to login @ nextcloud with the domain name URL.
    Still the local Ip is not working for me, not sure why.?


    And one more thing when I am connecting with URL https://nextcloud.mydomain/ it works for me.
    Strangely I am not able to connect to the same URL outside my network, this shouldn't be the case though...!!


    Where I am going wrong now.. food for thought..


    Thanks,
    Andy

    Sure, here it is


    # make sure that your dns has a cname set for nextcloud
    # assuming this container is called "letsencrypt", edit your nextcloud container's config
    # located at /config/www/nextcloud/config/config.php and add the following lines before the ");":
    # 'trusted_proxies' => ['letsencrypt'],
    # 'overwrite.cli.url' => 'https://nextcloud.your-domain.com/',
    # 'overwritehost' => 'nextcloud.your-domain.com',
    # 'overwriteprotocol' => 'https',
    #
    # Also don't forget to add your domain name to the trusted domains array. It should look somewhat like this:
    # array (
    # 0 => '192.168.0.1:444', # This line may look different on your setup, don't modify it.
    # 1 => 'nextcloud.your-domain.com',
    # ),


    server {
    listen 443 ssl;
    listen [::]:443 ssl;


    server_name nextcloud.*;


    include /config/nginx/ssl.conf;


    client_max_body_size 0;


    location / {
    include /config/nginx/proxy.conf;
    resolver 127.0.0.11 valid=30s;
    set $upstream_nextcloud nextcloud;
    proxy_max_temp_file_size 1024m;
    proxy_pass https://$upstream_nextcloud:443;
    }
    }

    Thanks Macom, i followed the same link ..and figured out the different issues stated in it.
    But still not able to find out..where I am i going wrong in it.


    To me it seems like something trivial I m missing in the configuration, not sure where..?


    Please can u suggest me ..?


    Thanks,
    andy

    <Initial Link Followed>


    Hi All,


    Thanks for providing valuable inputs for setting up the nextcloud with the Lets encrypt , well for me this is the first time I am setting it up and after installing couple of times , I am able to successfully create the certs and in the console I can see the message "server ready".


    What I have done so far:-

    • Install OMV5 and it is running on default port on Rasbian buster.
    • Install docker using OMV-Extras
    • Install Portainer and cockpit, working fine.
    • Used the link <Nextcloud subdomain reverse proxy example> for preparing the compose.yml, with the letsencrypt port as ports:
      - 444:443
      - 81:80
    • Pass thru all the errors and finally i can see the certs are created and I can see the message as server ready.
    • Navigate thru the path of subdomain conf and rename the sample as .conf file, changed the server_name mydomain.*;
    • Navigate thru \\<path>\appdata\nextcloud\config\www\nextcloud\config\config.php and added the following lines 'trusted_proxies' =>
      array (
      0 => 'local ip:444', # This line may look different on your setup, don't modify it.
      1 => 'nextcloud.mydomain name',
      ),
      'overwrite.cli.url' => 'https://mydomain name/',
      'overwritehost' => 'mydomain name',
      'overwriteprotocol' => 'https',
    • Post that restarted the nextcloud and letsencrypt container.
    • And everytime when i try to access the URL as https://nextcloud.mydomain name/ , I am getting the message as Welcome to our serverThe website is currently being setup under this address.For help and support, please contact: me@example.com

    2 questions :
    how can i pass thru and should be able to login @ nextcloud, as I am not able to login even once
    how can i access nextcloud from the local machine using local ip as whenever i tried as https://localip:444/ it is not working.


    It seems like I am missing some trivial thing in this configuration, but not sure where.
    please suggest...and shed some light on this...!!


    Thanks,
    Andy