Posts by CarlB

    Thank you both for the answers. Effectively the problem was that my ups was setted by default to no switches itself off after a power outage. I resolved the problem by connect the ups to my PC and by modify this option via the software provided by the manufacturer. Then I set the restore power policy on the BIOS to "Always ON" and everything work as I want.


    Furthermore, after doing some test and inspecting the parameters visible by the OMV-Web-UI I found that the behaviour of the system is regulated by 3 parameters (see attachments below) and is like this:


    1) Power Outage occures --> the UPS safely shutdown the server after "ShutdownTimer" seconds (in my case 30) and switches itself of after "ups.delay.shutdown" seconds (in my case 30) after the shutdown of the server.


    2) After Power is Restored the UPS come back on (only if a minumum of "ups.delay.start" seconds (in my case 180) have passed) and the omv-server restart.


    The only editable parameter seems the ShutdownTimer . The other two (visible via the services tab of the OMV-Web-UI) seems not editable


    So, problem Solved. Thank's again.

    Hi!


    I have an ups connected via usb with my omv-server. I have installed the NUT-Plugin and it's great! I have set that in case ups goes on battery mode the nas is safely shutdown in 15 seconds.


    I would like that the omv-server also automatically-restart when (and only when) power is restored (ups return in normal mode). How can I do that?


    Browsing the internet I've read that I should set the Power Restart Option in the BIOS on "Always On". Is the correct way? I suspect that if I set "Always On" in case of power failure the omv-server is safely shut down after 15 seconds but if the power outage is persistent with this option the server is restarted with the ups still in battery mode and I don't want it.


    Thanks

    Problem solved. I leave a summary of the procedure followed which can be useful for other novice users like me. Any comments/suggestions or improvement to the following configuration are welcome.


    1) From the OMV-WebUI create a user called 'docker' and give him r/w permissions to each shared folder to be synchronized


    2) Took the UID and GID of the docker user from CLI by executing : id docker


    3) Create and Start the Container by executing the following:


    Pull the image ------> docker pull syncthing/syncthing:latest


    Code
    docker create --name=syncthing --network=host \
    -e PUID=1005 -e PGID=100 -e TZ=Europe/Rome \ # Whit PUID and GUID from step 2)
    -v /srv/dev-disk-by-label-DATA/:/DATA \ # mountpoint of the shared folders
    --restart unless-stopped syncthing/syncthing:latest
    docker start syncthing


    4) Browse to Syncthing WebUI at 192.168.1.XXX:8384 and follow the wizard to set username and password.


    5) Connect the Remote Devices and Configure the Shares


    6) To Avoid permission problems go to 'Actions' -> 'Advanced' and check the 'Ignore Permission' box for every shared folder (see the attachments).

    (If 'Ignore Permission' is left unchecked the syncthing service create the file with r/w permission for the docker user but with r-only permission for others user)

    Hi everybody. I have installed the syncthing/syncthing container on my OMV5 machine by the following procedure:


    Code
    -> docker pull syncthing/syncthing:latest
    -> docker create --name=syncthing --network=host \
    -e PUID=1005 -e PGID=100 -e TZ=Europe/Rome \
    -v /srv/dev-disk-by-label-DATA/:/DATA \
    --restart unless-stopped syncthing/syncthing:latest
    -> docker start syncthing

    I use UID and GID of the 'docker' account (an account specifically created to run the syncthing service that have r/w/x permission on all the shared folder to be syncronize in order to use the same service/container to sync the shares of the different users which have the same permission on the respective folders).


    The permission are like this docker user rwx on Folder1 and Folder2 and user1 rwx on Folder1 & no access on Folder2 | user2 no access on Folder1 & rwx on Folder2


    The problem is that every file created by the syncthing service in the shared folder of the specific user (e.g. 'file' on Folder1) it's owned by docker account and it's not anymore editable by the user1 (unless going every time in the omv web gui and restore the permission on every subfolder of Folder1 again).


    To fix this issue i edit the PUID variable setting it at 0 (root account) and everything work fine but the syncthing service tell me that running the container as root shouldn't be done.


    So what I have to do? I have to run a specific syncthing container for every user to avoid permission problems or can I leave the container running as root without issues?


    I hope i have explained the problem correctly.

    Do you mean this thread? OpenVPN-Renew CRL


    If I understand correctly the plugin stop work when the certificates are revoked and they have to be updated manually.


    I execute openssl crl -in /etc/openvpn/pki/crl.pem -text to check my expiration date and i get Next Update : Jul 20 14:54:17 2020 GMT.


    So before Jul20 i have to renew certificates by executing : /opt/EasyRSA-3.0.6/easyrsa gen-crl and the plugin continue work. It's correct?


    Finally, just for curiosity, have you modified the server.conf file too to get the plugin work?

    Hi, for making openvpn plugin work on OMV 5 you have to follow these steps (for me works):



    0) On your router open the UDP 1194 port pointing your server ip (e.g. 192.168.1.xxx)


    1) On the Control Panel in the Web GUI set the following :


    --------------------------------------------


    GENERAL


    Enable -> ON
    Port-> 1194
    Protocol -> UDP
    Use Compression -> ON
    PAM Authentication -> ON
    Extra Options -> NONE
    Logging level -> Normal Usage output


    VPN NETWORK


    Adress -> 10.8.0.0
    Mask -> 255.255.255.0
    Gateway -> Select Your Connection (e.g. eth0)
    Default gateway -> ON
    Client to client -> OFF


    DHCP options


    DNS Server(s) -> NONE
    DNS search domains -> NONE
    WINS Server -> NONE


    PUBLIC


    Public Adress: yourdomain.duckdns.org (or other ddns or your static ip if you have one)


    --------------------------------------------
    Then Save and Apply


    2) Generate the certificate for the users on the WebGUI ( you may also do that in a second moment)


    3) Then SSH into your server and cd /etc/openvpn/ and nano server.conf


    4) Remove from the server.conf file the following line --> ;push "route 192.168.1.0 255.255.255.0" then Ctrl+X ->Y->Enter to apply changes


    (You can also delete -> ;push " route client-to-client" and other commented settings to make the file more clean but it is not necessary to get the plugin work. I don't know the reason why deleting the line indicated in 4 must be done to get the plugin work even if it's a commented setting too)


    5) cd ~ and service openvpn restart



    After this mod in the server.conf file the vpn works. The server.conf remains updated (also after reboot the machine) until you change something in the web GUI control panel of the plugin, then the wrong line appear again and you have to reupdate the server.conf file by repeat 3) 4) 5) to make the plugin work again.