Posts by NAST

    Quote

    ..The jessie comment wasn't for your post. It was more about the outdated resources comment....


    ( If the post was meant for me... which I kind a doubt)
    I was not talking about Jessie at all - the link has been out of date for quite some time now.

    I opt for OPVN.


    But something I really would like to see - an updated list of plugins that are avaialable. http://omv-extras.org/simple/ does not seem to get updated anymore.
    The plugins are one of the powerfull features of OMV - but it is very hard for a newbie to find out what a plugin does and which ones can be used with say 1.X and with the upcoming 2.X.


    I think it gets even more important - with the focus of development shifting away from 1.X and geared more towards 2.0 (for which an info can not be found anywhere at predominant place).
    If I am all wrong please correct me - but if not - well, I would happy to see the concern picked up - as I believe it is hurting OMV big time - at least for the huge fraction of the unexperienced and new fans.


    Thanks,
    NAST

    I have to say - I do not see the panel for 'developer features (experimental) in the OMV-extras.org.
    How can I activate it?


    NAST


    BTW the option OMV-extras.org came only by after rebooting when the plugin for this enabled the first time.

    With the update of OMV to 0.5.25 and the recent update of the plug in - the installation went fine - no error messages.
    But i have to say - that I have not tried much yet.


    See the recent blog entry
    http://blog.openmediavault.org/?p=1124


    After the installation - you are supposed to find owncloud here:

    Code
    http(s)://xxx.xxx.xxx.xxx/owncloud.


    where 'xxx.xxx.xxx.xxx' has to be replaced by the IP address of your OMV installation.


    NAST

    Quote from "subzeroin"

    What does

    Code
    apache2ctl configtest

    say?


    it brought something like:

    Code
    SYNTAX ok


    Before that I ran all commands again... individually and carfully typed...
    after an

    Code
    ap-get autoremove

    and a reboot the GUI is back!


    I might have had a typo... before.
    Thanks, guys!


    NAST

    Quote from "ryecoaaron"

    apt-get remove --purge openmediavault-owncloud
    rm -rfv /etc/apache2/openmediavault-webgui.d/owncloud.conf /etc/apache2/sites-available/openmediavault-owncloud /var/www/owncloud


    Thanks for the advice
    I did as prescribed a bunch of directories got removed - but it did not bring the GUI back... same as before.
    Some apache2 still failing...


    Any further idea?


    NAST

    For now it broke my machine - at least I can not access the GUI after a reboot.
    I did try to remove the plug in though...


    Even after some tinkering - the installation is dead ... like a dead horse...
    The advertised IP does do anything.


    The log shows some errors.. apache 2 does not start..


    So be careful,
    NAST

    Quote from "ryecoaaron"

    Maybe you need to a couple of days before installing new plugins or try them on a virtual machine first :) Let the bugs get worked out :)


    Quite right - but I thought there would some kind of testing repo which there is for 3rd party plugins.. I believe.
    But it seems that there is not one for the default plugins... funny.


    I know things can break... ;-) !
    But I am glad to know that it is being worked on..


    NAST

    Quote from "tekkbebe"

    Yeah, he is testing. If he is busy he does not always make a blog entry.


    i sure understand - the same was with the 0.5.19 release which fixed some potential serious issue for 'new installers (-> could not mount drives).
    That one was also not mentioned - I wonder if this means something...


    I always check the blog for updates...


    Thanks,


    NAST

    Quote from "ryecoaaron"

    I think Volker pulled it because I don't have it in my list even after a reboot.


    Well, the plugin is still with me - I did reinstall - which went ok but I leave it for now disabled.
    I also could they hit the apply button w/o any trouble...


    Wonder why I always seem to stumble across that kind of issues... lately.
    Thanks for the quick replies though ;-) !


    NAST

    Quote from "tekkbebe"

    I think Volker put it there a bit early.... He is working on it but not done yet.


    I would have to agree... did it make to the repository by accident then?
    Also - OMW was updated to 0.5.23... which is also not mentioned in the blog..maybe this was also not meant to be...


    NAST

    Quote from "ryecoaaron"

    There is an update. Do you have 0.5.0 or 0.5.1 installed? Haven't tried it myself.


    As stated I just have tried it and the plugin list did say 0.5.1...

    Code
    ...owncloud_5.0.13-1_all.deb...


    Is what I see during the install...
    Now I attempt an reinstall of the owncloud plugin,..let's see..


    NAST

    The system remain in the state of wanting me to apply the configuration - which not work - it does not matter, if I enable the owncloud plugin or not.


    Even the removal/purging of the plugin does not change this - every 'apply action' results in:


    Code
    Error #4000: exception 'OMVException' with message 'Failed to execute command 'export LANG=C; invoke-rc.d 'apache2' graceful 2>&1': Syntax error on line 7 of /etc/apache2/openmediavault-webgui.d/owncloud.conf: Wrapper /var/www/owncloud/php-fcgi cannot be accessed: (2)No such file or directory Action 'configtest' failed. The Apache error log may have more information. failed! invoke-rc.d: initscript apache2, action "graceful" failed.' in /usr/share/php/openmediavault/initscript.inc:169 Stack trace: #0 /usr/share/openmediavault/engined/module/apache.inc(59): OMVSysVInitScript->invoke('graceful') #1 /usr/share/openmediavault/engined/rpc/config.inc(198): OMVModuleApache->startService() #2 [internal function]: OMVRpcServiceConfig->applyChanges(Array, Array) #3 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array) #4 /usr/share/openmediavault/engined/rpc/config.inc(247): OMVRpcServiceAbstract->callMethod('applyChanges', Array, Array) #5 [internal function]: OMVRpcServiceConfig->applyChangesBg(Array, Array) #6 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array) #7 /usr/share/php/openmediavault/rpc.inc(62): OMVRpcServiceAbstract->callMethod('applyChangesBg', Array, Array) #8 /usr/sbin/omv-engined(495): OMVRpc::exec('Config', 'applyChangesBg', Array, Array, 1)