Posts by Tanosuke Hata

    So, Transmission is stuck (again), this time while looking at the error messages I found out that this is a recurrent one: error unable to save torrent file no file descriptors available, especially for newly added files.


    By googling I found out that this could be a "file descriptor" limit problem, I did all the checks and generally the limits sets in my system are much higher than the advised quantity, except for one value: ulimit -Sn 1024 this should be at least 16384.


    The solution suggested in the article is this:


    If you’re working with hundreds of torrents (each with dozens to hundreds of files) with Transmission, this isn’t enough. To let a user have a few thousand (in the below example, 16,384, with 128 more for the hard limit), create a new file /etc/security/limits.d/debian-transmission.conf


    Code
    sudo sh -c "echo debian-transmission soft nofile $(dc -e '2 14 ^ p')" > /etc/security/limits.d/debian-transmission.conf


    Since my transmission is inside a container I'm sure it's of no use to create this file, so, how do I increase the "soft nofile" limit for transmission?

    I don't use Volumes, I use Binds instead. I suggest you do the same.

    I too use binds, that's what I have to put inside the transmission configuration when I create the container (if I didn't do something wrong this time, which I probably did).


    Quote

    Also, this thread has drifted off topic. You may want to start a new one.


    OK, I'll mark this solved because the original problem was indeed solved.

    I can't say what went wrong there without seeing the bind statements

    That's exactly what I thought I provided with that picture... ^^




    After an extensive search in portainer I found this instead:


    jG6JMaH.png


    This is wrong of course, the /downloads folder should be the one that ends in "DISCO2TB/Torrent", can I change it?


    Maybe if I click "Remove this volume" I can add a different one from this same interface? (I'm hoping it'll be so simple ^^)

    I realised why transmission is behaving that way: he's downloading the torrents inside the docker folder, instead of the folders I assigned it, that's why it doesn't find the complete ones.


    The folder it's using is something like this:

    \docker\volumes\e7c64b0f98y61c37p0fb3409639b6e1da48e5e3cf13e19d309d524a8ebfc92\_data





    This is the transmission container's configuration:

    6W19Twy.png


    The one highlighted should be the "/downloads" folder, is this correct? Or did I mix them up?

    You are trying to use a container from the wrong architecture. Not sure what system you are using but you probably need armhf instead of amd64

    My board has an Atom x86 (64bit) processor embedded. By deleting and reinstalling the Transmission container in Portainer now it works (but it now wants to restart downloading from zero even the completed torrents, this is a very strange behaviour from transmission, I may have to restore the system anyways, after all, the "guru meditation" error is stil not solved).


    On my system the User: admin is in the Groups: users and openmediavault-admin (you may or may not have this group)


    But why that group doesn't even exist in my system? What's wrong with it?

    I have these "openmeddiavault-" groups but not openmediavault-admin:



    openmediavault-config:x:999:openmediavault-webgui

    openmediavault-engined:x:998:openmediavault-webgui

    openmediavault-webgui:x:997:



    My OMV version is 5.3.8.-1, it should have that group.


    Quote

    The only role the admin user has is to access the OMV Web GUI.


    Oh OK, that is kind of sorted out (if we don't count the "session expired" error).

    I managed to login to Portainer again (by reinstalling it from the "OMV-Extras" interface), the problem is that I still cannot start transmission, when I try I get this error:


    Failure

    OCI runtime create failed: container_linux.go:349: starting container process caused "exec: \"/init\": permission denied": unknown



    EDIT: to be clear, "admin" now is part of these groups: "adm root users docker"

    With "adm" being the main one, is this correct? (I added it to all these groups, before that it was just part of the "users" group).

    conect by shell ( SSH) like root, and use omv-firstaid


    PD: openmediavault-admin is only for OMV5, sorry if I asume that you have OMV5


    I do have OMV5 [5.3.8.-1 (Usul)] .


    I added admin to the "adm" group. After a minute or so that I'm logged in I still get the guru meditation error, it says something like: "Software failure. Press left mouse button to continue, the session is expired". Although now I can login again without resetting the password with omv-firstaid.


    Other than this, the problem is that I cannot access Portainer anymore, I get "ERR_CONNECTION_REFUSED" when I try to log in.


    I just noticed that the Portainer admin password is different than the OMV admin password, is this correct? Or should I have used the same password?


    Is there a way to reset the Portainer password too? (and to solve that "software failure" problem, otherwise I'll clonezilla restore the whole system).

    Not unless you made them the same.


    If you never changed the webUI password, the default password is openmediavault (username admin).


    If that still doesn't log you in, SSH the server as root, run omv-firstaid and change the web panel password there. That should get you logged in to the webUI then you can try figuring everything else out.


    I did it and now I can access the web interface, I still can't access portainer though (nor connect to its supposedly running apps). Also, see below


    add user admin to admingroup: 'OMV_WEBGUI_ADMINGROUP_NAME' does not exist


    The "openmediavault-admin" group does not exist, should I create it?


    P.S. "admin" belongs only to the "user" group, this probably happened when I reset the permissions.



    UPDATE: after a couple of minutes I was logged in I got a kind of "guru meditation" error message and now I'm locked out again:


    Code
     Error #0:
    OMV\HttpErrorException: Incorrect username or password. in /var/www/openmediavault/rpc/session.inc:145
    Stack trace:
    #0 [internal function]: OMVRpcServiceSession->login(Array, Array)
    #1 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)
    #2 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('login', Array, Array)
    #3 /usr/share/php/openmediavault/rpc/proxy/json.inc(97): OMV\Rpc\Rpc::call('Session', 'login', Array, Array, 3)
    #4 /var/www/openmediavault/rpc.php(45): OMV\Rpc\Proxy\Json->handle()
    #5 {main}       

    Yesterday I was experimenting with adding new users and assigning them specific shares, in the end I made it and I got what I wanted, but after a while I had to stop a container and when I tried to start it again I got a permission error, so I restarted the machine and now I'm locked out: my admin password doesn't work anymore (my user passwords do, but they're useless, also my SMB shares still work, transmission doesn't though).


    I swear I didn't touch the admin account nor did anything with the admin group, what I did though is reset the permissions (through the plugin).


    P.S. strangely I can still access as root trough SSH (isn't the root password the same as the "admin" one?).

    I'm not sure if this is a docker problem, although I came across a guy with the same problem and he also uses Transmission docked, so let's see...


    Yesterday I saw Transmission not downloading anymore and I realised that the disc was full, so I freed around 140GB of space yet Transmission is stuck at not downloading (but it's seeding fine).


    I purposefully added a file with a ton of seeds but nothing happens: it says 0 of 502 seeds connected and 0 of 49 peers connected and no error message, all this while seeding without problems. I tried stopping and restarting the Transmission service from portainer and also rebooted openmeidvault but it's still stuck, what can I do?

    Good to know!

    Using Windows you can check what version your shares are using. The most recent one is 3.xx.

    Simply run Get-SmbConnection in a Powershell admin console and it will tell. Mine is 3.1.1.


    I too get 3.1.1 under "Dialect". Does this mean that I'm good with security now?


    Quote

    Right, I see. You can also buy aftermarket adaptors with SATA interface but without ethernet.

    i know, I don't like those because you have to take out the HDD every time you add a game (not gonna happen) :P

    EDIT, try client min protocol = NT1, I've found some references online that is the right one.


    Nope, didn't work. But I tried this alone ntlm auth = yes and it worked. Does this mean that my shares are now back to SMBv4.11? (or whatever version they were).


    Quote

    If you have a FAT PS2 you could also discard the network functionality and buy a sata adapter and store all the games locally.

    I do have a FAT PS2, and with an old school IDE drive mounted, but it's in a room I cannot easily use now, so I tend to to stick to the PS2 slim.

    Plus, I use Ethernet with the FAT too, both to install games and to casually play games that are "not worthy" of precious hard disk space.

    Interesting.


    I can't remember what version of SMB is OMV5 running, and my server is currently turned off, but according to this changelog, Samba 4.11 is deprecating SMBv1.

    The changelog mentions NT1, LANMAN2, LANMAN1 to support SMB 1, try each of these settings and see if works.


    I don't get it, you mean one at a time? Also, in what way it would be different from my solution? Would it be safer?


    Quote

    Coincidently I also have a PS2 Slim with OPL but I've never used it with OMV, only with a Synology NAS where I could enable SMBv1.


    Maybe I could try with a raspberry Pi zero.


    Quote

    For the best security you could use a samba docker container on a custom port, enable SMB 1 there and only share the PS2 folder. This requires some docker skills and playing around with the samba config as we are doing now.


    I wish I could do it, If you can help me I could try... I already have portainer set up and running for Transmission, but I still don't know my way around dockers.


    Quote

    Migration to SMB 2/3 is also happening for OPL, they are looking into it right now. Things are finally moving and we should see things happening soon :)


    Finally, I hope that they'll make it work.



    P.S.

    To anyone who may encounter this problem: after turning my SMB shares into SMBv1 they stopped working in Windows 10, to make them work again I had to install the SMBv1 client.


    Here's how to do it:

    1. Search in the start menu for 'Turn Windows features on or off' and open it.
    2. Search for 'SMB1. 0/CIFS File Sharing Support' in the list of optional features that appears, and select the checkbox next to it.
    3. Click OK and Windows will add the selected feature.
    4. Reboot

    UPDATE: I searched "Ignoring invalid value 'SMB1' for parameter 'min protocol'" with google and I landed on a forum where there was a guy complaining that with the "new" version of Debian he couldn't make his old printers work. Someone suggested him to put this in the SMB options:


    max protocol = NT1

    min protocol = CORE

    ntlm auth = yes


    Well, I did, I started my PS2 and all games were there! :) Thanks, I couldn't have made it without your help.

    Try adding this to SAMBA's advanced settings


    min protocol = SMB1


    So, I tried to add the line in "Extra options" and I got this error:



    Code
    Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C.UTF-8; omv-salt deploy run samba 2>&1' with exit code '1': debian: ---------- ID: configure_samba_global Function: file.managed Name: /etc/samba/smb.conf Result: True Comment: File /etc/samba/smb.conf updated Started: 00:19:36.511568 Duration: 306.725 ms Changes: ---------- diff: --- +++ @@ -35,100 +35,5 @@ multicast dns register = no # Special configuration for Apple's Time Machine fruit:aapl = yes -#======================= Share Definitions ======================= -
    [REDACTED, message is too long, it must be under 10.000 characters]



    And if I click "Show details" I get another bunch of stuff but I think the relevant part is this: "Ignoring invalid value 'SMB1' for parameter 'min protocol'"

    Quote

    The issue might be related to SAMBA's version. Unfortunately, OPL ony supports SMBv1. This is potentially a security threat since this protocol is long gone.


    That's unfortunate: I'll have to either dismantle my OMV server or find a dedicated solution for my PS2s


    Quote

    Try adding this to SAMBA's advanced settings

    min protocol = SMB1


    So, I have to past this line in in "Extra options"?



    Quote

    Additionally, have you assigned the shared folder to the user you're trying to use?


    I think I did, since I have to input my user and pass in order to access the share from my other devices, however, now I can't find where the option is, can you tell me how to check?

    I hope there's someone here that knows about OPL (Open PS2 Loader), a software that loads PS2 games from a network share (or from USB, or from an attached HDD).


    I have a SMB share called "Playstation2" where all my PS2 games are, this share works perfectly in windows and on all my android devices, but not on the PS2 itself, I get "network startup error 300" from OPL.


    EDIT: I updated OPL to the latest version and initially I got the same 300 network startup error, but after configuring it now I get "301: cannot log into SMB server", I guess it's an improvement :/


    Now, the PC I'm using had previously debian installed on it, and my (manually written) "Playstation2" share worked with all my PS2s. Is there something I have to set to make it work with OPL? (I noticed that there are quite a few options I have no idea how to set, like the "WINS" one, for example).


    Also, in the OPL menu the SMB port is set as "445", but I couldn't find how to set the port in OMV.


    These are my settings:


    PS2 internal network settings:

    IP= 192.168.1.20

    Mask=255.255.255.0

    Gateway=192.168.1.1


    OPL:

    PC IP=192.168.1.70

    Port=445

    Share=Playstation2

    user=*****

    password=*****


    Openmediavault network settings:

    ipv4= static

    ipv6= disabled

    ipv4= 192.168.1.70

    netmask= 255.255.255.0

    gateway= 192.168.1.1

    MTU= -

    WOL= YES

    DNS servers= 8.8.8.8


    SMB settings:

    enable= yes

    workgroup= MSHOME

    description= %h server

    enable user home directories= no

    browseable= yes

    WINS support= no

    log level= none

    use sendfile= yes

    asynchronous I/O= yes


    Share settings:

    Playstation2

    public= no

    read only= no

    browseable= yes

    honor existing ACLs= yes

    enable permission inheritance= yes

    enable recycle bin= no

    extended attributes= no

    store DOS attributes= no

    audit= no