Posts by shecky66

    From yesterday, my NextCloud Docker installation result in Maintenance Mode.


    How I can disabled It?

    SOLVED!

    Problem was due to a plugin incomplete update.
    To resolve, enter on docker bash:

    Code
    sudo docker exec -it <YOUR-DOCKER-NAME> /bin/bash

    To remove maintenance mode, digit:

    Code
    sudo -u abc php /config/www/nextcloud/occ maintenance:mode --off

    (where "abc" is the user owner of config.php)


    To avoid timeouts with large installations, you can run the following command from the installation folder.
    So digits:

    Code
    cd /config/www/nextcloud #installation folder for Nextcloud docker
    occ upgrade


    Thats all! :P

    Hi at all!


    In my OMV, I installed Nextcloud (following the macom guide - [How-To] Nextcloud with Letsencrypt using OMV and docker-compose) and Airsonic.


    Airsonic however does not use Letsencrypt, so I tried to change its configuration.


    First of all, I removed LetsEncrypt service from the Nextcloud stack and created a container only for it.

    I added LetsEncrypt container network the to the containers of the Nextcloud stack (redis, nextcloud and nextcloudDB).

    Nextcloud continues to work properly.


    So, I tried to follow the same steps to insert LetsEncrypt on Airsonic.

    • I removed 4040 port forwarding from the router, leaving only ports 80 and 443 rules.
    • I modified the Airsonic stack by inserting the variables CONTEXT_PATH and JAVA_OPTS and remove port 4040
    • I removed from airsonic container the bridge network and added the LetsEncrypt network

    I then moved on to setting up the proxy:


    cd /srv/dev-mydisk/appdata/letsencrypt/nginx/proxy-confs


    cp airsonic.subfolder.conf.sample airsonic.subfolder.conf


    and I modified the .conf file in this way:


    Now, if I call:


    Someone can help me?

    Thanks!

    In Fail2ban the filter configuration file for Nextcloud is missing!


    Create it with:

    Code
    sudo nano /etc/fail2ban/filter.d/nextcloud.conf


    Add the following to the file:

    Code
    # Fail2Ban filter configuration file for Nextcloud
    #
    # /etc/fail2ban/filter.d/nextcloud.conf
    [Definition]
    failregex = ^{"reqId":".","remoteAddr":".","app":"core","message":"Login failed: '.' (Remote IP: '')","level":2,"time":"."}$
    ^{"reqId":".","level":2,"time":".","remoteAddr":".","app":"core".","message":"Login failed: '.' (Remote IP: '')".}$
    ^.\"remoteAddr\":\"\".Trusted domain error.*$


    Now go to Fail2Ban --> Jails and add a new jails with this options:

    Code
    Name: nextcloud
    Port: http,https
    Max Retry: 3
    Ban Time: -1
    Filter: nextcloud
    Log Path: path/to/yournextcloud/data/nextcloud.log


    Activate the nextcloud jail and deactivate apache-404 and apache-noscript jails (if they are not present in your installation).


    Problem solved! 8o

    I have installed and activated the Fail2Ban plugin and setup some jails.


    In the "Services" area it is enabled again but not running.



    When I click on the Fail2ban tab the following error is shown



    This is the error with it's details:

    Someone can help me?


    Thanks.

    Davide.

    Hi, davidh2k !


    I started from your configuration and I came to this:



    ...and everything works fine!


    Thanks for your support!

    Davide.

    Last night, following the macom guide I installed Nextcloud on my OMV 5.x.


    To speed up Nextcloud as suggested by monsen I also added redis to the stack.

    Everything worked perfectly so I turned OMV off.


    When I restarted it this morning, I received the "Internal Server Error" message.

    I checked the logs, but there was no obvious error.


    I therefore went to check the port assigned to redis container which was different from the one used before the restart.

    My question then is:

    is there any way to fix the port used by redis container so that it doesn't change with every reboot?


    Nextcloud config.pho now start with:

    PHP
    <?php
    $CONFIG = array (
    'memcache.local' => '\\OC\\Memcache\\APCu',
    'memcache.distributed' => '\\OC\\Memcache\\Redis',
    'redis' =>
    array (
    'host' => '172.18.0.3', # <== this value changes with each reboot
    'port' => 6379,
    ),

    Do I need to change the host value?

    If yes, what value should be entered?


    Thanks.
    Davide.


    Only a David could reply to another Davide in this way... :P:P:P

    Now I try it and let you know ;)


    Thanks so much!

    Thanks macom !


    This was exactly the kind of help I was looking for ;)


    If I can take advantage of you, according to your point of view, it's better to stay on Nginx (on which OMV is based) or look for a docker with Apache?

    Could Nginx and Apache on the same machine create conflicts?


    Thanks again for your reply.