Posts by antsh

    Just experienced this when upgrading to the 5.6 kernel. For anyone that comes across this the answer is to install the

    linux-headers-amd64 package. This will automatically install the new headers needed when a new kernel is installed. This way you don't have to manually install the linux headers for your specific kernel every time.

    Got it thanks. This will default these for all shares for my testing. Am I right in assuming that these settings are not currently adjustable at a per share level?

    Hi All,


    Is there an env variable available to change the file create masks and force create modes for samba shares? Right now they are are set as 0664 which works for most things. Also, this will change the create mask and create modes for every share created. Is there a way to change this at a per share level?


    My use case is I am using a share as a mapped drive in windows for a steam library. This mask causes the files that steam creates at installation to be created as non-executable, which of course breaks the launching of games.


    I am looking for a way to create a share that allows files to be created as executable. I am thinking modifying the create mask and mode is the way to solve this, unless there is a better way?


    Thanks!


    and in general, is there a way to lookup all the valid env variables that can be set across OMV?

    Thanks, I had no idea you could append configurations with separate files for netplan; this makes it really easy to "enhance" some of the configuration available through the UI.


    Just as an FYI for anyone that sees this later, you need to add the parameters: line to the above, so it should actually looks like this if your interface is bond0:

    YAML
    network:
    bonds:
    bond0:
    parameters:
    transmit-hash-policy: layer3+4

    Thanks as always for the great work. Issue created:


    https://github.com/openmediavault/openmediavault/issues/727


    As a temp fix until this is addressed (as priority dictates, of course) just to add the below to the extra options of every share that isn't a time-machine share?


    Code
    fruit:encoding = private
    fruit:locking = none
    fruit:metadata = netatalk
    fruit:resource = file
    vfs objects = catia fruit streams_xattr

    I have a general question regarding the default samba settings in omv5.


    I see that if you have at least one share enabled for time machine then


    Code
    fruit:aapl = yes 


    gets set globally and


    Code
    vfs objects = catia fruit streams_xattr

    Gets set only on the time machine share.


    The global behavior is as I would expect, but only the time machine share getting the vfs object parameters is counter what I’ve seen from the samba wiki. It recommends to set this on all shares if set on any of them:


    Code
    Be careful when mixing shares with and without vfs_fruit. OS X clients negotiate SMB2 AAPL protocol extensions on the first tcon, so mixing shares with and without fruit will globally disable AAPL if the first tcon is without fruit.


    Running testparm actually warns about it as well:


    Code
    WARNING: some services use vfs_fruit, others don't. Mounting them in conjunction on OS X clients results in undefined behaviour.

    Is this being done deliberately, or perhaps an oversight? Any harm in manually setting the vfs objects as suggested in the extra options of the non-time machine shares?


    Thanks for taking a look!

    You aren't using one of the containers to access the gui at the time are you? This would happen if you were using the letsencrypt/nginx container to proxy your domain name, and then used that domain name to access omv during the update for example.

    Hi All,


    This doesn't pertain to OMV directly perhaps, as I have a feeling that this is a Debian issue/nuance.


    I am using a MegaRAID card, and there is a monitoring service that is provided as a service called megaclisas-status. When this service tries to start, i get this in the logs and it exits:


    Code
    megaclisas-statusd[811]: Starting megaclisas-status monitor: megaclisas-statusddaemon: ignoring unsafe /etc/daemon.conf (/etc is group writable)
    megaclisas-statusd[811]: daemon: fatal: refusing to execute unsafe program: /usr/bin/daemon (/ is group writable)


    Does someone with a bit more linux knowledge than me have an idea how this can be addressed? I am thinking it is a permissions issue, but don't know if messing with daemon is a good idea.

    Can you show your storage mappings for emby for both omv4 and omv5? One thing to note is that omv5 doesn't use /sharedfolders/ by default anymore, so you need to change that mapping. Also, specifically for your emby config files, you have it pointed to the same location in omv4 and omv5 and the same files exist in the same locations for both installs?

    You don’t need to do it through the web interface if you use that command.


    You can have it start automatically by changing the command slightly to: Note that is a double dash before restart, it gets formatted weirdly on my phone.


    You can also change the restart policy if any container using portainer, including itself.


    Code
    docker run -d —restart always -p 9000:9000 -v /var/run/docker.sock:/var/run/docker.sock -v portainer_data:/data portainer/portainer

    Also, portainer sometimes does weird things if you create containers using the UI, or edit them there. I very much learned from scratch and went from OMV's original plugin to portainer, but I have to say now that I am a bit more comfortable using docker-compose is the way to go.