Posts by chudak

    I just noticed this is not right. It should 192.168.90.2:/export/Public. You can see the exports with: showmount -e 192.168.90.2 on the client

    Do you mean in /etc/fstab?


    I have now:


    #NFS mount

    192.168.90.2:/Public /media/pi-nas-nfs nfs defaults 0 0



    showmount -e 192.168.90.2

    Export list for 192.168.90.2:

    /export *

    /export/Public *

    Hello


    I've had NFS set for a long time (not really used it, instead used Samba mounts)


    But still, I see that there was some change in July-August as some users experienced issues with NFS


    I am not able to connect. See an error during mourning mount.nfs: access denied by server while mounting 192.168.90.2:/Public


    My setup looks like this:




    Needless to say, I have not touched my setup in months and therefore am hesitant to change anything unless I check with experts here.


    Any clues on what changed?

    TIA

    Yes done that.


    But those are still listed and this seems to be a problem.


    Thx

    I run 6.0.30-1 on R Pi 4 and tried to see what updates are available with options:


    Pre-release updates

    Community-maintained updates


    Checked those options, ran the update, and got these packages:



    Now I wanted to uncheck those options and return back to the initial condition, but that did not work.


    Any clues on how to fix it?


    Thx

    Did you finally solve your issue?


    Thx

    Can someone give me a hand and help fix a similar issue pls?

    I have Rpi-4 and Seagate 5TB drive


    Here is some info:


    $ sudo smartctl --health /dev/sda


    smartctl 6.6 2017-11-05 r4594 [armv7l-linux-5.10.63-v7l+] (local build)

    Copyright (C) 2002-17, Bruce Allen, Christian Franke, http://www.smartmontools.org


    Read Device Identity failed: scsi error unsupported field in scsi command


    A mandatory SMART command failed: exiting. To continue, add one or more '-T permissive' options.


    $ sudo smartctl --health -d sat -a -T verypermissive /dev/sda

    smartctl 6.6 2017-11-05 r4594 [armv7l-linux-5.10.63-v7l+] (local build)

    Copyright (C) 2002-17, Bruce Allen, Christian Franke, http://www.smartmontools.org


    Read Device Identity failed: scsi error unsupported field in scsi command


    === START OF INFORMATION SECTION ===

    Device Model: [No Information Found]

    Serial Number: [No Information Found]

    Firmware Version: [No Information Found]

    Device is: Not in smartctl database [for details use: -P showall]

    ATA Version is: [No Information Found]

    Local Time is: Tue Dec 7 16:05:42 2021 PST

    SMART support is: Ambiguous - ATA IDENTIFY DEVICE words 82-83 don't show if SMART supported.

    SMART support is: Ambiguous - ATA IDENTIFY DEVICE words 85-87 don't show if SMART is enabled.

    Checking to be sure by trying SMART RETURN STATUS command.

    SMART support is: Unknown - Try option -s with argument 'on' to enable it.

    Read SMART Data failed: scsi error unsupported field in scsi command


    === START OF READ SMART DATA SECTION ===

    SMART Status command failed: scsi error unsupported field in scsi command

    SMART overall-health self-assessment test result: UNKNOWN!

    SMART Status, Attributes and Thresholds cannot be read.


    Read SMART Error Log failed: scsi error unsupported field in scsi command


    Read SMART Self-test Log failed: scsi error unsupported field in scsi command


    Selective Self-tests/Logging not supported


    $ lsusb

    Bus 002 Device 002: ID 0bc2:ac2b Seagate RSS LLC

    Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub

    Bus 001 Device 002: ID 2109:3431 VIA Labs, Inc. Hub

    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


    Thanks in advance!

    macom


    While we are on this topic I have a hypothetical question


    So my failed and new drives were identical and were devices as /dev/sda


    Assuming that I got a completely different new drive say SSD, will it be possible to use the same process or something else to make it work in my case?


    Thx

    OK so after all - everything worked fine.


    I followed the steps with a slight change in the order.


    On another Linux machine ubuntu:

    1. connected the new drive
    2. deleted all pre-formatted partitions
    3. added ext4 partition
    4. added label MAIN
    5. connected to pi OMV
    6. verified connection, rebooted
    7. changed permissions on MAIN to be user_name:users
    8. rsync data files


    Thank you for your help!


    macom thanks a million! :)


    Actually, I mightbe be wrong looking closely...

    macom


    OK deleted partitions and created a new etx4 with label MAIN


    After connecting and rebooting my OMV, I see that in Disks connected by ID:



    How can I change it to be by the label?


    Thx