Posts by pascalts

    Hey,


    today I messed up my boot-configuration. It seems, as my bootloader was on one of my data drives, wich I just removed. So: No bootable drive...


    I thought: No problem. Use super-grub-disk. So I ran the super grub disk and it successfully found my grub config and I was able to boot into my OMV system. Having this problem not the first time I ran "grub-install /dev/sde" (yes, sde.... don't ask) and it retuned no error. I checked the boot-flag on the partition /dev/sde1, wich was present so I thougt: Restart.


    But: Still not bootable. :cursing:


    Do you have any suggestions?


    Regards


    Pascal

    Hi!


    I have a 6TB HDD from TOSHIBA, wich becomes... slower. I am a bit concerned about its state, as it has already over 21000 power-on-hours and has a horrily long spinup time. Could someone with experience have a look at my smart data?


    If I say "slower", I mean it used to sequentially write with over 110MByte/s on it (via my 1GBit/s network), but now I am getting drops in sequential read and write perfomance to 40 or 30 MByte/s if I write or read huge files (>=20GB usually).


    [SMART-data attached as txt]

    If I test it with hdparm I still get quite good values...

    Code
    hdparm -tT --direct /dev/sdd
    /dev/sdd:
    Timing O_DIRECT cached reads: 242 MB in 2.01 seconds = 120.18 MB/sec
    Timing O_DIRECT disk reads: 618 MB in 3.00 seconds = 205.71 MB/sec

    Any suggestions?


    Best regards


    Pascal

    Files

    • smart.txt

      (17.46 kB, downloaded 24 times, last: )

    Hi!


    We are using a setup with a software RAID 1, with EXT4 and a 24-hour backup. This works nice so far, but we discovered, that we might need a tighter backup-timing, more likely a file-versioning, to be able to get a older version of a changed file. Our software wich creates the files does not support any file-versioning, so I thought it would be nice to use a filesystem-based versioning, to keep, for example, the last 5 versions of a file, if it was modified and is under a certain size (most our files are below 2MB so...).


    As far as I understand, this is possible if I use Btrfs. Btrfs should also able to be converted from a ext4 filesystem, which would also be reversible.


    What would you suggest? Is this filesystem-conversion easiely* possible in OMV, or are there even some other possebilities?


    I am looking forward for your suggestions.


    Pascal


    *easiely: Of cause I will backup all data. I am familiar to Debian-based operation systems and the konsole.

    Hi!


    I want to add full harddisks to my NAS build. They come from a existing Debian system (without OMV) and are alredy EXT-formatted, no RAID, just disks...


    Until now I only added empty, unformatted harddrives to my NAS and I am a bit afraid of losing my 14 TB of data (wich is backuped on a foreign drive, wich is really slow accessibly via sftp...)


    Can I add those disks without harm to my data and yust go on using them?


    Best regards


    Pascal

    Dear pascalts,


    Thanks for your quick reply. Actually I am using OMV5 on raspberry pi 3. You told we can lon into the public server an access the "forwarded port" from OMV. Is it a different way to connect the network wihtout forwarding the port from router ? Because our problem that we are not able to forward a port because of ISP/Router policy.

    You do definetely need no DynDNS or Portforwarding with this method, because your OMV / Raspberry act like a client, connection to the server. But the client-connection provides a reverse-shell to OMV from the server. So you could ssh to your server on a non-standart-port (like 2222) and acces OMV through this reverse-connection. Autossh helps to re-connect instantly, if your internet service provider does a force-diconect every day or so. You could start autossh like this:


    autossh -M 23456 USER@FOREIGNSERVERIP -N -R 2222:localhost:22


    Explenation:


    -M 23456 --> Monitoring port, were autossh checks, if the connection is still alive

    USER@FOREIGNSERVERIP --> a valid username at the foreign server (eg root@123.123.123.123). IP or FQDN is possible

    -R 2222:localhost:22 --> forwards port 22 on the local OMV to port 2222 on the foreign server (wich will not be public! you will have to locally log into the foreign server to then acces ssh user@localhost -p 2222 to access OMV)


    This sounds horrible complex, but once it is running, it works like a charm and forever.


    Pascal

    Okay, so I resettet the ACL last week via "setfacl -b [FILENAME]" and the "+" was gone.


    Today i rechecked, and the ACL "+" is back again.


    "getfacl [FILENAME]" shows:

    Code
    # file: [FILENAME]
    # owner: [myuser]
    # group: users
    user::rw-
    group::rwx
    group:[mygroup]:rwx
    mask::rwx
    other::r--

    I do not understand the system of ACLs completely, but this should give [myuser] as well as [mygroup] access to the file (r/w). Strange is, that I deactivated ACLs and those ACLs keep comming back.


    By the way: The user still needs sometimes 2 to 6 attempts to acces the file. But only THIS certain user. I think at the moment about adding a new account for the user... (I work with group-privileges, users are only for logging).


    Best regards


    pascal

    Okay,


    we testet now for one week. As it happens, disabling "inherit permissions" did not work. Some days the user had no problems at all, but there were 2 days, when he needed 4 to 6 attampts to open the file again.


    My next idea is to set the user permissions on unix level again. ananas told that there are some ACLs still somehow inside (I have disabled the option for the usage of ACLs)... maybe I should set all files to 0660 via chmod?


    Pascal

    I might have had activated them in earlyer times, but now they are definetely off.


    I disabled "Inherit permissions" on all our shares, and so far it seems to work. I will test it for a week or so and then report back.


    Tanks!

    Wouldn't this make other users unable to edit files created a user ? The documentation says:

    Quote

    Why I can’t edit files that other users have created?
    The default umask in Samba is 644 for files. To enable flexible sharing check Enable permission inheritance in the Samba share settings, this will force 664 creation mode. Files created previously need to change their permission mode. Check also that you don’t have read only enabled. This option overrides privileges and POSIX.

    https://openmediavault.readthe…ices/samba.html#questions

    Hi,


    I am using OMV5 with a software RAID 1 and CIFS for sharing files with Windows machines. Works fine so far, but we have problems with about 5 files (out of about 1000). Those files are in a subfolder were the user has R/W privileges. But quite often it happens, that the user needs 3 or more attemps to open the file in Write-Mode.


    So I took a look at the syslog, filtering for messages referring to the file:


    Sorry for the "###PATH_TO_FILE###"-like consorship, but it is nessesary.


    You can see, the third attemt to open the file is successfull ("read=Yes write=Yes"). :/ This happens only to a handful of files, while nobody else is even in the office. The user does definetly have permissions to R/W the folder and files, some of the files were even createt by him. We do not use ACL.


    The only difference I saw in the pile permissions are while using "ls -hl" in shell, were some files are "-rw-rw-r--+" and some "-rw-rw----+" - but as far as I understand this should not matter, because all users are in the group "users" wich has R/W permission.


    At the moment I struggle a bit to understand why this happens. May you help me?