Posts by RudyBzh

    I'm sure it could be added. I can look but not sure how much effort I will be putting toward OMV 5.x plugins with OMV 6.x on the horizon. You can always mount 9p from the command line and then use the sharerootfs plugin to make shared folders.

    Thanks.

    As mentionned in all this thread, I have this 9p mounted through fstab. From my point of view, it works perfectly from OMV in SSH.


    Using sharerootfs is not working for me (see the issues I have in OMV GUI and attached services : SMB in my case).


    Using mergerfs makes it work...

    Just to share for those who are interested...


    The missing subdirectories are in reality accessible by using "cd subdirectory" (with exact name) on an SMB Client. So, it's as if some directories have not "read access" but only "execute access".

    After looking in ssh (from where I can see every folders/subfolders without any issue, so it's not a "9p" issue for me) the permissions and others ACL on all the directories/files (previously reset via OMV plugin... but did it applied everywhere ?! Not sure), I can't find a single difference...

    So, I don't know why I have this strange behavior.


    By the while, I manage to get it work using a dirty solution => mergerfs !

    I put my 9p folder /mnt/data (the one mounted from the underlying Proxmox ZFS) in mergerfs. Yes, he's alone...

    Next, I used the created mergerfs to set my shares and voila... It works "normaly' => I can see all my folders.

    Any idea/explanation on why it's working with mergerfs an not with shareroot plugin ?!


    I just have OMV throwing me some errors on some shares when I apply config (same error as in #11).

    It looks like it's only for the shares that are not at the root.

    If I share "/dir", I have no error (OMV doesn't try to put any ACL, I think ?!)

    If I share "/dir/subdir", I have the error (OMV tries to put a "execute" only ACL on "dir" from group users... Why ?! Also, I don't know why it's not working because it should ; And, finally, look at my 2nd phrase in this post...)


    Well, it's not really a wonderful way of doing things but, without help, I don't know what to look at to understand why I have these kind of issues and how to do it a better way.


    As every reads I made about passing ZFS to VM, neither Proxmox, neither OMV (or others...) wants to make it easy to work and every one is staying at his position... "blabla Proxmox on a baremetal" & "blabla NAS on a baremetal"...


    Adding 9p on remotemount plugin won't be possible ?


    I'm going to look a way to activate SMB shares directly from Proxmox (ZFS Shares). Should be more "natural"...

    I do not intend to use ACL.

    By the while, the error displayed is related to ACL.. is it the default behaviour of OVM ?

    How could it work for several folders and not for some ?

    I looked at folder/files with getfacl, and they are the same ones (default as made by a chmod) between a working and not working folder/file in a share.


    What can I look at to troubleshoot this ?

    In smb.conf, all the folder should be shared... Why some files are not visible and even with differences between a windows and a linux client ?

    More strange, Windows and Linux don't see the same number of folders...

    Lets take a shared folder as an exemple...


    # On my ZFS, it contains 951 subfolders (ls | wc -l)

    # On OMV mount (9p), it contains 951 subfolders also


    On OMV WebUI, I have a "shared folder" for this folder.

    If I try to edit it, I don't see every subfolders (don't know if webUI is only limiting the number of result or so...)


    I have an SMB on this sharefolder that I can use on windows or linux


    # On Windows, I see 765 subfolders

    # On Unix (2 different VM), I see 506 subfolders


    Same user ; Looked at the permissions, same for all ; no ACL. (I even use the reset permission utility to remove ACL and restore every perms...)

    Really strange.



    Next, if I try to create a new sharefolder for on a missing subfolder (manually typing the path), when I apply, I have this error :

    Code
    Failed to execute command 'export
    PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin;
    export LANG=C.UTF-8; setfacl --modify group:users:--x /mnt/data
    2>&1' with exit code '1': setfacl: /mnt/data: Operation not
    supported


    Hope this will help do diagnose something and point me to the right way

    Hi,

    Follow of my use case, I think I successfully implemented virtFS.

    On my OVM VM, connected in SSH, I can see all my folders/files through the 9p mount.


    BUT, and I really don't understand why, my shares doesn't include every folders... some are missing, depending of the share.

    Even on OMV WebUI, if I go to create a new "Share folder", in the path selection, all folders are not there ?!


    Any idea please ?

    I wouldn't use fstab. I would make a systemd mount file and either set a Before= dependency in the mount file for the services that need it or add overrides to the services to wait for the mount.

    Thanks, will look for this.

    I'm not wondering about the systemd but about identifying the before list...


    Well, we'll see.


    Thanks a lot for your (very) fast and clear responses.

    OMV doesn't work in containers.

    I do. My VMs aren't file servers though. So, I just create virtual disks. But, I am working on a kvm plugin and I will replace proxmox on the host with OMV and the plugin. New openmediavault-kvm plugin

    OK, so the container way to do is not a good idea... ;(


    When you say your VM are not file servers, what are you using OMV for ?!

    Proxmox is the host and OMV is the guest ? Right ? But OMV is not a file server for you ?


    I saw the plugin to replace Promox by OMV...

    Well, It would be a big (r)evolution for me... BTW, Not sure to go this way...


    It's proxmox job to deal with VM/CT, not OMV (in my point of view).

    I'm asking myself if it's not easier to make OMV as a container and use bind mount in place of virtFS... :/

    Should probably be more straight forward...

    Just have to use the same "sharerootfs" as suggested and no issues with fstab mount... :)

    Well, except the privileged vs unprivileged container choice...


    I remember have read that you also are using proxmox & OMV ?

    What solution did you use to use both ?


    Thanks.

    Thanks aaron, that's what I was thinking of.


    Any advise on the fstab way to mount this ? "_netshare" and so on to be sure service dependencies are in the right order ?

    I guess I will have troubles with this :/

    Hi all,


    I know the question have been asked a lot of time but I never feel comfortable with all answers I saw.


    I'm running OMV as a VM on Proxmox.

    I've just created a ZFS pool ("tank") in proxmox and want to give that full FS to OMV.

    I successfully did this using virtFS (9p) passthrough. On the OMV VM config file on the host (proxmox), I add this line :

    Code
    args: -fsdev local,security_model=passthrough,id=fsdev0,path=/tank/data -device virtio-9p-pci,id=fs0,fsdev=fsdev0,mount_tag=dataZFS

    and can successfully mount it on OMV with this :

    Code
    sudo mount -t 9p -o trans=virtio,version=9p2000.L,msize=512000 dataZFS /mnt/data

    Performances are quite as good from guest (OMV) as from host (Proxmox).


    Unfortunately, I stuck now on OMV side to be able to use this directory (/mnt/data) as shared because it's not recognize as a drive ?!

    I could mount it somewhere else if it's relevant (/media ? /srv ?) ?

    I can use remotemount add on, who doesn't know 9p FS...

    I wondering about using root share add on ?


    What would you suggest to do here ?

    (from fstab, with good options to mount in the right order, to ability to create shares in this virtFS remote folder)


    Thanks a lot.

    Regards

    Hi,

    I'm having an issue following this guide : How to make a good Media share for Emby and PlexMediaServer

    I use to make "/" SMB shares but, reading this guide, it's "stupid" to do so.

    So, I'm trying to follow these best practices and I've just discovered that a big functionality is missing doing so : hardlinks !


    Sharing the root folder permitted me to make hardlinks between 2 top folders - say "Folder A" & "Folder B" - from unix clients having only 1 mount (and native mount options like serverino and/or mapposix)

    Now, if I make 1 share for "Folder A" and another one for "Folder B", it seems that I cannot make hardlinks between them...

    Invalid cross-device link


    Am I missing something ? A SMB option on the server side ? Or on the client side (having 2 different mounts for "Folder A" & "Folder B") ?

    How do you manage this ?


    Thanks a lot for you advices.

    Hi,


    Was having the exact same issue (on last OMV 5.5.17-3).


    OMV uses monit to monitor the health of the system (memory, cpu load, ...) ; Check with sudo monit status or sudo monit summary. If errors are reported, syslog are filled and you receive mails (if configured).


    Actually, Debian Buster runs monit 5.26.0 (check with sudo monit -V) and a bugs exists in this version for hosts running in VM or LXC : https://bitbucket.org/tildeslash/monit/issues/843

    A fix has been made in monit for this bug since version 5.27.0, see https://mmonit.com/monit/changes/ :

    Quote

    Fixed: Issue #843: Linux: Monit reported wrong memory usage in LXC container if the ZFS filesystem was used. Monit now use MemAvailable on Linux when calculating memory usage for more accurate statistics. Thanks to Joe LeVeque for patch.


    I solve this on my OMV by installing the backports version of monit (actually monit 5.27.1 ) :

    sudo apt install -t buster-backports monit


    Hope this will help others.


    Regards.

    Hi,


    My OMV server's syslog is full of messages like this (every 30sec) :

    Code
    Sep 18 10:39:41 omv monit[672]: '\omv.xxxxx.fr' mem usage of 454613336064.0% matches resource limit [mem usage > 90.0%]
    Sep 18 10:40:11 omv monit[672]: '\omv.xxxxx.fr' mem usage of 454613336064.0% matches resource limit [mem usage > 90.0%]
    Sep 18 10:40:41 omv monit[672]: '\omv.xxxxx.fr' mem usage of 454613336064.0% matches resource limit [mem usage > 90.0%]
    Sep 18 10:41:11 omv monit[672]: '\omv.xxxxx.fr' mem usage of 454613336064.0% matches resource limit [mem usage > 90.0%]

    The percentage shown is always at the exact same value.


    Nevertheless, it seems that everything is OK :

    Code
    xxxxx@omv:~$ free -h
    total used free shared buff/cache available
    Mem: 7,8Gi 209Mi 366Mi 35Mi 7,2Gi 7,2Gi
    Swap: 1,0Gi 1,0Mi 1,0Gi
    top - 10:46:12 up 2 days, 11:24, 1 user, load average: 0,00, 0,00, 0,00
    Tasks: 127 total, 1 running, 124 sleeping, 0 stopped, 2 zombie
    %Cpu(s): 0,1 us, 0,1 sy, 0,0 ni, 99,8 id, 0,0 wa, 0,0 hi, 0,0 si, 0,0 st
    MiB Mem : 7965,7 total, 363,7 free, 212,0 used, 7390,0 buff/cache
    MiB Swap: 1022,0 total, 1020,5 free, 1,5 used. 7417,5 avail Mem


    Have you got any idea of the reason ?


    Thank you.

    Thank you for your answer and sorry for my english :)

    I'm going to try to reformulate...


    My 1st question about "exclusion time" and "max retry" :

    Can the values entered in the fail2ban plugin main page (1st tab "General parameters") be used in anyway ?

    I'm telling that because I think they are overridden by the same parameters you must fill in each jail (under jail service you cannot leave it blank to inherit general values ? "This field is required" ).



    2nd point, for the "tip" below the "max retry", it's not "in seconds" :



    Finaly, for sendmail, no, unfortunately I didn't know it's part of postfix (I should have been... It would have prevented me from all the problems I had to deal with ^^)

    That's what I finally though... I didn't have /usr/sbin in my path and so missed this binary existence... So tried to install it and crashed my OMV...

    Of course, if sendmail is present by default, no need to switch to mail (the way I described or the alternative way you told).

    This part is solved... even if I think I broke some things in my installation because if I try to make the same manipulations (without going to the end...), I can't cause something seems to be broken :

    Don't know if I should try to correct this or not (also because I don't know how...). I fear to broke OMV again...


    Thanks

    Hi,


    I'm trying to play with Fail2ban plugin and I don't understand the goal of "exclusion time" and "max retry" in the main parameters tab :


    They seem to always be ignored and replaced by the same parameters under each jail service configuration which are not optional :


    With the previous values, exclusion time is set to "forever" and cannot be left empty to use general parameter (1h).

    Same for max retry... except I don't know what "-1" means. It seems it blocks account on each fail.


    Another small issue is for the text attached to max retry (in jail tab). In french, it's translated in "Essai maximum en secondes" but, as I understood it's in occurrences, not in seconds.

    And it's not a translation issue because in english, the text is the same :

    Code: /usr/share/openmediavault/locale/fr_FR/openmediavault-fail2ban.po
    msgid "Max Retry in seconds."
    msgstr "Essai maximum en secondes."


    Finally, last issue I had is the default MTA generated by OMV in /etc/fail2ban/jail.conf file.

    It's set as "mta = sendmail" (the default for fail2ban), but as I remember sendmail is not installed on OMV by default (finally, not really sure, it's not a path issue...)


    So to solve this, my 1st try was to install sendmail with "apt install sendmail" (DON'T DO THIS) without looking enough on packages impacts and, doing this, OMV is simply uninstalled... :(

    Well, I solved this by reinstalling OMV and sendmail stays installed for me.

    If sendmail is effectively not installed by default, better option would be to change OMV generated jail.conf file to use "mta = mail", no ?

    As an alternative, on the user side, it's possible to create a local file for this :

    Code
    sudo nano /etc/fail2ban/jail.d/default.conf

    and insert in this file :

    Code
    [DEFAULT]
    mta = mail

    then reload fail2ban with :

    Code
    sudo systemctl restart fail2ban.service


    Sorry for this long mail and thank you for your advices.


    Regards.