Posts by HackitZ

    And the directory you're specifying inside booksonic is /Audio-Books? When you run the image, can you check the log and see if it's got any errors?


    I generally ignore the default directories for media. Actually I've changed my setup a bit since the guide: I now made a single storage container that maps all the directories I need for all of my images (except the config directories) and map that entire container to every single image.

    Yes i'm trying to add /srv/dev-disk-by-label-Media/Audio-Books/ as my directory. ive checked the logs and nothing jumps out at me. here's a copy of my log for booksonic.

    Which booksonic container are you using? Linuxserver.io? Can you show us a screenshot of your Docker container settings? Are you using any other Docker containers successfully?


    Did you map the folder you are trying to use when you created the image?

    I'm Using Linuxserver.io, i have running libresonic.
    i tried to add my own directory following your guide, but the image has it's own directory for books, atleast thats what the info page says about this booksonic image.
    here's a screen shot;

    Hi,
    I'm having a hard time to figure out why i can't get booksonic to create the books folder, i have tried to manually edit the location in the container gui.
    i have tried to add a folder in the web gui,
    i have remove and reinstalled the container several times.
    i t just seems the container does not create the default folder to put my files into.
    Any advice on what i could try is much appreciated.


    omv 3.0, docker 3.1.10

    is this how config.php should be?


    ok i have re read this thread a few times and added
    [list=1][*]'memcache.local' => '\OC\Memcache\APCu',
    [*]'memcache.locking' => '\OC\Memcache\Redis',
    [*] 'redis' => array(
    [*] 'host' => 'localhost',
    [*] 'port' => 6379,
    [*] ),
    [/list]
    to config.php located in nextcloud/config (when i add this page wont load at all had to remove)


    I also added
    [list=1][*]opcache.enable=On
    [*]opcache.enable_cli=1
    [*]opcache.interned_strings_buffer=8
    [*]opcache.max_accelerated_files=10000
    [*]opcache.memory_consumption=128
    [*]opcache.save_comments=1
    [*]opcache.revalidate_freq=1
    [/list]
    To my php.ini


    nextcloud log file shows this:

    Code
    {"reqId":"3r6uenNeHiu1pFk0wJvr","level":3,"time":"2017-11-15T16:25:52+00:00","remoteAddr":"192.168.144.11","user":"--","app":"PHP","method":"GET","url":"\/","message":"OC\\HintException: Memcache \\OC\\Memcache\\APCu not available for local cache at \/srv\/dev-disk-by-label-Media\/www\/nextcloud\/lib\/private\/Memcache\/Factory.php#96","userAgent":"Mozilla\/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit\/537.36 (KHTML, like Gecko) Chrome\/61.0.3163.100 Safari\/537.36","version":"12.0.3.3"}


    still the main page has a big white page that loads and says the content failed to load.
    see image below

    ok started again, back to the setup page.
    how do i setup mysql? i have searched for hours and found nothing. so it must be something simple ,
    so i have tried twice to open mysql,
    created a new data base called nextcloud
    i then create a new user ncadmin and password
    i then open the new user and select the nextcloud database i created and select all the options and apply.


    is this the way you create a mysql user and database?
    thanks

    here's what i have in the extra options



    I commented out fastcgi_param HTTPS on; by adding #

    here's what i have in the extra options


    error log says my config.php has an error on line 2.
    here's my config.php file, any help on what's wrong with it is much appreciated.