Posts by FabriceC01

    Hello,


    things are progressing


    I've identified 2 problems :

    • One with the name resolving on the beginning.
      One with the mysql connection at the end.

    Thanks to the last change of Dan Landon image which permit me to stop the container before the killing (NO_START_ZM mode), I could debug and with some Internet research I found that I have to do this command to solve the first problem :

    Code: Select all

    Code
    chmod 0644 /etc/resolv.conf

    the apt install is OK after.


    for the second one which is a permission problem again I need to do :

    Code: Select all

    Code
    chmod 0777 /var/run/mysqld/mysqld.sock

    after that zoneminder start succesfully.


    I would like to know the reason of these problems because Dan don't want to modify his image for now and I can't restart my container without redo all of this.


    Is there someone who have an idea of this problem source ?


    thanks in advance.


    Fabrice

    Hello,


    It seems that there're a lot of network problems in several docker containers images with no access to DNS.


    I saw a solution which seems to works in this thread. I've tried succesfully on my zoneminder container :

    going into the container (console) and running chmod 0644 /etc/resolv.conf?

    It was difficult but I had time to do the command in the portainer console before the "Killing all processes".


    Maybe you can try ...


    Is there a solution to applicate it more easily (in particular when the container stop quickly before entering in the console) ?


    but it's only the first problem and there's the second with mysql (line 83 of your log) and I can't really investigate because of the processes killing. Is it possible to desactivate it and how ? I would like to test if Mariadb is really running.


    Fabrice

    Hello,


    It seems that there're a lot of network problems in several docker containers with no access to DNS.


    I saw a solution which seems to works in this thread. I've tried succesfully on my zoneminder container :

    going into the container (console) and running chmod 0644 /etc/resolv.conf?


    Maybe you can try ...


    Is there a solution to applicate it more easily (in particular when the container stop quickly before entering in the console) ?


    Fabrice

    Hello,

    I've got the same problem from weeks, with no help from dlandon who is not on OMV. I've written issue on his github.


    and my log ( no problem with pgid) :

    I don't know how to investigate ...


    thanks for your help too.


    Fabrice

    Hello,


    I've tried to install Zoneminder docker container for my 6 RSTP network cam.


    No installation problem thanks to Techno Dad Life. But after several minutes there's a crash of zoneminder. In fact, OMV(5) is crashed too.

    I tought that it was a Zoneminder problem but today I've just installed Motioneye (thanks to DB Tech) and I've got the same crash problème after 10 minutes

    I don't know how to investigate. Which log to consult ? What test can I do ?


    Is there someone to help me ? an idea ?


    Thank you in advance


    Fabrice

    Hello Morlan,

    Yes my user docker1 has permissions on my folder.


    I'm tired. I've tried millions of things, saw hundreds of posts and youtube without results since tuesday.

    It seem difficult to install nextcloud behind a reverse proxy and letsencript with docker...

    I don't really understand how docker works.


    My holidays are over and tomorow I go back to work... I give up for now.


    Maybe next Week-end...


    Thanks again to people who have answered me.


    Fabrice

    Hello,

    For my last try, my stack compose file is :

    I've create a docker1 user (puid 1004)

    When I try to connect, I've got :

    an idea ?


    Fabrice

    Hello,

    This is my first message about my new NAS (DIY xeon with 2 x 4To raid1) and my first steps with OMV (5).

    No problem with the OMV installation (thanks TechnoDad Life) and Reverse proxy with let'sencript (Thanks DB tech) but big problems with the nexcloud installation.


    A lot of Tutorials and templates or staks use DuckDNS and I don't want it because I've got my own domain.


    I've found this video of DB Tech (thanks again) which use a portainer stack but even if the deployment is OK, I've got an error when I try to open nextcloud (Error 403) in my browse (http://myip:8080).

    see attached pictures.

    I don't know what to do. I've read lot of things about Ownership and permissions (My nextcloud folder is owned by www-data) and about apache configuration but I can't find httpd.conf.


    Is there someone to help me ?


    Fabrice