Posts by MarkTwo

    Another option is to run omv-firstaid from the cli and select option 2

    I used omv-firstaid and did option 2.


    So I did this:


    I set HTTP to Port 81

    I set HTTPS to Port 443


    I am back in and both https://192.168.1.103:81/ and https://192.168.1.103:443/ successfully connect - However it removes the https:// when I connect.


    I am using Google Chrome, but I think it is again the server not letting me use TLS/SSL, which is also why I can't fully install and use NextCloud-LetsEncrypt. This is the fundamental issue here.


    Any thoughts why it is doing this?

    Alright so my OMV5 NAS does not connect via HTTPS. It only connected via HTTP, even if I try to force a TLS/SSL connection. I can access the Control Panel, and even network shares where I store my files (via Windows 10 network shares)


    My inability to connect via HTTPS (TLS/SSL) only became a problem when I was trying to install "NextCloud". Its an application that allows you to access files remotely on the internet. This video shows you how to do it as a container in Docker, managed by the application Portainer:



    Skip to 8:00 to 9:00, and he will talk about running some custom code that he made which will basically set up your NextCloud containers.


    However - when you run this guy's code it also requires an encrypted connection, because it sets up something called "NextCloud-LetsEncrypt". This obviously requires that TLS/SSL is enabled on the server for it to work. If you don't have that turned on, then running the code will install the NextCloud application, but not the LetsEncrypt container, and that's a problem


    After some troubleshooting - I figured out how to get it working. I turned off SSL/TLS in OMV5 General Settings, but kept TLS/SSL on in the TLS tab. Then I ran the code on more time, and it worked! All the containers were installed.


    But... I was having trouble with setting up a "fresh" install of NextCloud - so I decided to start from scratch, reinstall everything etc. make it so I could configure NextCloud properly...


    Following his instructions, in General Settings I made my server connect to a different port than HTTP. I set it to Port 81. Then I turned back on TLS/SSL in General Settings....


    Now I try to connect using my internal IP, so it looks like this (including the port number):


    192.168.1.103:81


    Now here is the problem:


    1) Using https://192.168.1.103:81

    I can't connect to the OMV5 control panel using HTTPS, because it says it "refused to connect". As if it is forcing a TLS/SSL connection...


    2) Using http://192.168.1.103:81

    I can't connect using HTTP either - it gives the same error.


    Did I mess it up? I feel like doing either HTTPS or HTTP at Port 81 wont work.


    Furthermore even if I get this working and I get back in - how DO I enable a TLS/SSL connection?


    I ultimately want to be able to complete this guy's video and do a proper NextCloud install. Thanks.

    I have successfully connected to my OMV5 server with OpenVPN over the internet (outside of my home network) with my Laptop running Windows 10.


    My home router has port forwarding to my OMV5 server with port 1194 on (used by OpenVPN). My OMV5 server configuration also has NFS enabled, and I have added to it the shared folder that I want to be able to access (which is the same one I access when I am connected to my home network).


    I had expected to see my NAS server pop up in the "Network and Sharing" center in Windows 10, just like it does when I am connected from my home network. Unfortunately however, it does not appear, and I cannot access my Network Shares from across the internet.


    I have tried solutions such as running:


    net use x: \\vpn.ip.address\share-name


    from the command prompt in the Windows 10 client laptop. However that just gives "System error 53 has occurred. The network path was not found."


    I am at a loss for solutions? Any idea what I am doing wrong?

    No matter what I try, my public IP address (e.g. from whatismyipaddress.com) is not connecting to my OMV server. I have tried connection by both entering the public IP address into my browser, and by using a DuckDNS url.


    Note: This issue first happened after my router was reset. Beforehand, it was connecting when I used the public IP address.


    I have already done the following:

    -Added port forwarding in my router to go my OMV server for ports 443 and 80. (Had it that way before router was reset).

    -Added my OMV server LAN IP address as a Static IP address in my router.

    -Updated /etc/resolv.conf file in my OMV server to have my new router IP address (before reset it was 198.162.2.1 now it is 198.162.1.1)

    -Re-added all SSH and SSL certificates.-Added SSL to "General Settings > Secure Connections"-Tried connecting with "Enable SSL/TLS" and "Force SSL/TLS" disabled or any combination of those two options.

    -Added 8.8.8.8 to "Network > Interfaces > DNS Servers" (Note: In this menu the IPv4 connection method is set to "DHCP" and the IPv6 connection method is set to "Disabled").

    -Successfully pinged 8.8.8.8 and Google.com and received responses.

    -Successfully ran "apt-get update" and "apt-get upgrade" (selecting no configuration changes for most options)

    -Restarted my OMV server several times.


    I am at a loss. It should be connecting simply by typing http://publicipaddress. Is it a configuration issue with OMV or my router? What else am I missing?