Posts by Portal

    Can someo e help me with securing login into admin panel for omv, please?


    If I'm going to login into omv panel outside of home, I would like to have secure connection with my admin login page, because as we all know not encrypted connections are easy to view what kind of data has been typed (login/pw).


    How can I establish ssl for omv admin login panel? I've tried to create own key (4kb) and request it from user but I've learned server is expecting user to have certificate preinstalled before connection. How can I force omv to install certificate to user while connecting/entering login panel? By Eeample: same like with bank login, You don't need to install any certificates to enter Your bank accout, anyway You can see connection is safe/encrypted.

    I have one more question because I am not quite sure of my own lack of knowledge of omv malfunction.


    When I first time install omv os, during creating shared folders, I left priviges only read and write for admin, all users and guests was as no access. Then I grant some users prividges and I couldn't see/enter thoose folders anyway. I was strugling with it half of the night, at the end I wiped whole hdd and I've made a new clean install of Omv os; the same installation I'm using till now.


    When I was creating new shared folders, I tried to set write/read option for admin AND for users. Guests stayed with no access. Then I configure access or limitations for specific users in shared folders menu and allso in users menu. Everythink worked well, without any issue... Till now:

    I've started to installing omv-extras, duckdns and nextcloud. During installation of thoose extensions I was adding shared folders for files, separately for nextcloud, duckdns etc. All folders has been created with access and write /read options for admin AND users. No access for guests. Immediately I was allso configurating access options in users menu and shared folders menu.

    This time when I've entered my omv shared folder location, on my windows machine, I was unable to see new folders. Even when I typed direct path to the location I was unable to open folder and I recieved error message about path doesn't exist or i have no access. I'm sure user id and pw I've used for login got all access granted.

    While ssh->root i can see thoose folders exist with all content.


    Does anybody know why does it happening? How can I fix it?

    Unfortunately thoose 2 commands didn't help. Nothink changes BUT I found somethink interesting in installation, take a look at the screens. (They are in polish but I made some translations and I left some marks. Thoose screens are from complete installation"

    Wymaga: means required
    Ale nie da sie go zainstalować: means but it was impossible to install

    Nastepujace pakiety maja niespelnione zaleznosci: means Following packages has not fullfiled variables

    Greetings everyone !

    Few days ago I've installed and configured OMV on my old laptop. It went smooth, nice and without absolutely any issues. I was so happy OMV user I decided to make it working allso as a cloud, so....

    1) I watched full video about docker and all extras from Techno Dad Life - just from this link:


    2) After installing putty and loging as a root on my server machine, I've copied a link from omv-extras.org and it went smooth, installation finish without any issues.
    3) Here is where the problem occurs: after refreshing page, OMV-Extras did NOT appear in my menu. I tried to reboot machine but it didn't help.

    4) I went back to omv-extras.org and I went to installation through GUI section. I've downloaded a 5th version package , uploaded by GUI, in Plugins section and openmediavault-omvextrasorg-5.4.2 appear on my plugins list. When I checked it and tried to install it I've recieved an information this plugin can not be installed because somethink went wrong.
    5) This is error message:


    >>> *************** Error ***************

    Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C.UTF-8; export DEBIAN_FRONTEND=noninteractive; apt-get --yes --allow-downgrades --allow-change-held-packages --fix-missing --allow-unauthenticated --reinstall install openmediavault-omvextrasorg 2>&1' with exit code '100': Reading package lists...


    Building dependency tree...


    Reading state information...


    Some packages could not be installed. This may mean that you have

    requested an impossible situation or if you are using the unstable

    distribution that some required packages have not yet been created

    or been moved out of Incoming.

    The following information may help to resolve the situation:


    The following packages have unmet dependencies:

    openmediavault-omvextrasorg : Depends: dirmngr but it is not going to be installed

    E: Unable to correct problems, you have held broken packages.

    <<< *************************************


    >>> *************** Error ***************

    Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C.UTF-8; export DEBIAN_FRONTEND=noninteractive; apt-get --yes --allow-downgrades --allow-change-held-packages --fix-missing --allow-unauthenticated --reinstall install openmediavault-omvextrasorg 2>&1' with exit code '100': Reading package lists...


    Building dependency tree...


    Reading state information...


    Some packages could not be installed. This may mean that you have

    requested an impossible situation or if you are using the unstable

    distribution that some required packages have not yet been created

    or been moved out of Incoming.

    The following information may help to resolve the situation:


    The following packages have unmet dependencies:

    openmediavault-omvextrasorg : Depends: dirmngr but it is not going to be installed

    E: Unable to correct problems, you have held broken packages.

    <<< *************************************




    6) I didn't modify any files on server machine or anythink with GUI - everythink is just OEM, like installed with OS.

    7) I allso doesn't see flashmemory update on the list...

    8 ) Copying link with -wget from website and installing it again doesn't help :( Installed successfull again...

    9) My OMV version: 5.5.13-1 (Ursul)

    10) Plzz help :(