Posts by NunoAlex

    Hello OMV experts,


    I'm using Rsync client + RSync Server (2 x Raspberry 4B) to backup data from one NAS to a backup NAS and everything was working fine for a month or two.

    I recently had to rebuild the Raid storage on the backup NAS and I had to delete/recreate all the Rsync jobs (nothing changed on the Rsync server).

    However, now when I manually start a RSync Job, I get this error:



    The rsync job seems to work fine but I can't see the job output on the UI due to the error above and I'm getting spammed every 2 minutes with an email like this:


    Code
    Subject: [HOSTNAME] Cron
    Please wait, syncing <USERNAME@192.168.x.x::MODULENAME> to </srv/dev-disk-by-uuid-1234567-..-1234560abcd/backups/MODULENAME/> ...
    receiving incremental file list
    sent 4,197 bytes received 4,053,016 bytes 62,902.53 bytes/sec total size is 765,478,487,390 speedup is 188,671.01 The synchronisation has completed successfully.


    If I disable the option to "Send command output via email" on the Rsync Job everything works and I can see the Rsync progress on the system logs, but I'm wondering what happened since this was working fine before, i.e. I was able to start an Rsync job, see the output on the UI and receive 1 single email when finished with all the output together.


    I've already tried to re-create the jobs again without success. I'm using the latest build and I have already installed all the available updates and rebooted the device.


    Any thoughts? :)

    To resolve this issue in OMV5 follow the solution at How to increase the "space usage .... matches resource limits" in OMV 5






    Credit goes to @gderf !

    Quote

    install usrmerge (sudo apt-get install usrmerge).

    I used this method and it fixed this issue but had to make some changes, I hope it didn't mess up anything.

    Here's what happened:


    1. Initial attempts to install usrmerge was throwing an error:




    2. Compared the folders /usr/bin and /bin and the latter seem to have less 'things' so I decided to rename the /bin/upssched-cmd to

    /bin/upssched-cmd.old


    Bash
    sudo mv /bin/upssched-cmd /bin/upssched-cmd.old



    3. Tried installing usrmerge again and it worked!


    Bash
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    usrmerge is already the newest version (21).
    0 upgraded, 0 newly installed, 0 to remove and 4 not upgraded.
    1 not fully installed or removed.
    After this operation, 0 B of additional disk space will be used.
    Do you want to continue? [Y/n]
    Setting up usrmerge (21) ...
    The system has been successfully converted.




    4. [IMPORTANT] Reboot machine



    5. Then enabled 'UPS' with success!


    Hope that helps.

    Note: Using OMV5 on a Raspberry 4B