there's a workaround for this.
Didn't work.
there's a workaround for this.
Didn't work.
OK, last question.
There are no data in Compose. Looks like fresh installed (That's exactly what happened ;).
Is there a way to restore the old data?
Pinfeed
Ok, did it.
Looks like everythings is fine. Found Compose, Docker and all the other stuf I need.
Thanks for this fast support ![]()
Pinfeed
After the Upgrade everything wents fine. But I miss the Compose Service. Also there is no OMV-Extra under System.
I installed OMV-Extra via SSH. Under Plugins, it's shown as installed.
Surprisingly, Jellyfin is working. Jellyfin was installed via Compose and Docker under OMV 6. I'm not having any problems at the moment, but I'd still like to update Jellyfin soon. ![]()
Anny Suggestions?
Pinfeed
First of all:
Thank you to all of you for helping. I learned a lot and i have less shares then before new installation
And everything runs fine. Jellyfin an Docker are running also.
Software isn'my thing.
My profession is to design LAN and WAN networks ![]()
But I've a question. What for is the Option Docker repo? Docker was running also without this? Do I need it? At the moment it is activated.
Have a nice day.
Thanks a lot to all ![]()
You take my frustration away
![]()
Now the last part is to install Jelflyin again ![]()
Hir,
i'm not able to install compose. I got an error message:
Failed to read from socket: Connection reset by peer
OMV\Rpc\Exception: Failed to read from socket: Connection reset by peer in /usr/share/php/openmediavault/rpc/rpc.inc:172
Stack trace:
#0 /usr/share/php/openmediavault/rpc/proxy/json.inc(97): OMV\Rpc\Rpc::call()
#1 /var/www/openmediavault/rpc.php(45): OMV\Rpc\Proxy\Json->handle()
#2 {main}
I found compose under services.
I've massive trouble with omv-compose. I reinstalled OMV 6, hoping it will be better working. But this never happend. IMO omv-compose is not a big hit. Before compose, i was able to install portainer and then jellyfin. With compose i don't now what to do.
Sorry, i must tell this.It's frustrating with all this errors.
So what can i do to get compose run? And is ther a tutorial to get dockker run? Found no tutorial for the current version. All tutorials don't look like my installation
Pinfeed
You'll be better off, using the Debian bullseye netinst ISO (v11.7 is the last one before bookworm v12 which won't work with OMV) with only SSH server package ticked.
After, run the install script and you'll bypass all those issues and will be on latest and greatest.
Thanks. I'll try it this week.
For the moment it looks like this works for me:
systemctl unmask proftpd.service
Which image did you use to install OMV?
What system are you using? arm or x64?
openmediavault_6.0.24-amd64.iso
Hi again,
the problem with error 500 is allways present. I can't install plugins. I got allways error 500. Here the error messages after tring to installe compose:
This happens also with any other plugin.
The system is a fresh setup. started with usb stick.
Problem solved. I had a drive with no filesystem online. It was conected to the eSTA connector to bring backup on the new system. I had this drive cleared before vacation. The drive (SSD, very small) was places behind the server. Now everything wents fine again
Thanks or support,
Pinfeed
Or, use the reset permissions plugin
try ro install the reste permisson plugin. This is the result:
Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C.UTF-8; export LANGUAGE=; export DEBIAN_FRONTEND=noninteractive; apt-get --yes --allow-downgrades --allow-change-held-packages --fix-missing --allow-unauthenticated --reinstall install openmediavault-resetperms 2>&1' with exit code '100': Reading package lists...
Building dependency tree...
Reading state information...
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 0 not upgraded.
6 not fully installed or removed.
Need to get 0 B/7340 B of archives.
After this operation, 0 B of additional disk space will be used.
(Reading database ...
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 41417 files and directories currently installed.)
Preparing to unpack .../openmediavault-resetperms_6.0.3_all.deb ...
Unpacking openmediavault-resetperms (6.0.3) over (6.0.3) ...
Setting up proftpd-core (1.3.7a+dfsg-12+deb11u2) ...
usermod: no changes
Synchronizing state of proftpd.service with SysV service script with /lib/systemd/systemd-sysv-install.
Executing: /lib/systemd/systemd-sysv-install enable proftpd
Failed to enable unit: Unit file /etc/systemd/system/proftpd.service is masked.
dpkg: error processing package proftpd-core (--configure):
installed proftpd-core package post-installation script subprocess returned error exit status 1
dpkg: dependency problems prevent configuration of proftpd-mod-vroot:
proftpd-mod-vroot depends on proftpd-abi-1.3.7a; however:
Package proftpd-abi-1.3.7a is not installed.
Package proftpd-core which provides proftpd-abi-1.3.7a is not configured yet.
dpkg: error processing package proftpd-mod-vroot (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of openmediavault-ftp:
openmediavault-ftp depends on proftpd-mod-vroot; however:
Package proftpd-mod-vroot is not configured yet.
dpkg: error processing package openmediavault-ftp (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of proftpd-mod-crypto:
proftpd-mod-crypto depends on proftpd-core (= 1.3.7a+dfsg-12+deb11u2); however:
Package proftpd-core is not configured yet.
dpkg: error processing package proftpd-mod-crypto (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of proftpd-mod-wrap:
proftpd-mod-wrap depends on proftpd-core (= 1.3.7a+dfsg-12+deb11u2); however:
Package proftpd-core is not configured yet.
dpkg: error processing package proftpd-mod-wrap (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of proftpd-basic:
proftpd-basic depends on proftpd-core; however:
Package proftpd-core is not configured yet.
proftpd-basic depends on proftpd-mod-wrap; however:
Package proftpd-mod-wrap is not configured yet.
proftpd-basic depends on proftpd-mod-crypto; however:
Package proftpd-mod-crypto is not configured yet.
dpkg: error processing package proftpd-basic (--configure):
dependency problems - leaving unconfigured
Setting up openmediavault-resetperms (6.0.3) ...
Updating configuration database ...
Processing triggers for openmediavault (6.4.8-1) ...
Updating workbench configuration files ...
Restarting engine daemon ...
Errors were encountered while processing:
proftpd-core
proftpd-mod-vroot
openmediavault-ftp
proftpd-mod-crypto
proftpd-mod-wrap
proftpd-basic
E: Sub-process /usr/bin/dpkg returned an error code (1)
OMV\ExecException: Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C.UTF-8; export LANGUAGE=; export DEBIAN_FRONTEND=noninteractive; apt-get --yes --allow-downgrades --allow-change-held-packages --fix-missing --allow-unauthenticated --reinstall install openmediavault-resetperms 2>&1' with exit code '100': Reading package lists...
Building dependency tree...
Reading state information...
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 0 not upgraded.
6 not fully installed or removed.
Need to get 0 B/7340 B of archives.
After this operation, 0 B of additional disk space will be used.
(Reading database ...
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 41417 files and directories currently installed.)
Preparing to unpack .../openmediavault-resetperms_6.0.3_all.deb ...
Unpacking openmediavault-resetperms (6.0.3) over (6.0.3) ...
Setting up proftpd-core (1.3.7a+dfsg-12+deb11u2) ...
usermod: no changes
Synchronizing state of proftpd.service with SysV service script with /lib/systemd/systemd-sysv-install.
Executing: /lib/systemd/systemd-sysv-install enable proftpd
Failed to enable unit: Unit file /etc/systemd/system/proftpd.service is masked.
dpkg: error processing package proftpd-core (--configure):
installed proftpd-core package post-installation script subprocess returned error exit status 1
dpkg: dependency problems prevent configuration of proftpd-mod-vroot:
proftpd-mod-vroot depends on proftpd-abi-1.3.7a; however:
Package proftpd-abi-1.3.7a is not installed.
Package proftpd-core which provides proftpd-abi-1.3.7a is not configured yet.
dpkg: error processing package proftpd-mod-vroot (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of openmediavault-ftp:
openmediavault-ftp depends on proftpd-mod-vroot; however:
Package proftpd-mod-vroot is not configured yet.
dpkg: error processing package openmediavault-ftp (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of proftpd-mod-crypto:
proftpd-mod-crypto depends on proftpd-core (= 1.3.7a+dfsg-12+deb11u2); however:
Package proftpd-core is not configured yet.
dpkg: error processing package proftpd-mod-crypto (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of proftpd-mod-wrap:
proftpd-mod-wrap depends on proftpd-core (= 1.3.7a+dfsg-12+deb11u2); however:
Package proftpd-core is not configured yet.
dpkg: error processing package proftpd-mod-wrap (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of proftpd-basic:
proftpd-basic depends on proftpd-core; however:
Package proftpd-core is not configured yet.
proftpd-basic depends on proftpd-mod-wrap; however:
Package proftpd-mod-wrap is not configured yet.
proftpd-basic depends on proftpd-mod-crypto; however:
Package proftpd-mod-crypto is not configured yet.
dpkg: error processing package proftpd-basic (--configure):
dependency problems - leaving unconfigured
Setting up openmediavault-resetperms (6.0.3) ...
Updating configuration database ...
Processing triggers for openmediavault (6.4.8-1) ...
Updating workbench configuration files ...
Restarting engine daemon ...
Errors were encountered while processing:
proftpd-core
proftpd-mod-vroot
openmediavault-ftp
proftpd-mod-crypto
proftpd-mod-wrap
proftpd-basic
E: Sub-process /usr/bin/dpkg returned an error code (1) in /usr/share/openmediavault/engined/rpc/pluginmgmt.inc:247
Stack trace:
#0 /usr/share/php/openmediavault/rpc/serviceabstract.inc(619): Engined\Rpc\PluginMgmt->Engined\Rpc\{closure}('/tmp/bgstatusKz...', '/tmp/bgoutputWZ...')
#1 /usr/share/openmediavault/engined/rpc/pluginmgmt.inc(251): OMV\Rpc\ServiceAbstract->execBgProc(Object(Closure))
#2 [internal function]: Engined\Rpc\PluginMgmt->install(Array, Array)
#3 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)
#4 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('install', Array, Array)
#5 /usr/sbin/omv-engined(537): OMV\Rpc\Rpc::call('Plugin', 'install', Array, Array, 1)
#6 {main}
Display More
I think i have other problems ![]()
BTW, ther is no Compose or Docker on my server. I've a fresh installation. The drive was for Docker on my old System ( also OMV 6)
Hi,
i have a file system from an old drive. all references are deleted. SMB, FTP, shared folders, omv backup, users and so on. I don't know, where to search npow. Is there a way to see, what reference blocked the deleting of this old system? The drive was used für docker data. But at the moment, there is no docker in use.
Pinfeed
Thanks to all helping people.
New installation is running. Now I have to mount my data drives, mini dlna, and so on.
After finishing, i'll make a backup. Then i try to run jellyfin again ![]()
Have a nice sunday.
I think that there is a need to add : "network_mode: bridge" line just below "container_name: jellyfin
thanks, but its to late. installed new drive and OMV ...
When do you get that error? What were you doing? Is there any more information you can provide?
With that information alone it is difficult to diagnose a patient.
After alle trouble, i decide to start by zero
I made a fresh install.
New drive installed.
Downlading the latest image.
Starting from usb stick.
Waiting until installation ends.
open the gui in my webbrowser
Getting the error directly after startinging gui.
Thats it.
Hi again,
i changed my bootdrive and installed OMV completly new.
After starting OMV and opening the gui I got the following error messages:
404 - Not Found The method 'enumerate' does not exist for the RPC service 'Exec'. a few seconds ago
I'm a little bit surprised, because it's a new installation?
Sorry forgot something ![]()
Must go to sleep. Have to get up 3:45 am ![]()
More tomorow
MY OMV isn't only for Media. Its for Backup of my System. And for 3 Smartphones.. Via rsync I made copy of important data. So i have redundance.
And my biggest problem is, my linux skills are not the best. Have you a tip for something to read for me to get mor informagtion about permissions and shares?
---
# https://hub.docker.com/r/linuxserver/jellyfin
version: "2.1"
services:
jellyfin:
image: lscr.io/linuxserver/jellyfin:latest
container_name: jellyfin
environment:
- PUID=1008
- PGID=100
- TZ=Europe/Berlin
- JELLYFIN_PublishedServerUrl=192.168.0.127 #optional
volumes:
#- /srv/dev-disk-by-uuid-300e87a3-55c4-458e-b322-6308be2ed854/DBackup/JellyFin:/config
- /srv/dev-disk-by-uuid-f90c1631-ae40-49af-b307-12147525ee12/Media:/media
- /srv/dev-disk-by-uuid-3b5b8fcb-30d4-46b2-b441-31f5bb49769c/data/appdata/jellyfin:/config
ports:
- 8096:8096/tcp
#- 8920:8920 #optional
#- 7359:7359/udp #optional
#- 1900:1900/udp #optional
restart: unless-stopped
Display More
Here it is. Yesterday, before using Reset Permissions, this YML works ![]()
I don't see the Media folder
?? it called Media. The third from the bottom.