Posts by greg77

    I installed iperf but what options do i use ?

    On one of the devices (i.e. Raspberry Pi) run it as a server:

    iperf3 -s -f K

    and on the other (your PC, I use Linux, but I'm sure there is iperf for other OS's too) as a client connecting to that iperf 'server':

    iperf3 -c -f K

    change the ip address to you iperf server IP you run the first code from above.

    Both machine will give you similar results. Paste the results from one of them here.

    In meantime (before the new version of the plugin will be distributed) based on your changes in Github I added a line:


    to /etc/default/openmediavault and changed old find line in omv-backup to:

    find "${backupDir}" -maxdepth ${OMV_BACKUP_MAX_DEPTH} -type f -mtime +${keep} -name "${OMV_BACKUP_FILE_PREFIX}*" -delete

    as you updated it in Github repository.

    The backup ran last night. Created a new one, but haven't deleted the old ones.

    Will investigate more in the evening when I'm back home, but it seems like the script finds old files in:


    but OMV_BACKUP_DIR_NAME in my case is dependant on a current date (and everytime the script runs the dir path if different, thus old files / dirs are not deleted):

    OMV_BACKUP_DIR_NAME="/backups/omvbackup/`date +%y-%m-%d-%H`/"

    so I guess I need to move date part to file prefix and make it look something like:

    OMV_BACKUP_FILE_PREFIX="`date +%y-%m-%d-%H`/omv__"

    That will make the script to find old file in .../omvbackup/ dir. However I'm not sure if slash ("/") can be placed as a part of file prefix and if it's going to be recognised as directory name.

    Will change the settings and run it manually tonight when get back home and see the result.

    Many thanks ryecoaaron for your help with that.


    Tried to put a date in the prefix part, but it says No such file or directory:

    Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C.UTF-8; /usr/sbin/omv-backup 2>&1': Method: ddfull
    Device file: /dev/root
    Root drive: /dev/mmcblk0
    /usr/sbin/omv-backup: line 84: /srv/dev-disk-by-uuid-83a49c51-f71d-4fd0-a4f0-028b95102cd7/backups/omvbackup/21-03-05-19/omv__-05-Mar-2021_19-49-34.fdisk: No such file or directory

    The script should make the directory (based on a current date) first :(

    EDIT 2:

    Would it be possible to have a different date format in filenames? I personally prefer date +"%y-%m-%d_%H-%M-%S" instead of hardcoded date +"%d-%b-%Y_%H-%M-%S" (better for sorting files by name from the oldest to newest).

    Again - I'm going to change it manually for now and don't use sub-dirs, but it will be overwritten on the plugin update.

    Happy to modify some file, but I guess they will be restored to 'factory' on the backup plugin update.

    May be safer and more reliable if I keep all backups in the same directory. Then it should work straight away.

    In meantime is there any place (github?) I can report a bug / request a feature to make it work in a future?

    The result of ls command is nothing. The same with the find command.

    However it returns a list of files if I change -maxdepth to 2 (I have it in sub-directories as explained in my first post (also sub-dirs are listed below for you reference.

    I've got it set to 5, but last night just got one more backup without deleting the old one, so I've got 8 of them at the moment. Will wait another 48 hours so see if creating another one will delete the very old one too.

    I'm guessing the problem may be the path and sub-directories where the backups are saved as cubemin suggested in a previous post. Will change it in a few days and see.

    when I installed OMV it was using only UUID names.

    I personally just created links (I mean - using ln command) with a human readable label to particular UUID name. The system uses UUID, but I can quickly access directories and drive using labels if I need to.


    I use backup plugin with scheduled backup jobs (running every 2 days).

    There is an option Keep (with description "Keep the last x days of backups"). I have is set to 5, but doesn't seems like old backups are deleted. At the moment I have 7 backups and the oldest is from the 17th of Feb. The only non-standard thing is a different path and additional sub-directory for backups added in /etc/default/openmediavault and it looks like that:

    OMV_BACKUP_DIR_NAME="/backups/omvbackup/`date +%y-%m-%d-%H`/"

    which saves a backup to /backups/omvbackup/ and sub-directory with a current date and hour.

    Could anyone explain how to set it up to keep only last few backups please?



    I have 4GB version, but OMV5 with a light usage and SMB + NFS active uses 4% of memory. Currently 136MB used. Max used value was 165MB. A page cache occasionally goes up to 3.5GB (rsync or backup process), but usually stays at around 1.0-1.5GB, so 4GB is plenty for OMV use, unless you use it heavily.

    It doesn't look like /srv takes lot of space.

    Is the 5.1G in root fs ("/") a swapfile?

    Also 1.5G in /var looks suspicious after cleaning logs and apt cache.

    try du -xhd1 /var to see, but anyway it's only 1.5GB (BTW what is the size of your drive?).

    sudo apt-get clean
    sudo apt-get autoremove -y
    sudo find /var/log -mindepth 1 -mtime +3 -delete

    First two lines will clean apt cache and remove not used dependencies.

    Last line will delete logs older than 3 days.

    That should free up some space.

    Try this command before and after the cleanup to see if there is any difference:

    df –h

    I'm not sure if it helps, but when I try to login to OMV from Firefox on my Android phone it redirects to login page all the time (after putting the correct credentials). Maybe it's something to do with your browser? Try a different one if you can.

    I first read about the MS repo a week or so after my first OS Lite installation, then OMV installation via the script on RPi2B. Checked the /etc/apt/sources.list.d/vscode.list file. It existed, but it was empty already.

    Then a couple of days ago I installed OS via the same image and OMV via the same script on my brand new RPi4 and the same situation - vscode.list file is empty.

    So I don't think it's a script.

    Hi all,

    Yesterday one of my scheduled rsync jobs (added via services > rsync > jobs) executed ok.

    Files copied, log generated, notification email sent.

    Last night there was another job. Same setting as above, but syncing different folders on a different day.

    I've checked it this morning - files copied, but nothing in rsync logs (last rsync jobs log is from the first job above) and no email notification.

    When checked a CPU load and Disk I/O and Disk space in OMV GUI I can see there was an activity from around 2am for 2 hours, so exactly when the the rsync job was scheduled.

    The system is up-to-date OMV5 on RPi4 if that helps.

    I use Linux for last 15 years (as a user rather than a programmer), but never seen anything line that before.

    Could someone explain it?

    Please paste here a results of these two commands:

    find / -iname *phpvirtualbox*


    grep -R "phpvirtualbox" /etc/* | less

    1st will output all files matching pattern *phpvirtualbox* in their name (case insensitive)

    2nd will find all files in /etc which content word phpvirtualbox in them

    In both cases we expect config files of php or a web server.