Posts by fitur

    Just a hint, I installed a fresh OMV 3.0.59 system. When choosing between Plex as docker-image vs plex as omv-plugin I decided to install it via omv-plugin. Maybe it would be easier for you to manage plex via plugin then resolving the docker issues?

    I'm using the OMV-Plex-plugin and not Docker-plex. I meant the OMV-Docker-plugin isn't working either.

    I rebooted my server and ran into these error messages when trying to start plexmediaserver:



    I noticed that Docker didn't work properly after the reboot, which made me realize that Plex didn't work either. I tried re-installing the plugins, but no success...

    Hi,
    I was attempting to download PlexRequests and set it up for autostart when I came across this error message:

    Code
    perl: warning: Setting locale failed.
    perl: warning: Please check that your locale settings:
    LANGUAGE = "en_US:en",
    LC_ALL = (unset),
    LC_CTYPE = "UTF-8",
    LANG = "en_US.UTF-8"
    are supported and installed on your system.
    perl: warning: Falling back to a fallback locale ("en_US.UTF-8").


    AFAIK, I haven't done anything to modify locales prior to this error message.
    After Googling around I attempted:



    Code
    sudo locale-gen "en_US.UTF-8"
    sudo dpkg-reconfigure locales


    Which generates the following error message:


    What am I doing wrong here?

    Sorry i forgot that i had this issue, it came to me when i changed a setting in omv general settings in nginx, there was a commit in dec 2015 about the default server, when i applied the change all my local domains went down (almost a year after the commit). I solved this by adding one extra listen line in each block, so every host should have


    Code
    listen 80;
    listen [::]:80;

    You can return to your default omv nginx by using omv-mkconf nginx then restart the service

    I just noticed that the listening port change each time I edit a setting in the webGUI that change anything with NGINX. The new line gets deleted.


    Thanks!

    no, the ones at /etc/nginx/sites-enabled/

    Sorry, still doesn't work.
    I've tried manually including the multi_host file in nginx.conf. I've tried changing the name of multi_host to zmulti_host.
    Nothing seem to do the trick. Are you using OMV 2.1 or 3.0 yourself?


    EDIT 1: I just noticed that when I try to change the webGUI port, the new port works (88) but 80 still work as well.
    Tried setting it to 80 and 88 through OMV-firstaid and the port I specify show up in the webGUI but 80 always work either way.


    EDIT 2: my /etc/nginx/sites-enabled/openmediavault-webgui file listened on port 80 while the same file in sites-available was listening to whatever I specified in the webGUI config page (General Settings) or OMV-firstaid.
    I'm not sure if I've messed with a symlink during first day of setup, but I managed to get a grip on the listening port by symlinking from sites-available/openmediavault-webgui to sites-enabled/openmediavault-webgui, which then resolves that issue.
    However, no luck with proxy_pass and the multi_host file.


    EDIT 3: Resolved by editing openmediavault-webgui. Swapped listen 80; to listen [::]:80 default_server ipv6only=off; which I fortunately found in the old multi_host backup where I "accidentally" backed up the whole folder.


    Merry Christmas!

    I think the problem now ngnix loads in order. So first should be omv default config, then use your file. So maybe change the first letter to z of your ngnix configuration.

    I have a file called openmediavault-something in te sites-enabled folder but no default. Which nginx-configuration should I rename? /etc/nginx/nginx.conf?

    What worked? Are you using the nginx plugin?

    I was able to re-route subdomains to specific ports. As subzero79 explained in the guide.
    I did this without a plugin in Stone Burner but since I re-installed OMV and used Erasmus instead, this method no longer works, even though the nginx.conf includes /etc/nginx/sites-enabled/* and I have a multi_host file in that folder.

    Hi,
    I recently tried to install HomeBridge on my OMV 2.2.13 box but since I'm not very good with Linux, I may have messed something up.


    According to the guide i read, I had to change the /etc/apt/sources.list so that the top two rows said Jessie instead of Wheezy.
    Then I had to install GCC and G++, which I did. Then, since HomeKit didnt work anyway, I uninstalled the packages and reverted the changes in sources.list.


    Now, I get errors each time I try to install something. Both via the WebGUI and through a terminal. Everything I do ends with "E: Unable to correct problems, you have held broken packages."


    I've tried apt-get autoclean, apt-get dist-upgrade, apt-get update, apt-get upgrade, apt-get purge, you name it. It gives no error whatsoever.
    Also, I've set to only use community-based updates and not pre-release updates.


    What can I do besides re-installing OMV from scratch?


    Thanks and happy holidays!