Posts by privacy313

    I still have a problem with trying to add any new shared folders.

    I get the error:


    Code
    Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C.UTF-8; omv-salt deploy run --no-color avahi 2>&1' with exit code '1': raspberrypi: ---------- ID: mask_avahi_service Function: service.masked Name: avahi-daemon Result: True Comment: Service avahi-daemon was masked Started: 18:29:22.860333 Duration: 725.848 ms Changes: ---------- masked: ---------- new: True old: False ---------- ID: stop_avahi_socket Function: service.dead Name: avahi-daemon.socket Result: True Comment: Service avahi-daemon.socket has been disabled, and is dead Started: 18:29:23.586989 Duration: 1056.716 ms Changes: ---------- avahi-daemon.socket: True ---------- ID: stop_avahi_service Function: service.dead Name: avahi-daemon.service Result: True Comment: Service avahi-daemon.service is already disabled, and is dead Started: 18:29:24.644564 Duration: 275.593 ms Changes: ---------- avahi-daemon.service: False ---------- ID: configure_default_avahi_daemon Function: file.managed Name: /etc/default/avahi-daemon Result: True Comment: File /etc/default/avahi-daemon is in the correct state Started: 18:29:24.929288 Duration: 112.695 ms Changes: ---------- ID: divert_default_avahi_daemon Function: omv_dpkg.divert_add Name: /etc/default/avahi-daemon Result: False Comment: State 'omv_dpkg.divert_add' was not found in SLS 'omv.deploy.avahi.05configure' Reason: 'omv_dpkg.divert_add' is not available. Changes: ---------- ID: configure_avahi_daemon_conf Function: file.managed Name: /etc/avahi/avahi-daemon.conf Result: True Comment: File /etc/avahi/avahi-daemon.conf is in the correct state Started: 18:29:29.707802 Duration: 42.662 ms Changes: ---------- ID: divert_avahi_daemon_conf Function: omv_dpkg.divert_add Name: /etc/avahi/avahi-daemon.conf Result: False Comment: State 'omv_dpkg.divert_add' was not found in SLS 'omv.deploy.avahi.05configure' Reason: 'omv_dpkg.divert_add' is not available. Changes: ---------- ID: remove_avahi_service_ftp Function: file.absent Name: /etc/avahi/services/ftp.service Result: True Comment: File /etc/avahi/services/ftp.service is not present Started: 18:29:29.801332 Duration: 1.59 ms Changes: ---------- ID: remove_avahi_service_nfs Function: module.run Result: True Comment: file.find: ['/etc/avahi/services/nfs-music.service', '/etc/avahi/services/nfs-pictures.service', '/etc/avahi/services/nfs-videos.service', '/etc/avahi/services/nfs-work.service'] Started: 18:29:29.803248 Duration: 4.67 ms Changes: ---------- file.find: - /etc/avahi/services/nfs-music.service - /etc/avahi/services/nfs-pictures.service - /etc/avahi/services/nfs-videos.service - /etc/avahi/services/nfs-work.service ---------- ID: configure_avahi_service_nfs_videos Function: file.managed Name: /etc/avahi/services/nfs-videos.service Result: True Comment: File /etc/avahi/services/nfs-videos.service updated Started: 18:29:29.808285 Duration: 28.907 ms Changes: ---------- diff: New file mode: 0644 ---------- ID: configure_avahi_service_nfs_music Function: file.managed Name: /etc/avahi/services/nfs-music.service Result: True Comment: File /etc/avahi/services/nfs-music.service updated Started: 18:29:29.837604 Duration: 19.189 ms Changes: ---------- diff: New file mode: 0644 ---------- ID: configure_avahi_service_nfs_pictures Function: file.managed Name: /etc/avahi/services/nfs-pictures.service Result: True Comment: File /etc/avahi/services/nfs-pictures.service updated Started: 18:29:29.857312 Duration: 18.762 ms Changes: ---------- diff: New file mode: 0644 ---------- ID: configure_avahi_service_nfs_documents Function: file.managed Name: /etc/avahi/services/nfs-documents.service Result: True Comment: File /etc/avahi/services/nfs-documents.service updated Started: 18:29:29.876497 Duration: 18.332 ms Changes: ---------- diff: New file mode: 0644 ---------- ID: remove_avahi_service_rsync Function: file.absent Name: /etc/avahi/services/rsync.service Result: True Comment: File /etc/avahi/services/rsync.service is not present Started: 18:29:29.895325 Duration: 1.936 ms Changes: ---------- ID: configure_avahi_service_smb Function: file.managed Name: /etc/avahi/services/smb.service Result: True Comment: File /etc/avahi/services/smb.service is in the correct state Started: 18:29:29.897701 Duration: 39.16 ms Changes: ---------- ID: configure_avahi_service_ssh Function: file.managed Name: /etc/avahi/services/ssh.service Result: True Comment: File /etc/avahi/services/ssh.service is in the correct state Started: 18:29:29.937341 Duration: 23.58 ms Changes: ---------- ID: configure_avahi_service_webadmin Function: file.managed Name: /etc/avahi/services/website.service Result: True Comment: File /etc/avahi/services/website.service is in the correct state Started: 18:29:29.961284 Duration: 24.68 ms Changes: ---------- ID: unmask_avahi_service Function: service.unmasked Name: avahi-daemon Result: True Comment: Service avahi-daemon was unmasked Started: 18:29:29.986349 Duration: 673.07 ms Changes: ---------- masked: ---------- new: False old: True ---------- ID: start_avahi_socket Function: service.running Name: avahi-daemon.socket Result: True Comment: Service avahi-daemon.socket has been enabled, and is running Started: 18:29:30.660136 Duration: 1042.091 ms Changes: ---------- avahi-daemon.socket: True ---------- ID: start_avahi_service Function: service.running Name: avahi-daemon.service Result: True Comment: Service avahi-daemon.service is already enabled, and is running Started: 18:29:31.703053 Duration: 265.901 ms Changes: ---------- avahi-daemon.service: True Summary for raspberrypi ------------- Succeeded: 18 (changed=11) Failed: 2 ------------- Total states run: 20 Total run time: 4.375 s

    Yesterday I was trying to add a new shared NFS directory and OMV gui returned a very long error unable to resolve $PATH.

    This was my 4th NFS shared folder I was adding. I added it in the same manner as the others, so I'm quite clueless where this error came from.

    Looking into the situation it seems the nfs-server.service has failed on my pi. I have tried disabling and enabling and restarting. I get the error "Job for nfs-server.service cancelled."

    I have reinstalled nfs-common and nfs-kernel-server with no luck.


    I checked in /etc/exports and the share I tried to create that caused the problem was there -- so i deleted it.. but the issue persists. nfs-server.service is always failed.


    I'm really at a loss of how to troubleshoot this further. Can anyone help?

    Hey there,


    I've just set up my first NAS.

    It's a Raspberry Pi 4B with USB HDD.

    The OS and OMV are installed on on the SD card.


    The Pi is plugged into my router (Compal CH7466CE) via Ethernet, as is the client computer.


    I've set up an NFS shared folder and mounted it on my client computer with fstab.

    All seems to be running fine except transfer speeds are much slower than I expected.

    Copying files with rsync shows transfer speeds of ~2.5MB/s. Rsync also updates the progress information very slowly.


    htop shows CPU usage of max 17% on each core (often much lower) on the RPi server.


    What could be the bottleneck here?


    Any help would be really appreciated. Thanks.