Posts by ottoking

    pretty much nothing...


    Why not just apt-get install docker-ce (so that its the latest version) and then then the docker-gui should install fine.
    OR otherwise apt-get install openmediavault-docker-gui try that.

    Code
    root@LianLi:~# apt install docker-ce
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    docker-ce is already the newest version (5:19.03.0~3-0~debian-stretch).
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

    Tried it but again failed - docker-ce is already the latest, I just cannot install docker-gui. I've already rebooted the machine, no change getting the same error.

    I'm kinda stuck here too.... Docker in GUI gone, trying to install openmediavault-docker-gui again gives me the error:
    >>> *************** Error ***************Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C.UTF-8; export DEBIAN_FRONTEND=noninteractive; apt-get --yes --allow-downgrades --allow-change-held-packages --fix-missing --allow-unauthenticated --reinstall install openmediavault-docker-gui 2>&1' with exit code '100': Reading package lists...

    Building dependency tree...

    Reading state information...

    Some packages could not be installed. This may mean that you haverequested an impossible situation or if you are using the unstabledistribution that some required packages have not yet been createdor been moved out of Incoming.The following information may help to resolve the situation:

    The following packages have unmet dependencies: openmediavault-docker-gui : Depends: openmediavault-omvextrasorg (>= 4.1.15) but 4.1.13 is to be installedE: Unable to correct problems, you have held broken packages.<<< *************************************


    Cannot install version 4.1.5. What now?