Posts by Freya

    I share 5 hard drives using NFS with rw and 'no_subtree_check' as the only option in NFS settings. I can mount the shares using AutoFS on an Ubuntu machine and i can create new files in the subfolders but not in the root dir. Mount point on Ubuntu is '/autofs/omv-data1'. There is an old folder 'data' that was created month ago before i started using OMV. I can write files in /autofs/omv-data1/data but not in /autofs/omv-data1.


    This is the auto.master and the auto.omv1 on Ubuntu:

    Code
    /autofs      /etc/auto.omv_data1    --browse


    Code
    omv-data1 -fstype=nfs,rw,retry=0  192.168.10.35:/export/data1


    I use NFSv3 share also on my raspberry pi (without OMV but with Raspbian Buster). Ths works perfect without these problems.


    After creating the NFS share the mount point was changed from /srv/<hdd-id> to /export/data1. But i have access to the HDD with the old moint point (/srv). Is this correct?

    What do i need to do? I go to storage / shared folder, go to 'create', give a name and choose a 'file system' (there is only one at the moment). Then i have to choose a 'relative path', this cannot be empty. Then i click 'ok' and i have a new 'absolute path'


    Code
    /srv/dev-disk-by-uuid-3c658a4d-e308-430f-82d8-04d7bc4892b3/<relative-path>

    At the end i want to share all hard drives (all with one file system) using NFS. On my client system i want to have one mount point for each hard drive in the server. Thats all what i want.


    This works very easy on my raspberry pi with a normal raspbian image.

    Hi,


    i have a 1GB hard drive with one big ext4 partition and want to create a nfs share for other devices. the normal "mount point" of the file system in OMV is /srv/dev-disk-by-uuid-3c658a4d-e308-430f-82d8-04d7bc4892b3/. When i go to storage/shared folders the shared folder is not "/srv/dev-disk-by-uuid-3c658a4d-e308-430f-82d8-04d7bc4892b3" its "/srv/dev-disk-by-uuid-3c658a4d-e308-430f-82d8-04d7bc4892b3/<name>" and that - of course - an empty folder. How can i create a nfs share for "/srv/dev-disk-by-uuid-3c658a4d-e308-430f-82d8-04d7bc4892b3". I think i will have the same problem with all the other hard drives.


    freya

    I could create a boot stick with UEFI mode using windows 7 in a virtual machine but this did not solve the problem.


    The boot stick has a fat32 partition with esp flag.


    I don't think its a problem with the UEFI mode. I think there is something wrong with the bios/uefi settings.

    There is no ESP-Partotion. The file system is 'iso9660'.


    At the moment i can't test it on a windows-pc. perhaps at the weekend.


    But to understand the problem. I searched a little bit and found some awsers to similar questions. UEFI mode should be a 'image thing', means the image should be in UEFI mode. All my linux are installed on UEFI on systems with GPT and i've always used 'dd'. Is there something different with the OMV-Image?

    Hi,


    i can install OMV 6 from an USB drive to an other USB drive. But when i try to boot then OMV my mainboards starts the UEFI every time. The UEFI recognizes the USB drive and its at first boot position - but doesn't boot. Secure boot is disabled. UEFI isn't in 'Bios Mode' (CSM). Is there a special setting to boot from USB drive when using UEFI? I had never problems with that on other mainboards.


    Installing OMV 6 on a normal 2,5'' HDD works and i can boot from the HDD.


    edit

    i tried this from USB2.0 and USB3.0 ports. all the same.