Posts by flatwhitemark

    are you doing this from omv or the client

    im doing this from my headless raspberrypi via ssh on my pc


    Either run the rclone config on your client and copy the conf file or use the procedure with no browser on the server.

    i've run the rclone config, my remote is saved but unable get the authorization to access google drive.

    Was trying to do rclone config with google drive, until this part;

    Code
    Use auto config? * Say Y if not sure * Say N if you are working on a remote or headless machine
    
    y) Yes (default)
    n) No
    y/n> y
    2022/06/10 13:08:30 NOTICE: If your browser doesn't open automatically go to the following link: http://127.0.0.1:53682/auth?state=5O_S2bHiC_2QyilCB7xDow
    2022/06/10 13:08:30 NOTICE: Log in and authorize rclone for access
    2022/06/10 13:08:30 NOTICE: Waiting for code...

    it should be opening the browser automatically, but it didn't. also face the same issue when i type "n" on auto config. I've use the link that is given but the site can't be reached.

    how do i fix it?

    Code
    config file "/root/.config/rclone/rclone.conf" not found 

    Did you setup rclone as root, it does not look like this.

    The config file is missing.


    copy the file to the right place and retry.

    Hmm, i did not setup rclone as root. I set it as pi. I'm using headless raspberry pi on virtual machine and had my omv and rclone installation + setup from there. I was able to run omv in my normal browser, outside the virtual machine app.

    hi macom i have an issue on scheduled tasks tab in my omv. i was trying to test run the scheduled tasks ( rclone copy files from network shared folder to google drive ) and i received an error in my output;


    This just happen this morning as i'm trying to access OpenMediaVault by the entering the ip addr of my Pi. But it tells me that the site can't be reached. My raspberry is connected to the internet via usb tethering from an android phone and a LAN cable. I unplug one of them and try to ping the hostname but no luck, even though my pc is connected to the internet. I keep getting;


    Did you follow the new user guide (linked in my signature)?

    yes i did follow. it works this morning, i copied a text file and paste to the folder and also manually created a folder. but when i want to paste another file or create another folder, it suddenly shows an error saying that "the media is write protected". not sure what happen. i checked the folder security in properties and everything is okay

    This might be a tricky part as the clients might upload all files again.


    If you want to keep a local versioned backup, have a look at UrBackup. I use it to backup my clients to the server. You can use the latest snapshot to backup offsite.

    Okay.

    Now i have an issue. In the raspberry pi (named GdriveRPI) in my network drive, i wanted to create a folder or a text file inside the shared folder but it shows that the "destination folder access denied"

    The shared folder was created in omv v6 and I've set the permissions to "Everyone: Read/write"


    but still, I can't access it to create a file.

    hi,

    I'm currently using omv, Raspi and rclone in my work place. I've set up a main pc and thinking how to connect all the pc in the office to the main pc. Like all my colleagues work whether its google docs or google spreadsheet or any files, are automatically sent to the main pc in Raspi OMV at a certain time of the day and then upload all the work to google drive as backup. And the files in Raspi are deleted after being uploaded.


    I've already created a drive in rclone for that. Does anyone have idea on how to connect the pc's?

    Correct. There's also 64bit links depending on which pi 3 you have.


    https://www.raspberrypi.com/so…s/#raspberry-pi-os-32-bit


    Download Bullseye, and you'll get OMV 6 (current stable) or Buster, and you'll get OMV 5 (which is going EOL soon)

    Alright. Thank you

    Also, I'm using Raspberry Pi 3 model B v1.2. If I download the lite version of the image from the link that you've provided and install on my current R-Pi 3, is it possible? Because I've downloaded a Raspberry Pi OS Lite to my hard drive from Raspberry Pi Imager and I'm not so sure where to install it.

    Honestly it couldn't have been that recent, as desktop installs have been deliberately blocked by the script for at least a year (maybe longer). This was done because of the problems that arose from installing OMV on top of Desktops.

    I see. So in order to reinstall the OMV, I need to use Lite version of the image? I couldn't find it in Raspberry pi imager

    It says right there why you can't install.


    Installing OMV on a system with a desktop is not supported nor recommended.

    i see. recently i just read a google docs documentation (installation of omv on raspberry pi), that was created by my former co-worker and it shows that she didn't face the issue that i'm facing now. here's the screenshot from her documentation.

    5_YEUKlfiFCqVkd033Px4VLfxSdCQRUNIfLOO1heHYS7IWEF6U9Xhc3XmdAGdg9JaXVLCT7mN6ipYKjUddKyg4knQ6_g3SwaFm6p-k_-1oXREVSEdwyGJwnDcj9YIw9o4Kk3a7qRc-CYyLtzYA

    hi, yesterday i had to remove/uninstall OMV from Raspberry Pi (apt-get remove --autoremove openmediavault) because it had issues in logging in (former co-worker create and setup OMV in raspberry pi and didn't provide the user name and password for OMV), so I tried to reinstall OMV after I wrote the command;

    "pi@raspberrypi:~ $ sudo apt update && sudo apt upgrade"


    then I proceed with install OMV in Raspberry, this is the output I received;


    pi@raspberrypi:~ $ sudo wget -O - https://githubusercontent.com/OpenMediaVault-Plugin-Developers/installScript/raw/master/install | sudo bash

    --2022-05-25 12:24:13-- https://github.com/OpenMediaVa…Script/raw/master/install

    Resolving github.com (github.com)... 20.205.243.166

    Connecting to github.com (github.com)|20.205.243.166|:443... connected.

    HTTP request sent, awaiting response... 302 Found

    Location: https://raw.githubusercontent.…tallScript/master/install [following]

    --2022-05-25 12:24:13-- https://raw.githubusercontent.…tallScript/master/install

    Resolving raw.githubusercontent.com (raw.githubusercontent.com)... 185.199.109.133, 185.199.108.133, 185.199.111.133, ...

    Connecting to raw.githubusercontent.com (raw.githubusercontent.com)|185.199.109.133|:443... connected.

    HTTP request sent, awaiting response... 200 OK

    Length: 19620 (19K) [text/plain]

    Saving to: ‘STDOUT’


    - 100%[==============================================>] 19.16K --.-KB/s in 0.009s


    2022-05-25 12:24:13 (1.99 MB/s) - written to stdout [19620/19620]


    This system is running a desktop environment!

    Please use a Lite version of the image or

    do not choose to install a desktop environment.

    This install is not supported.

    Search the forum for more info - https://forum.openmediavault.org

    Exiting...

    pi@raspberrypi:~ $



    Any help will be very much appreciated. Thank you in advanced.

    Did not follow everything, but the error is telling you that the job could not find restic. Try to use the absolute path for restic in the script/scheduled job.

    /usr/bin/restic instead of just restic


    confirm that which restic gives you /usr/bin/restic

    thank you for the response. i see, may i know where can i find the path for restic in the schedule job?

    hi all, i'm a newbie to this omv and rclone. I've already set up everything in the open media vault.

    So, today i tried to create a drive through rclone configuration on my windows command prompt for my destination source on open media vault > schedules task > command "rclone move /srv/dev-disk-by-uuid-5a368b5d-0c6a-46fd-8474-ce66029f49c3/MyDrive" . I've gone through the steps in rclone config online and there's one part where authorizing rclone on google account, a code should appear in the google like this;

    WmgctOUGdNDewJRGp2E_0QE7DoCjzT2auQfDNR-Vi_1r4aiXXRPNByzN-7hm_K9cTaGQhbU14p-on4CFQaubTPoNjeQHWGTj28K2ax5ymC0jWw3pZqTjSLVxVt9wTA-WU2_-pSr-eHW6jtxBVg


    but it didn't appear on mine. shows like this instead. so i open new cmd window and type out; rclone authorize "drive" "code" and it opens a new tab in my browser rclone requesting access on google which i've allowed it.

    and it generates a long line of config_token. after im done with rclone config, i went back to omv to test run the scheduled task, and the results came out;

    "500 - Internal Server Error"

    And i am not sure what to do next. Any help will be much appreciated. Thank you for your time.