Posts by Wetter

    @Mr.President
    Da OMV das ganze über die Weboberfläche steuert, musst du dort auf System -> Netzwerk -> Schnittstellen -> deine Lankarte (eth0) bearbeiten. Weiter unten unter "DNS Server" trägst du die IP deines Routers oder ein DNS aus dem Internet ein (Google DNS or whatever). Danach sollte es flutschen. Manuell per Console ändern ist bei OMV nicht immer zu empfehlen. ^^"


    Falls die Netzwerkkarte auf DHCP steht, solltest du in deinen Router/DHCP Server nachschauen welche DNS Config er da durchgibt... - denn so hätte der Fehler nicht vorkommen sollen.

    Sorry, but english is not my main language.


    Also ich denke die Diskussion sollte man ein wenig einschränken, da es hier große Verständnisprobleme gibt.


    1nvader will halt irgendwie seine Daten an 2 verschiedene Standorte plus Sicherung haben. Da Windows nunmal nur mit NTFS oder Fat oder exfat klar kommt, ergaben für ihn ZFS & Co überhaupt keinen Sinn - zumindest wenn nicht klar ist, mit welchen Konzept er an besten verfahren kann. Statt auf die Definition eines NAS und das ganze drum herum zu reiten, sollte man die Sachen abkürzen und erstmal erläutern, wie 1nvader an besten arbeiten kann.


    Nextcloud ist zwar ne nette Idee, aber am Punkt Internet happert es doch schon. In Deutschland gibst nunmal keine 100mbit Upload Leitungen für Lau, daher dürfte späteten beim Hochladen eines 10GB Filmes sehr schnell viel Frust aufkommen.


    Seine bisherige Idee von einen Mirror Raid pro Standort plus manuelles updaten mit einen 5. Laufwerk sind ja ganz nett, aber da reicht auch nen Windows mit ein passenden Syncro Programm dafür. Windows kann das sogar selber, wenn man weiß wie (Robocopy)


    Nur da er hauptsächlich Programmierer ist und kein PC Spezi, sollte man nun einschränken inwiefern welche Möglichkeiten für ihn noch offen stehen. Ganz ehrlich: OMV halte ich derzeit für nicht geeignet, da man wirklich schon relativ viel mit Linux beschäftigen musst. Das ist nix für Anfänger. Zumindest bist OMV 3.0 mal "Stable" wird *hust*.


    Um welche Datenmengen sprechen wir hier? Und wieviel Daten würden pro "Standort Transfer" miteinander synchronisiert und gebackuped werden müssen?

    I am having a hard time keeping up with the changes and no one else is helping...

    Year, because i think for the most plugin writer it is very frustrating to keep up the plugins on an Vulnerable and heavy update needed system.
    i dont know what debian is thinking of his Jessie system or what Volker thinking about but i dont think the currently way of omv is going to be good. And if you see in the forum how much peoble report problems after new updates releases or instable plugins or how much time have to be invested for fixes over the consoles... How should beginners feel comfortable with this? This can't be good!

    Pretty sure you are having this issue because of this - Could not fetch a matching mount point w/ mergerfs w/ new OMV mounting points

    I dont understand why omv release a new version meanwhile the plugins are not compatibel to this. (And its now one week later ahead!)
    This is quite frustrating if you have to constantly patch afterwards rather than expect a stable system.


    I wish you guys come to a point of stable system with all plugins what can be use for and than you all go to a holiday. Because this constant cat and mouse game between ovm updates and plugin updates destroys omv long term and I do not like these thoughts. Constantly fixing this afterwards can not be sense of the thing

    Hi, @ryecoaaron


    Edit: After found this post, the issue has solved Virtualbox 5.1.8 and kernel 4.9 error


    ----
    After update to 3.0.65, virtualbox doesnt start anymore.


    Code
    Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; systemctl start virtualbox-web 2>&1' with exit code '1': A dependency job for virtualbox-web.service failed. See 'journalctl -xn' for details.
    Fehler #0:exception 'OMV\ExecException' with message 'Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; systemctl start virtualbox-web 2>&1' with exit code '1': A dependency job for virtualbox-web.service failed. See 'journalctl -xn' for details.' in /usr/share/php/openmediavault/system/process.inc:175Stack trace:#0 /usr/share/php/openmediavault/system/systemctl.inc(83): OMV\System\Process->execute(Array, 1)#1 /usr/share/php/openmediavault/system/systemctl.inc(101): OMV\System\SystemCtl->exec('start', NULL, false)#2 /usr/share/openmediavault/engined/module/virtualbox.inc(107): OMV\System\SystemCtl->enable(true)#3 /usr/share/openmediavault/engined/rpc/config.inc(189): OMV\Engined\Module\VirtualBox->startService()#4 [internal function]: OMVRpcServiceConfig->applyChanges(Array, Array)#5 /usr/share/php/openmediavault/rpc/serviceabstract.inc(124): call_user_func_array(Array, Array)#6 /usr/share/php/openmediavault/rpc/serviceabstract.inc(150): OMV\Rpc\ServiceAbstract->callMethod('applyChanges', Array, Array)#7 /usr/share/php/openmediavault/rpc/serviceabstract.inc(528): OMV\Rpc\ServiceAbstract->OMV\Rpc\{closure}('/tmp/bgstatusrn...', '/tmp/bgoutputzO...')#8 /usr/share/php/openmediavault/rpc/serviceabstract.inc(151): OMV\Rpc\ServiceAbstract->execBgProc(Object(Closure))#9 /usr/share/openmediavault/engined/rpc/config.inc(208): OMV\Rpc\ServiceAbstract->callMethodBg('applyChanges', Array, Array)#10 [internal function]: OMVRpcServiceConfig->applyChangesBg(Array, Array)#11 /usr/share/php/openmediavault/rpc/serviceabstract.inc(124): call_user_func_array(Array, Array)#12 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('applyChangesBg', Array, Array)#13 /usr/sbin/omv-engined(536): OMV\Rpc\Rpc::call('Config', 'applyChangesBg', Array, Array, 1)#14 {main}


    After try ...



    what now?

    If you have the configure: error: libdcadec not found


    you must try

    Code
    make -C tools/depends/target/libdcadec PREFIX=/usr/local

    and after that start

    • ./configure
    • make
    • make install

    again.
    "configure" & "make" must running throug without error!

    If i added a zfs pool to my union system this error comes:


    Code
    Could not fetch a matching mount point from the provided fsname: 'media/85b917c0-a89f-4bdc-90a4-fa82b16690c7:media/5763287c-c94f-409f-bb39-b0f84c36b6a2:media/24e79b44-2a20-4c27-a72f-7bf8af000114:media/0ae57b04-dd68-470b-b433-bcdb56e4885b:pool1'.


    Code
    Fehler #0:exception 'OMV\Exception' with message 'Could not fetch a matching mount point from the provided fsname: 'media/85b917c0-a89f-4bdc-90a4-fa82b16690c7:media/5763287c-c94f-409f-bb39-b0f84c36b6a2:media/24e79b44-2a20-4c27-a72f-7bf8af000114:media/0ae57b04-dd68-470b-b433-bcdb56e4885b:pool1'.' in /usr/share/php/openmediavault/system/filesystem/backend/mergerfs.inc:111Stack trace:#0 /usr/share/php/openmediavault/system/filesystem/backend/mergerfs.inc(55): OMV\System\Filesystem\Backend\Mergerfs::fetchMountPointFromFstabByFsnameAndType('media/85b917c0-...', 'fuse.mergerfs')#1 /usr/share/php/openmediavault/system/filesystem/filesystem.inc(885): OMV\System\Filesystem\Backend\Mergerfs->getImpl('media/85b917c0-...')#2 /usr/share/openmediavault/engined/rpc/sharemgmt.inc(156): OMV\System\Filesystem\Filesystem::getImplByMountPoint('/media/d0bd8987...')#3 [internal function]: OMVRpcServiceShareMgmt->enumerateSharedFolders(Array, Array)#4 /usr/share/php/openmediavault/rpc/serviceabstract.inc(124): call_user_func_array(Array, Array)#5 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('enumerateShared...', Array, Array)#6 /usr/sbin/omv-engined(522): OMV\Rpc\Rpc::call('ShareMgmt', 'enumerateShared...', Array, Array, 1)#7 {main}


    pool1 = zfs pool


    What can i do?


    More information:

    Thanks. tftp running well. My "Test" will show up.


    Now i am happy :D


    Again for the other user here:
    my "extra" entry on dsmasq is:

    Code
    dhcp-range=192.168.0.0,proxy
    pxe-service=x86PC,"PXE Boot-Server",pxelinux

    If anyone try to compile kodi on omv3 from this guide: [GUIDE] Kodi 17 on OMV3


    i wasn able to use

    Code
    ./bootstrap
    ./configure
    make
    make install


    My solution was to git Krypton.

    Code
    git clone -b Krypton git://github.com/xbmc/xbmc.git kodi

    Now i was able to compile kodi succesfully.


    If you have trouble on ./configure about "libdcadec" so try this and start ./configure again


    Code
    make -C tools/depends/target/libdcadec PREFIX=/usr/local

    I see you discusion here and i have test dnsmasq plugin too.


    So the same problem with no dns with port 0 or without port 0.


    My solution was to remove line "resolv-file=/etc/resolv.conf". Now pxe will now find in my network.


    tftp has a ping timeout but without a pxe image (the pxe from omv-extras.org is offline) i can't test it.

    If i would download one of the images from the pxe plugin (for omv 3.0)
    this error come:


    Code
    Installing package ...
    converted 'http://pxe.omv-extras.org/package' (ANSI_X3.4-1968) -> 'http://pxe.omv-extras.org/package' (UTF-8)
    --2017-01-06 15:00:17-- http://pxe.omv-extras.org/package
    Resolving pxe.omv-extras.org (pxe.omv-extras.org)... 78.46.103.117
    Connecting to pxe.omv-extras.org (pxe.omv-extras.org)|78.46.103.117|:80... connected.
    HTTP request sent, awaiting response... 404 Not Found
    2017-01-06 15:00:17 ERROR 404: Not Found.


    When i open http://pxe.omv-extras.org/package with a browser, he said: "
    Not Found
    The requested URL /package was not found on this server."


    Can anyone fix this plz?

    After vm test and a new try with omv is running now. I think the first sequence install of plugins going wrong and i have testet one time the proxmox kernel. i read here later the kernel is not ready to use. to late for me ^^. many erros and problems with booting came at this point.
    anyway now is all fine.


    my feedback to the "old" dnsmasq plugin is: was running very well with pxe & Co. ^^