Posts by mikebetz42

    The service works fine if I turn it off and back on after a reboot... I am thinking it's starting up before the driver(s) is loaded. It's using SNMP to connect to the UPS. The log is attached.



    Jan 14 17:03:45 valhalla upsmon[1864]: Poll UPS [ups@localhost] failed - Driver not connected
    Jan 14 17:03:50 valhalla upsmon[1864]: Signal 15: exiting
    Jan 14 17:03:50 valhalla upsd[1861]: User monmaster@127.0.0.1 logged out from UPS [ups]
    Jan 14 17:03:50 valhalla upsd[1861]: mainloop: Interrupted system call
    Jan 14 17:03:50 valhalla upsd[1861]: Signal 15: exiting
    Jan 14 17:04:07 valhalla upsd[6666]: fopen /var/run/nut/upsd.pid: No such file or directory
    Jan 14 17:04:07 valhalla upsd[6666]: listening on 127.0.0.1 port 3493
    Jan 14 17:04:07 valhalla upsd[6666]: listening on 127.0.0.1 port 3493
    Jan 14 17:04:07 valhalla upsd[6666]: Connected to UPS [ups]: snmp-ups-ups
    Jan 14 17:04:07 valhalla upsd[6666]: Connected to UPS [ups]: snmp-ups-ups
    Jan 14 17:04:07 valhalla upsd[6667]: Startup successful
    Jan 14 17:04:08 valhalla upsmon[6670]: fopen /var/run/nut/upsmon.pid: No such file or directory
    Jan 14 17:04:08 valhalla upsmon[6670]: UPS: ups@localhost (master) (power value 1)
    Jan 14 17:04:08 valhalla upsmon[6670]: Using power down flag file /etc/killpower
    Jan 14 17:04:08 valhalla upsmon[6671]: Startup successful
    Jan 14 17:04:08 valhalla upsmon[6672]: Init SSL without certificate database
    Jan 14 17:04:08 valhalla upsd[6667]: User monmaster@127.0.0.1 logged into UPS [ups]

    Files

    • nut.zip

      (4.33 kB, downloaded 44 times, last: )

    Persistent data


    All data beyond what lives in the database (file uploads, etc) is stored within the default volume /var/www/html. With this volume, ownCloud will only be updated when the file version.php is not present.

    • -v /<mydatalocation>:/var/www/html

    For fine grained data persistence, you can use 3 volumes, as shown below.

    • -v /<mydatalocation>/apps:/var/www/html/apps installed / modified apps
    • -v /<mydatalocation>/config:/var/www/html/config local configuration
    • -v /<mydatalocation>/data:/var/www/html/data the actual data of your ownCloud



    Did you use the full path???


    /srv/dev-disk-by-label/ownclouddata


    So with Docker, after struggling with it for hours I finally got it to work.


    No videos would stream "transcode errors" - removed "noexec" from fstab on media and database drives - solved that problem
    Hauppage Quad TV Tuner wouldn't show up - had to add "--device=/dev/dvb/" - solved that problem


    It's working again, but what a pain in the ass it was.


    -Mike

    Can't seem to install Plex....


    Anyone have a working DISTCC setup?


    I wanted to use my NAS servers power to help compile other source on a client, but I haven't had nay luck getting it working.


    Thanks,


    -Mike

    Any RAID array will use the lowest drive size across the array.


    With a RAID array you would want x amount of not only the same size drive, but the same model as well for all drives in the array.

    I'm having the same issue, I do not believe all of the plugins I need exist on OMV4 yet.


    Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; echo '-bond0' > /sys/class/net/bonding_masters 2>&1' with exit code '2':


    Error #0:exception 'OMV\ExecException' with message 'Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; echo '-bond0' > /sys/class/net/bonding_masters 2>&1' with exit code '2': ' in /usr/share/php/openmediavault/system/process.inc:175Stack trace:#0 /usr/share/php/openmediavault/engine/module/moduleabstract.inc(75): OMV\System\Process->execute(Array, 2)#1 /usr/share/openmediavault/engined/module/interfaces.inc(76): OMV\Engine\Module\ModuleAbstract->exec('echo '-bond0' >...')#2 [internal function]: OMVModuleInterfaces->deleteBondInterface(Array)#3 /usr/share/php/openmediavault/engine/module/moduleabstract.inc(146): call_user_func_array(Array, Array)#4 /usr/share/openmediavault/engined/module/interfaces.inc(52): OMV\Engine\Module\ModuleAbstract->execTasks('delete')#5 /usr/share/openmediavault/engined/rpc/config.inc(152): OMVModuleInterfaces->stopService()#6 [internal function]: OMVRpcServiceConfig->applyChanges(Array, Array)#7 /usr/share/php/openmediavault/rpc/serviceabstract.inc(124): call_user_func_array(Array, Array)#8 /usr/share/php/openmediavault/rpc/serviceabstract.inc(150): OMV\Rpc\ServiceAbstract->callMethod('applyChanges', Array, Array)#9 /usr/share/php/openmediavault/rpc/serviceabstract.inc(528): OMV\Rpc\ServiceAbstract->OMV\Rpc\{closure}('/tmp/bgstatus0J...', '/tmp/bgoutputeI...')#10 /usr/share/php/openmediavault/rpc/serviceabstract.inc(151): OMV\Rpc\ServiceAbstract->execBgProc(Object(Closure))#11 /usr/share/openmediavault/engined/rpc/config.inc(213): OMV\Rpc\ServiceAbstract->callMethodBg('applyChanges', Array, Array)#12 [internal function]: OMVRpcServiceConfig->applyChangesBg(Array, Array)#13 /usr/share/php/openmediavault/rpc/serviceabstract.inc(124): call_user_func_array(Array, Array)#14 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('applyChangesBg', Array, Array)#15 /usr/sbin/omv-engined(536): OMV\Rpc\Rpc::call('Config', 'applyChangesBg', Array, Array, 1)#16 {main}


    Changing "secure" in extra options to "insecure" did it for me. I am able to connect to the share from Kodi on everything from a CU-Boxi, Pi3, PC, Android, etc....



    I can't save a configuration, it fails to apply changes, so I had to edit /etc/network/interfaces to get back up and running.


    auto lo
    iface lo inet loopback


    auto eth0
    iface eth0 inet static
    address 192.168.10.20
    netmask 255.255.255.0
    gateway 192.168.10.1
    dns-nameservers 192.168.10.1



    # ip addr flush dev bond0
    Device "bond0" does not exist.


    # echo "-bond0" > /sys/class/net/bonding_masters
    -bash: /sys/class/net/bonding_masters: Permission denied



    # ifconfig bond0
    bond0: error fetching interface information: Device not found


    # rmmod bonding
    rmmod: ERROR: Module bonding is not currently loaded




    Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; echo '-bond0' > /sys/class/net/bonding_masters 2>&1' with exit code '2':


    Error #0:exception 'OMV\ExecException' with message 'Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; echo '-bond0' > /sys/class/net/bonding_masters 2>&1' with exit code '2': ' in /usr/share/php/openmediavault/system/process.inc:175Stack trace:#0 /usr/share/php/openmediavault/engine/module/moduleabstract.inc(75): OMV\System\Process->execute(Array, 2)#1 /usr/share/openmediavault/engined/module/interfaces.inc(76): OMV\Engine\Module\ModuleAbstract->exec('echo '-bond0' >...')#2 [internal function]: OMVModuleInterfaces->deleteBondInterface(Array)#3 /usr/share/php/openmediavault/engine/module/moduleabstract.inc(146): call_user_func_array(Array, Array)#4 /usr/share/openmediavault/engined/module/interfaces.inc(52): OMV\Engine\Module\ModuleAbstract->execTasks('delete')#5 /usr/share/openmediavault/engined/rpc/config.inc(152): OMVModuleInterfaces->stopService()#6 [internal function]: OMVRpcServiceConfig->applyChanges(Array, Array)#7 /usr/share/php/openmediavault/rpc/serviceabstract.inc(124): call_user_func_array(Array, Array)#8 /usr/share/php/openmediavault/rpc/serviceabstract.inc(150): OMV\Rpc\ServiceAbstract->callMethod('applyChanges', Array, Array)#9 /usr/share/php/openmediavault/rpc/serviceabstract.inc(528): OMV\Rpc\ServiceAbstract->OMV\Rpc\{closure}('/tmp/bgstatusg8...', '/tmp/bgoutputEt...')#10 /usr/share/php/openmediavault/rpc/serviceabstract.inc(151): OMV\Rpc\ServiceAbstract->execBgProc(Object(Closure))#11 /usr/share/openmediavault/engined/rpc/config.inc(213): OMV\Rpc\ServiceAbstract->callMethodBg('applyChanges', Array, Array)#12 [internal function]: OMVRpcServiceConfig->applyChangesBg(Array, Array)#13 /usr/share/php/openmediavault/rpc/serviceabstract.inc(124): call_user_func_array(Array, Array)#14 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('applyChangesBg', Array, Array)#15 /usr/sbin/omv-engined(536): OMV\Rpc\Rpc::call('Config', 'applyChangesBg', Array, Array, 1)#16 {main}