Posts by rolling

    Hi!


    After try some things i found the problem.

    I've activates hot-plug memory and cpu on Proxmox VE and not configured on OMV5.


    Also i try activate on OMV5 but i can't because required modules are not compiled.

    Here Proxmox VE requirements for future features if OMV developers want ;).


    -----------------------------------------------------------------------------------------------------------------------------------------------------

    Linux Guests notes

    kernel modules needed

    you need to have 2 modules loaded in your linux guest

    Code
    #modprobe acpiphp
    #modprobe pci_hotplug

    cpu && memory hotplug

    you need a recent kernel > 3.10

    and a udev rules, to auto enable cpus or memory hotplugged

    you can add a file:

    /lib/udev/rules.d/80-hotplug-cpu-mem.rules

    Code
    SUBSYSTEM=="cpu", ACTION=="add", TEST=="online", ATTR{online}=="0", ATTR{online}="1"
    SUBSYSTEM=="memory", ACTION=="add", TEST=="state", ATTR{state}=="offline", ATTR{state}="online"

    for linux kernel >= 4.7,

    you don't need the udev rule for memory hotplug, you only need to add this kernel parameter at boot:

    memhp_default_state=online


    -----------------------------------------------------------------------------------------------------------------------------------------------------


    Thank you for your work.


    Best regards.

    Hi!


    I've OMV5 fresh installation on Proxmox VE VM with 4Gb of ram assigned.

    The problem is that OMV5 only detects or run with 1Gb.


    I've changed the memory configuration on Proxmox VE but it don't show changes on OMV5.

    I've also tried disabling ballooning but it ir equal.


    ¿any suggestions to try?


    Regards.

    ok now i coment the line of this volume in fstab, and remove all smb shares ok. Only have this error trying remove nfs shares.


    any idea?


    regards.

    Hi:


    I lost a volume in a virtualization system, and i can´t umount and remove it, and old smb and nfs shares from GUI. When i try it only have errors.


    One example of error:


    "Error #3003:
    exception 'OMVException' with message 'Failed to get configuration (xpath=//system/fstab/mntent[uuid='7d81737e-120a-409a-9a84-cbf3c7324526'])' in /var/www/openmediavault/module/nfs.inc:95
    Stack trace:
    #0 [internal function]: NFSModule->preDeleteShare(Array)
    #1 /usr/share/php/openmediavault/notify.inc(123): call_user_func_array(Array, Array)
    #2 /var/www/openmediavault/rpc/nfs.inc(347): OMVNotifyDispatcher->notify(16, 'org.openmediava...', Array)
    #3 [internal function]: NFSRpc->deleteShare(Array)
    #4 /usr/share/php/openmediavault/rpc.inc(261): call_user_func_array(Array, Array)
    #5 /usr/share/php/openmediavault/rpc.inc(97): OMVRpc::exec('NFS', 'deleteShare', Array)
    #6 /var/www/openmediavault/rpc.php(44): OMVJsonRpcServer->handle()
    #7 {main}"


    Anybody know how can i clean it?


    Thks, best regards.