Posts by MichaGue

    The notification service of OMV sent me the following message:


    /etc/cron.daily/log2ram:ERROR: /var/log.hdd/ doesn't exist! Can't sync.run-parts: /etc/cron.daily/log2ram exited with return code 1


    Any ideas? Thanks.
    Michael

    Here is my configuration of /etc/network/interfaces:

    This is my network configuration:

    I am running a bananapi with armbian jessy. If I switch back to dhcp and sned a notification test mail the error is still the same? Using OMV 2.x everything works fine.


    Any ideas? Thank you.

    Yes, I am using gmx and I had no problems with OMV 2.x.


    looking at /etc/openmediavault/config.xml my "OMV_MAIL_primarymail" is my gmx adress. The log files shows me an email with xyz@localhost.localdomain which seems not to be accepted form gmx. Where can I change this inside OMV?


    Thanks a lot.

    Hello,


    I have a problem using the notifications. The following error occures by sending a testmail (beispiel@beispiel.de is just an example):



    --------------------
    postfix/smtp[2163]: BAF045ECF: to=<beispiel@beispiel.de>, relay=mail.gmx.net[212.227.17.190]:587, delay=0.79, delays=0.2/0.2/0.38/0.01, dsn=5.0.0, status=bounced (host mail.gmx.net[212.227.17.190] said: 550-Requested action not taken: mailbox unavailable 550 Sender address is not allowed. (in reply to MAIL FROM command)



    --------------------


    I am using my email as sender adress in the omv configuration. Is there somewhere another option where I can change the sender adress?


    Thanks a lot.
    Michael

    Hello,


    I am running a banana pi with armbian (Linux 4.6.3-sunxi (wheezy)) on a sd-card and installed omv 2.2.1. I also installed omv flash memory plugin. Looking at the notes of flash memory plugin fstab should be changed.

    Code
    Add noatime and nodiratime to root options. See before and after example lines:
    BEFORE:
    UUID=ccd327d4-a1ed-4fd2-b356-3b492c6f6c34 / ext4 errors=remount-ro 0 1
    AFTER:
    UUID=ccd327d4-a1ed-4fd2-b356-3b492c6f6c34 / ext4 noatime,nodiratime,errors=remount-ro 0 1
    Comment out the swap partition. See before and after example lines (only need to add a # to beginning of the line):
    BEFORE:
    UUID=a3c989d8-e12b-41d3-b021-098155d6b21b none swap sw 0 0
    AFTER:
    #UUID=a3c989d8-e12b-41d3-b021-098155d6b21b none swap sw 0 0


    Looking at may fstab, there are some differences:

    Code
    # UNCONFIGURED FSTAB FOR BASE SYSTEM
    /dev/mmcblk0p1 / ext4 noatime,nodiratime,discard,defaults,noatime,nodiratime,data=writeback,commit=600,errors=remount-ro 0 0
    /var/swap none swap sw 0 0
    tmpfs /tmp tmpfs defaults 0 0
    # >>> [openmediavault]
    UUID=eb9c1dd5-583b-4659-ba93-d521129cd07c /media/eb9c1dd5-583b-4659-ba93-d521129cd07c ext4 defaults,nofail,user_xattr,noexec,usrjquota=aquota.user,grpjquota$
    # <<< [openmediavault]
    • Do I have to change line 2 and 3 or line 6?
    • line 2 already shows the "noatime, nodiratime", but twice. Could I delete "noatime, nodiratime" once?
    • What else do I have to change?

    Thanks a lot.
    Michael

    Just so you know, this is the defaults options in OMV


    defaults,nofail,user_xattr,noexec,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0"


    So you have the options there disabled, like quota and xattr. You can do your research but i think the option bothering you is user_xattr, which is ACL, so you won't be able to use them.


    After mounting the drive with the shortened option for OMV OMV_FSTAB_MNTOPS_EXT4="defaults,nofail,noexec" I could totally remove the option from nano /etc/default/openmediavault or put the whole options in the command. After a reboot the drive is still mounted and writing/reading works. Why?

    same error here,i just modify the fstab(/etc/fstab) file,under # >>> [openmediavault],change the last number from 2 to 0.


    Your workaround does not work for me. I tried a new install from scratch. After getting the same error as above I modified the fstab like you, changing 2 to 0. Than I tried to mount the volume. Still the same error.



    After that, I looked again inside the fstab. The 0 was changed to 2 again.


    Any ideas? Thank you.

    umount /mnt



    nano /etc/defaults/openmediavault


    The file ist empty. After putting OMV_FSTAB_MNTOPS_EXT4="defaults,nofail,noexec" inside and trying to save the error is "noch such file or directory".


    With nano /etc/default/openmediavault I get



    At the end I put OMV_FSTAB_MNTOPS_EXT4="defaults,nofail,noexec" and then followed your instruction.


    Mounting worked without any error. After reboot, everything is still okay.


    After reboot everything is fine.


    Thanks a lot.
    Michael