Posts by nielspauli

    But rsync is only one-way, right? Do you solve that by having an rsync job on both NASes? I can't see how that would behave as a two-way sync.


    What about deletions of files? If a file is delete on NAS1 it may be restored by a backup rsync job running on NAS2?

    Thank you for the reply. I did read the guides (and a lot more), but I must have missed that privileges only covers a very limited set of services. This explains why it doesn't work.


    I have tried using ACL to grant access to btuser, and this works. However, I would like to avoid ACL based on several recommendations around here. chown/chmod is of course possible, but not something you would expect to be required for a NAS with a "simple and intuitive web based administration"


    I'm aware that btsync plugin uses version 1.4. But this is ok for me. However, if this plugin is being abandoned I may reconsider using it.


    My goal is a two-way sync to my QNAP NAS, so I'm limited by what is available on both OMV and QNAP. Syncthing does not appear to be available on the QNAP, unfortunately.


    Any suggestions for two-way NAS-2-NAS sync? I dont't need instant sync of changes. Actually, I would prefer a scheduled run.

    I'm trying to setup btsync, but having problems with the privileges for btuser.


    When adding a location to btsync, the dialog states: The location needs to have read/write permissions for the user/group btsync


    I did the following:


    1) I created a group called 'Mygroup'
    2) Added myself and btuser to the group
    3) Gave the group read/write permission to the location/share I'm trying to add to btsync


    This works for giving me access to the folder using SMB. However, adding a location to btsync fails with the message: Btsync request failed with code 101 and the message 'Don't have permissions to write to the selected folder.'

    I think I have a gap in my understanding of OMV/Linux privileges, but I have been unable to find any good source of information about it.


    I noticed the following in the dialog for setting shared folder privileges for a group: These settings are used by the services to configure the user access rights. Please note that these settings have no effect on file system permissions. I'm thinking that this should also work for the btsync service and the btuser user. But apparently it does not. What am I missing?


    The question then remains, how do I set the privileges for btuser?

    This is because of:


    197 Current_Pending_Sector -O--CK 200 200 000 - 1


    Current Pending Sector Count S.M.A.R.T. parameter is a critical parameter and indicates the current count of unstable sectors (waiting for remapping). The raw value of this attribute indicates the total number of sectors waiting for remapping. Later, when some of these sectors are read successfully, the value is decreased. If errors still occur when reading some sector, the hard drive will try to restore the data, transfer it to the reserved disk area (spare area) and mark this sector as remapped.


    https://kb.acronis.com/content/9133

    Ok. Enabling the switch in privileges solved the problem. Thanks a lot. +1


    Still, I think this was very confusing. I never suspected rights management to be the problem since it was working with SMB. Further, I don't use ACL. I also think there is a lot of steps involved. Why do you need to set rights pr. user when that user is member of a group which has the access ('users' group).


    Is there a better way to manage rights. I know the 'users' group is a system group. Will it be simpler if I create a group of my own and put the users there?

    Eh. Can't insert an image here, so you get a description.


    I click Access Rights Management -> Shared folders. Select the folder and click Privileges. This brings up a dialog which shows the user and three columns: Read/Write, Read-only and No access. All are off for the user.


    This is stange. When I create the folder I get the option set set the permissions and I choose one where 'users' group has read/write access. Thus, shouldn't all users have read/write access to the folder? It certainly works for SMB share, why not FTP?


    Whats the fix here? Its not very intuitive to set access rights for the user when the group allready has access.

    I turned the mentioned option off, but it made no difference. I did not expect it to either, since I AM able to login. I just don't see any shared folders.


    I don't see my user name in the conf file. Could this be the problem?:


    Include /etc/proftpd/modules.conf
    LoadModule mod_vroot.c
    UseIPv6 on
    ServerName "OMV"
    ServerType standalone
    DeferWelcome on
    MultilineRFC2228 on
    DefaultServer on
    ShowSymlinks on
    DisplayChdir .message true
    ListOptions "-l"
    MaxInstances 30
    DenyFilter \*.*/
    AuthPAMConfig proftpd
    User proftpd
    Group nogroup
    Umask 000 000
    PersistentPasswd off
    TimesGMT off
    AllowOverwrite on
    AuthOrder mod_auth_pam.c* mod_auth_unix.c
    DefaultTransferMode ascii
    #SystemLog /var/log/proftpd/proftpd.log
    <IfModule mod_facl.c>
    FACLEngine on
    </IfModule>
    <IfModule mod_quotatab.c>
    QuotaEngine off
    </IfModule>
    <IfModule mod_ratio.c>
    Ratios off
    </IfModule>
    <IfModule mod_delay.c>
    DelayEngine on
    </IfModule>
    <IfModule mod_ctrls.c>
    ControlsEngine on
    ControlsMaxClients 2
    ControlsLog /var/log/proftpd/controls.log
    ControlsInterval 5
    ControlsSocket /var/run/proftpd/proftpd.sock
    </IfModule>
    <IfModule mod_ctrls_admin.c>
    AdminControlsEngine off
    </IfModule>
    <IfModule mod_vroot.c>
    VRootEngine on
    VRootLog /var/log/proftpd/vroot.log
    </IfModule>
    Port 21
    TransferLog NONE
    IdentLookups off
    UseReverseDNS off
    TimeoutIdle 1200
    TimeoutNoTransfer 600
    TimeoutStalled 600
    DeleteAbortedStores off
    <Directory />
    HideFiles (welcome.msg)
    </Directory>
    <Anonymous ~ftp>
    User ftp
    Group nogroup
    UserAlias anonymous ftp
    DirFakeUser on ftp
    DirFakeGroup on ftp
    RequireValidShell off
    <Directory *>
    HideFiles (welcome.msg)
    HideNoAccess on
    <Limit WRITE>
    DenyAll
    </Limit>
    </Directory>
    </Anonymous>


    <IfModule mod_vroot.c>
    VRootAlias "/media/13a2d70c-eb6b-4e49-b3fe-682f573d5894/Video" "Video"
    </IfModule>
    <Directory /Video>
    <Limit ALL>
    AllowUser OR root
    AllowGroup OR root
    DenyAll
    </Limit>
    <Limit READ DIRS>
    AllowUser OR root
    AllowGroup OR root
    DenyAll
    </Limit>
    </Directory>
    <IfModule mod_auth.c>
    DefaultRoot /srv/ftp
    MaxClients 5
    MaxLoginAttempts 98
    RequireValidShell off
    RootLogin on
    # This option is useless because this is handled via the PAM
    # pam_listfile.so module, so set it to 'off' by default.
    UseFtpUsers off
    </ifModule>


    <IfModule mod_ban.c>
    BanEngine off
    BanControlsACLs all allow user root
    BanLog /var/log/proftpd/ban.log
    BanMessage Host %a has been banned
    BanTable /var/run/proftpd/ban.tab
    </ifModule>


    DisplayLogin /srv/ftp/welcome.msg
    <IfModule mod_wrap.c>
    TCPAccessFiles /etc/hosts.allow /etc/hosts.deny
    TCPAccessSyslogLevels info warn
    TCPServiceName ftpd
    </ifModule>

    The user has access to the folder and it works with SMB from a PC. As far as I can tell there are no specific rights for FTP. I only have the option to add the share for FTP. I did this, and it works but only if I login as root or anonymous.

    I'm having trouble setting up FTP.


    First of all, in the beginning I could not log in at all - access denied. I figured out that the user name is case sensitive. I don't recall that I ever has needed to supply an FTP user name in the correct case. Is this intended behavior?


    After a successful login, I can not see any shared folders at all. I have added the shares to FTP, and I'm able to see them if I login using root or anonymous. So why can't a regular user see the share?


    The folder is also an SMB share and I can access the share this way without problems.


    I'm running OMV 2.1.27 with all updates installed.

    Thank you for your suggestions, however, as I said: All the drives are empty, and I'm certain I don't have anything accessing the drives which can keep them active.


    Anyway, it seems that the WD Green drives has a life of their own. Just recently, the problematic drive started to spin-down after 10 min. What caused this is unknown.

    I know how to set the disc properties via the GUI. Using hdparm is just another way of doing it and makes it possible to set values and change things you can't from the GUI. Anyway, it does not explain why my two 1TB drives behaves differently with the same settings.


    Did you try hdparm -B on you EARX drive? I don't think any of the Green drives support APM. Further, Have you tried any other time than 10 minutes? My WD15EADS spin down in 10 min. regardless of what time is set with hdparm -S or disc properties.

    I was under the impression the the size of tmpfs was allocated in RAM all at once, and thus not available for others. However, the GUI shows way more than 50% free. tmpfs does not appear to work as I think it does. Admitted, I am a linux newbie.


    df-h shows several folder2ram filesystems. Each 1G (I have 2GB RAM). Can each of these grow to 1GB?
    There are also several tmpfs filesystems.


    df -h does not make a lot of sense to me:


    Filesystem Size Used Avail Use% Mounted on
    rootfs 29G 1.1G 26G 4% /
    udev 10M 0 10M 0% /dev
    tmpfs 201M 540K 200M 1% /run
    /dev/disk/by-uuid/4a9eee14-1d76-42a6-a928-ac04e1220a94 29G 1.1G 26G 4% /
    tmpfs 5.0M 0 5.0M 0% /run/lock
    tmpfs 401M 0 401M 0% /run/shm
    /dev/sdb1 917G 205M 917G 1% /media/c4943c3b-70f1-4861-902c-e2df1101bca6
    /dev/disk/by-uuid/4a9eee14-1d76-42a6-a928-ac04e1220a94 29G 1.1G 26G 4% /var/folder2ram/var/lib/monit
    /dev/disk/by-uuid/4a9eee14-1d76-42a6-a928-ac04e1220a94 29G 1.1G 26G 4% /var/folder2ram/var/lib/rrdcached
    /dev/disk/by-uuid/4a9eee14-1d76-42a6-a928-ac04e1220a94 29G 1.1G 26G 4% /var/folder2ram/var/lib/openmediavault/rrd
    /dev/disk/by-uuid/4a9eee14-1d76-42a6-a928-ac04e1220a94 29G 1.1G 26G 4% /var/folder2ram/var/lib/php5
    /dev/disk/by-uuid/4a9eee14-1d76-42a6-a928-ac04e1220a94 29G 1.1G 26G 4% /var/folder2ram/var/spool
    /dev/disk/by-uuid/4a9eee14-1d76-42a6-a928-ac04e1220a94 29G 1.1G 26G 4% /var/folder2ram/var/log
    folder2ram 1002M 8.0K 1002M 1% /var/lib/monit
    folder2ram 1002M 4.0K 1002M 1% /var/lib/php5
    folder2ram 1002M 16K 1002M 1% /var/spool
    folder2ram 1002M 568K 1002M 1% /var/lib/openmediavault/rrd
    folder2ram 1002M 24M 979M 3% /var/lib/rrdcached
    folder2ram 1002M 24M 979M 3% /var/log
    /dev/disk/by-uuid/4a9eee14-1d76-42a6-a928-ac04e1220a94 29G 1.1G 26G 4% /var/folder2ram/var/tmp
    folder2ram 1002M 0 1002M 0% /var/tmp

    There have been written a lot about WD Green Caviar and Standby / spin-down. But I still have not been able to figure this out.


    I have 3 WD Green drives:
    WD15EADS - 1.5TB 32MB Cache - Firmware 01.00A01
    WD10EACS - 1.0TB 16MB Cache - Firmware 01.01A01
    WD10EAVS - 1.0TB 8MB Cache - Firmware 01.01A01


    All drives spin down immediately with the hdparm -Y command.
    All drives does not behave as expected using the hdparm -S command to set the spin down time. I found in this post, that hdparm -S 3 could work.


    For the WD15EADS, hdparm -S 3 /dev/sdx, makes the drive spin down after 10 min. (The expected behavior would be 15 seconds)
    For the WD10EAVS, hdparm -S 3 /dev/sdx, makes the drive spin down after about 15-20 min. (Haven't timed it accurately, but it works consistently)


    However, the WD10EACS does not spin down at all. What can cause this? The WD10EACS only differs from the WD10EAVS by the amount of cache. It even has the same firmware revision.


    All the drives are empty, and I'm certain I don't have anything accessing the drives which can keep them active.


    BTW: For all drives the dreaded idle3 timer is disabled.
    Apparently none of the drives support Advanced Power Management (hdparm -B /dev/sdx gives APM_level = not supported)

    It will disable the pretty usage graphs of cpu and stuff you can see (but most don't know-need-use), that is basically the only source of writes that can worry you


    I do care about statistics, and those pretty graphs are actually the ones I don't want to loose in case of a power failure.


    Another question that comes to my mind. I'm a total Linux newbie, but as far as I understand folder2ram is uses tmpfs which has a fixed size. So, how big is this 'ram-drive' that is created, and what happens if the log files (and whatever else is stored there) grows bigger than that?