Posts by KeremE

    Thank you. Although I was hoping for a solution/workaround for this type of problem. This is definitely the answer about the capability of the product at hand.

    guest account = nobody is already set in the smb.conf for omv. Setting restrict anonymous would break the feature that some people want so shares can be accessed by anonymous users. Will it affect your setup? Try it.

    Thank you this is the answer I was looking for. I mean would it break anything for the operation.. I'll try and see :-)

    Hi,


    I have, lets say, twp different CIFS volumes. I want to access these volumes from another windows host. I want one volume to have Read-Write and the second volume to have read only access to two different volumes. But windows system could only have one username/password pair for a single host. In commercial NAS systems they have a "Virtual CIFS Server" facilty. In that they create another virtual host with a different IP and assign the second volume to this new host. So that When I add a Drive Mapping to this volume I can enter different credentials. How does OMV support this ?


    Best Regards,
    Kerem E.

    Hi,


    I am using a AMV 3 server where I have several CIFS Volumes. we're auditing out resources for vulnerabilties. In one of the Vulnerability Audits we've been reported that our OMV server is vulnerable to "CIFS NULL Session". So we were suggested to add these lines in OMV settings:


    Samba on Linux
    Restrict anonymous access
    To restrict anonymous access to Samba, modify your "smb.conf" settings as follows:


    guest account = nobody
    restrict anonymous = 1


    Note: Make sure you do NOT list a user "nobody" in your password file.


    Do you think there would be no side effects so that shares are not accessible to network users etc. ?


    Best Regards,
    Kerem E.

    Hi,


    I had the same issue. My USB drive is located at /dev/sdh. Install goes fine but when it tries to install GRUB the install displays "grub-install /dev/sda" and then it say the installation has failed. So it seems that grub istal defaults to /dev/sda which prevents it to install any other drive. I think it should be fixed. This being said here's how I circumvent this:


    - I installed LILO instead since grub fails.
    - I've completed the isntallatin and reboot.
    - After the reboot I've run these commands:
    - update-grub
    - grub-install /dev/sdh


    Reboot and voila it now boots to GRUB.


    If you end up with "grub>" prompt then you can use this guide here:
    https://www.linux.com/learn/tu…-booting-grub-2-on-linux/


    and once you've reboot with grub commands you can repeat update-grub and grub install phase.


    Cheers,
    K.