Posts by DanieleU.

    To find what?
    The configpage for the namebased servers or the folder for your namebased servers?
    The folders you must create separately.
    I created for each namebased server a separate folder like so:


    /var/www/vhosts/name.based1.tld
    /var/www/vhosts/name.based2.tld


    and so on.


    You can create it as subfolder in /var/www/openmediavault too.
    Don't forget to chown www-data:www-data the (sub)folders e.g. you will use next-/owncloud.


    For the letsencrypt-plugin you must then create a entry for each domain in the domains section.


    So i hope this will help you.

    Stop stop. ^^
    Do you have vhosts?
    Is the name of the config-file in /etc/nginx/sites-enabled zz-omv-nginx?


    If yes, then open a cli via ssh or local on your mashine and type the command


    Code
    nginx_dissite zzz-omv-nginx
    or
    sudo nginx_dissite zzz-omv-nginx

    if you are not root.
    This disables your vhosts.


    After that, restart nginx with


    Code
    systemctl start nginx.service

    Now you should be able to oben your web interface.


    After login, you get an information for applying changes. Don't save that.


    I changed the port for the ssl web interface to 444, saved and applied the changes.
    You get a communication failure message after saving. Add :444 or whatever yout changed your ssl-port for the web interface and log in to your web interface.
    After that, you should be able to activate your vhosts over the webinterface.


    I hope this workes for you.
    It worked for me.


    But now, i say good night. Must go to bed.

    I disabled the vhosts over the cli with the command belo


    Code
    nginx_dissite zzz-omv-nginx

    and restartet nginx wit


    Code
    systemctl start nginx.service

    If you have vhosts, please look at /etc/nginx/sites-enabled, which name yours have, if it is enabled.
    That's what it looks like in my folder.

    Hello.


    I have a similar problem after upgrading to version 3.0.96.

    If I disable the virtual hosts and restart the nginx service, then the web interface works again.


    Code
    nginx_dissite zzz-omv-nginx
    systemctl start nginx.service

    If i change the web interface to e.g. Port 444, I can enable all virtual hosts again and the web interface is reachable.
    The vhosts are all set to use only ssl 443.


    What has changed, that this does not work anymore? :huh:

    .well-known is not the certfolder.
    This folder is generated by the certbot to look if the domain is available. A file is stored in this folder and deleted again to validate the address. That's how I understand that.


    Your certificates are stored under /etc/letsencrypt/...


    The folder you mean in the pluginsection is the folder, where your website is stored. E.g. /var/www/openmediavault or /var/www/vhosts/somthingelse.

    p.s. little offtopic: got a fritzbox - can i export the cert to import it into my fritzbox (fritzbox got option to import a cert) - so if i access my fritzbox with my dyndns i also no longer get the "cert issn't secure" warning from browser?

    For this I have made a script, which is executed once a month, fot creating a certificate for the Fritzbox and send it by email.

    After that, the certificate will be deleted from the /root directory.

    Apparently, Windows 10 Build 1709 deprecated SMB 1.0: https://social.technet.microso…orum=win10itpronetworking


    My PC's running older versions of Windows can continue to access my OMV's SMB shares without issue. The newer build PC's cannot.


    Is there a way to update my OMV to use SMB 2 or 3?

    Disabling smb1 in Windows-Features in Windows 10 1709 helped for me.

    Picture is in german. Sorry for that.


    After, now i can connect my shares.

    I changed the line 177 (missing one parentheses) on my running system but forgot to change it in the code which causes engined to not run. Fixed in 3.4.3. The following should get your systems fixed


    apt-get update
    apt-get install openmediavault-letsencrypt

    Oh. Sorry. I do not have seen your post.
    There was a missing ) on line 177?


    Now it works fine. Thank you.

    omv-engined -df shows:


    And posting in the Forum shows me

    Code
    Fatal error: An error occured. Sorry.
    Information:
    ID: 6e29caadbfdeb6b27683554b5473f8f088ba9afc
    Bitte teilen Sie dem Betreiber die oben stehende ID mit.
    Die Fehlermeldung kann mit dieser ID über „ACP » Protokoll » Fehler“ eingesehen werden.

    Hello hello.
    After updating omv-letsencrypt i can't log in to the webgui.
    This errormessage will be shown.

    Code
    Fehler #0:
    exception 'OMV\Rpc\Exception' with message 'Failed to connect to socket: Connection refused' in /usr/share/php/openmediavault/rpc/rpc.inc:140
    Stack trace:
    #0 /var/www/openmediavault/rpc/session.inc(56): OMV\Rpc\Rpc::call('UserMgmt', 'authUser', Array, Array, 2, true)
    #1 [internal function]: OMVRpcServiceSession->login(Array, Array)
    #2 /usr/share/php/openmediavault/rpc/serviceabstract.inc(124): call_user_func_array(Array, Array)
    #3 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('login', Array, Array)
    #4 /usr/share/php/openmediavault/rpc/proxy/json.inc(95): OMV\Rpc\Rpc::call('Session', 'login', Array, Array, 3)
    #5 /var/www/openmediavault/rpc.php(45): OMV\Rpc\Proxy\Json->handle()
    #6 {main}


    I've tried with
    omv-mkconf nginx
    omv-mkconf php-fpm
    systemctl restart nginx
    systemctl restart php5-fpm
    But the error still apears.


    This is the output of ls -al /var/www/openmediavault/js/omv/module/service/


    Is there a solution for this?